none
MMC Crashes when to launch Hyper-V, and other MMC add-ons after applying .NET Patches

    General discussion

  • I applied about 6 .NET Framework Patches on 6/17/2012 and now I am unable to open the Hyper-V Management Console, Components, Computer Management. If I just run MMC.EXE from Windows\System32 it at least launches. I uninstalled the patches but the problem stil exists. The exact errors are below:

    Description:
      Stopped working

    Problem signature:
      Problem Event Name: CLR20r3
      Problem Signature 01: mmc.exe
      Problem Signature 02: 6.1.7600.16385
      Problem Signature 03: 4a5bc808
      Problem Signature 04: MMCEx
      Problem Signature 05: 3.0.0.0
      Problem Signature 06: 4a5bda23
      Problem Signature 07: 832
      Problem Signature 08: 77
      Problem Signature 09: N3CTRYE2KN3C34SGL4ZQYRBFTE4M13NB
      OS Version: 6.1.7601.2.1.0.400.8
      Locale ID: 1033

    Read our privacy statement online:
      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

    If the online privacy statement is not available, please read our privacy statement offline:
      C:\Windows\system32\en-US\erofflps.txt


    FX:{18ea3f92-d6aa-41d9-a205-2023400c8fbb}
    Exception has been thrown by the target of an invocation.
    Exception Type: System.Reflection.TargetInvocationException

    Exception stack Trace
    at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck)
       at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache)
       at System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache)
       at System.Activator.CreateInstance(Type type, Boolean nonPublic)
       at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
       at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)
       at System.Activator.CreateInstance(String assemblyName, String typeName)
       at System.AppDomain.CreateInstanceAndUnwrap(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Internal.SnapInClient.CreateSnapIn(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Internal.ClassLibraryServices.Microsoft.ManagementConsole.Internal.IClassLibraryServices.CreateSnapIn(String assemblyName, String typeName)
       at Microsoft.ManagementConsole.Executive.SnapInInitializationOperation.OnStart()
       at Microsoft.ManagementConsole.Executive.RunningOperationsTable.EnqueueOperation(Operation operation)
       at Microsoft.ManagementConsole.Executive.StandAloneComponentData..ctor(SnapInRegistrationInfo info, Int32 bookkeepingId)
       at Microsoft.ManagementConsole.Advanced.FrameworkSnapInFactory.Microsoft.ManagementConsole.Advanced.ISnapInFactory.CreateSnapIn(Int32 bookkeepingId, String snapInKey, Object& snapIn)

     Any Ideas?


    David Baur

    Sunday, June 17, 2012 6:24 AM

All replies

  • I'm in similar situation. We updated the patches last weekend and MMC does not open up when we are trying to open Server Manager but  other machines who has similar patches are working fine. I guess the patches might not have installed properly. Let me repair the updates and will try. 

    Can you share the solution if you have fixed it already.

    Thanks


    -ravi

    Monday, June 18, 2012 1:28 PM
  • Ok. We reinstalled the updates and  it fixed  the problem.

    -ravi

    Friday, June 22, 2012 2:02 PM
  • Hi Ravi and David

    Could you share the specific KB updates pertaining to Microsoft .NET Framework  4 Client Profile as I applied some patches which resulted in the MMC and the application crashes. To make matters worse.. IE 9 also started crashing!!

    I am assuming these are the ones which need to be repaired  / re-installed 

    1. Microsoft Visual C++ 2010 x64 Redistributable - 10.0.30319

    2. Microsoft Visual Studio 2010 Shell (Isolated) - ENU - 10.0.40219

    Appreciate your inputs.

    Farhan

    Sunday, July 1, 2012 11:46 AM
  • Had the same issue and after uninstalling kb2686831 it worked again

    In elevated cmd screen typ:

    wusa.exe /uninstall /kb:2686831

    Wednesday, July 4, 2012 3:58 PM
  • Had the same issue and after uninstalling kb2686831 it worked again

    In elevated cmd screen typ:

    wusa.exe /uninstall /kb:2686831

    Many thanks Tom! This working Perfectly!!! :D
    Friday, July 6, 2012 3:44 PM
  • Had the same issue and after uninstalling kb2686831 it worked again

    In elevated cmd screen typ:

    wusa.exe /uninstall /kb:2686831

    Many thanks Tom! This working Perfectly!!! :D

    I've got this same issue on several servers, and I can also confirm that uninstalling and reinstalling KB2686831, then rebooting will fix the issue with the MMC. 

    Is there a way to restore the MMC without the reboot?  I notice that this hotfix is a security hotfix for .NET Framework 3.5.1.  Is there a service (or series of services) that can be bounced (or another series of actions) to restore the MMC functionality? 

    Thanks!

    --BJ

    Wednesday, July 18, 2012 8:59 PM
  • KUDOS!!!!!

    Solved my problem!

    You are a hero.

    Monday, July 30, 2012 5:08 PM