none
scaling remote desktop display to larger size ("pixel doubling") ?

    Question

  • I'm displaying the console of various remote hosts using Remote Desktop on my 2560x1600 display, and they come out very small. I would like to enlarge the RDP windows and have the remote displays' pixels increased in size accordingly. Is this possible?

    I initially thought RDP smart sizing would take care of this but it seems this feature only supports making pixels smaller (scaling down, not up).

    Note that I want any configuration changes to be done to my local machine only. Changing text size, DPI, or any other desktop related setting on remote hosts is undesired as they are correctly setup when used in other contexts.

    Thanks
    Mike

    Sunday, April 14, 2013 11:59 AM

Answers

  • Hi Mike,

    I just checked on my Windows 7, and found the same registry that I mentioned in my previous post. HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics

    I found this article as following:

    You cannot change the DPI setting through a Remote Desktop session on a computer that is running Windows 7 or Windows Server 2008 R2

    http://support.microsoft.com/kb/2726399

    We can try this hotfix first and see if the behiavor can be changed.

    I also found the following article, we may be able to find a workaround for our Windows 7.

    Windows 2008 R2 SP1 Remote Desktop Services – DPI change issue

    http://frolovs.wordpress.com/2011/06/03/windows-2008-r2-sp1-remote-desktop-services-dpi-change-issue/

    Thank you


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 19, 2013 8:34 AM
  • Hi Mike,

    I asked our escalation engineer and just got his reply this morning. it seems we dont have other ways to configure for clients-Remote Desktop scaling remote desktop display to larger size. We apologize for the inconvenience.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 02, 2013 8:40 AM

All replies

  • Hi,

    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

    Thank you for your understanding and support.

    Best Regards,

    Aiden

    If you have any feedback on our support, please click here


    Aiden Cao
    TechNet Community Support

    Tuesday, April 16, 2013 2:30 AM
    Moderator
  • Thanks for looking into this, Aiden.
    Tuesday, April 16, 2013 7:37 PM
  • What is the RD system version are you using? Windows Server 2008 R2 or Windows Server 2008 ...

    If you system is Windows Server 2008, please try modicying: Control Panel > Ease of Access > Optimize Visual Display > Change the size of text and icons.

    If your system is Windows Server 2008 R2, this will not work, we have a workaround to change the font size is modifying the registry keys:

    The only option we've found is to configure the DPI settings as apropriate and export them from registry [HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics] and import on per-user basis with logon script.

    Please let me know if you have any other questions.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Wednesday, April 17, 2013 7:17 AM
  • I'm not using server-based Terminal Services, just logging in to desktops ("console") of other client machines. Currently both local and remote machines are Windows 7, upgrade to Windows 8 is forthcoming. In this environment the DPI setting of the local machine seems not to affect scaling of the Remote Desktop display. I've heard (but not tried myself) that the MacOS Remote Desktop client does upscaling, possibly because of their Retina displays.

    Do you have any other suggestions for Win 7/8?

    (Please advise if there is a more appropriate group for discussing questions about "client-based" Remote Desktop)

    Best regard
    Mike

    Wednesday, April 17, 2013 8:34 AM
  • Hi Mike,

    I just checked on my Windows 7, and found the same registry that I mentioned in my previous post. HKEY_CURRENT_USER\Control Panel\Desktop\WindowMetrics

    I found this article as following:

    You cannot change the DPI setting through a Remote Desktop session on a computer that is running Windows 7 or Windows Server 2008 R2

    http://support.microsoft.com/kb/2726399

    We can try this hotfix first and see if the behiavor can be changed.

    I also found the following article, we may be able to find a workaround for our Windows 7.

    Windows 2008 R2 SP1 Remote Desktop Services – DPI change issue

    http://frolovs.wordpress.com/2011/06/03/windows-2008-r2-sp1-remote-desktop-services-dpi-change-issue/

    Thank you


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 19, 2013 8:34 AM
  • Hi Mike,

    How are you?

    Could you please let me know if you have any upate regarding this issue?

    Thank you


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, April 23, 2013 8:17 AM
  • Thank you, Yanna, and sorry about the delay.

    As I wrote in my original post I would like to avoid solutions where I need to reconfigure console desktop settings on the remote host. The increased DPI on the remote host may be fine when displaying it on my high-res screen, but may be unsuitable for local use or for remote access from other machines. So it seems the workflow will be to always adjust the DPI after connecting with the RD client and possibly restoring it before disconnecting.

    So really I would like a solution where I can easily have the RD client scale up ("zoom") all connections made from the machine with the high-res screen. This could be done by being able to specify a magnification factor in the .rdp file, by having RD client by default always apply the local machine's DPI setting to remote displays, or by upscaling the remote display according to how large the RD client window is resized.

    As the latter is already in place for downscaling according to RD client window size ("smart sizing") I was hoping this could be enabled somehow for upscaling as well.

    I will keep looking for a solution that lets me achieve my goal without reconfiguring the remote machine. If that doesn't work out, I will have to resort to remote host reconfiguration, and then your tips here will be invaluable.

    Thanks, and best regards
    Mike

    Wednesday, April 24, 2013 1:17 PM
  • Hi Mike,

    Thanks for your update,

    I can understand your concerns. currently I need to do further research regarding this case. and I will let you know as soon as I can. Thank you


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, April 26, 2013 8:56 AM
  • Hi Mike,

    I asked our escalation engineer and just got his reply this morning. it seems we dont have other ways to configure for clients-Remote Desktop scaling remote desktop display to larger size. We apologize for the inconvenience.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, May 02, 2013 8:40 AM
  • I have been looking for this solution for a long time with no help whatsoever. What I did is eventually moved to a Mac with Retina screen and remote desktop upscales properly. The OSX clients seems to upscale everything properly. iTap is a good one and the new MS one is OK, although I think they just bought out iTap. 

    It is really sad, that in order to use MS RDP properly I have to use a Mac. But we don't have a choice as high DPI screens are going to become the norm soon. I did, however, try to use reg entries to disable DPIAWARE on RDP, but that did not work. It works for all other apps, except RDP.

    This seems to have been an issue for a long time. As I was seeking answers, I found forum posts and requests from 2009 and MS reps saying "we are looking into it". Yet no solution and it's almost 2014. It's a bummer. 


    • Edited by aloshka09 Wednesday, October 30, 2013 6:21 AM
    Wednesday, October 30, 2013 6:19 AM
  • FYI, no better in Windows 8.1, I just got a Surface Pro 2 for my other half, the pen should be really good for her drawing. I thought I might get a second one as well for my personal use, but RDP is not useable. The modern interface version has the zoom, but doesn't allow changing resolutions, so you're stuck using scroll bars to move around the screen, inefficient. RDP works fine on my work retina Macbook though, so that might be the way to go for my next personal machine. Funny, never thought I'd be a mac user.
    Thursday, November 14, 2013 11:54 PM
  • I have the same issue. RDP on a Surface Pro or any other High Res small display device is really crap.

    TeamViewer works perfectly, and a full screen RDP session on a Surface RT. Please, Microsoft, enable upscaling/zooming as TeamViewer does. I even can dynamically (!) change the screen resolution during a session. But I would be fine if I just could configure e. g. a RDP session that has exactly half of the pixels as my Surface Pro and then expand both directions to full width/height. This cannot be that complicated, as it only affects the RDP client. The server does not need to know about that.

    Please consider that I also have to control Hyper V text based RDP sessions.



    Friday, November 15, 2013 7:24 PM
  • With more high resolution display out in the market(using yoga 2 pro 3200x1800 etc), I really hope this issue is escalated promptly. Been more than years already.
    Saturday, November 30, 2013 7:17 AM
  • I'm in the same boat as you with my new Yoga 2 Pro - I RDP into many machines very frequently and the content is microscopic since the Windows 8.1 RDP clients (both the Modern/Metro one and the Desktop version) don't scale up (zoom); only down.

    I'd prefer to use one of the Windows native RDP utilities since they are otherwise very nice, but I'm forced to use mRemoteNG ( http://www.mremoteng.org/ ) now in order to get the proper scaling needed establish a usable RDP session to any machine without needing to alter configuration(s) on the target machine being accessed.  In a perfect world, Microsoft would update their RDP clients to do this as well, but in the mean time mRemoteNG it is.

    Good luck.

    Gerry

    • Proposed as answer by Oliver Lohkamp Tuesday, January 07, 2014 8:44 PM
    Saturday, January 04, 2014 4:19 PM
  • I just saw this:

    http://blogs.msdn.com/b/rds/archive/2013/12/16/resolution-and-scaling-level-updates-in-rdp-8-1.aspx

    They mention dynamic scaling of remote sessions to solve usage f ex on high-resolution displays like the Surface Pro. I haven't tried it yet but it does look promising.

    • Proposed as answer by Oliver Lohkamp Tuesday, January 07, 2014 8:44 PM
    Saturday, January 04, 2014 4:43 PM
  • I also searched for this as I am running a very high res laptop. Use Microsoft Remote Desktop Connection Manger v2.2 (can't post links on a new account, may be someone else can)

    It does exactly what you want scaling the remote session, select "Same as client area" under Size on the Remote Desktop Settings tab to avoid scrolling around the remote window.

    I have to say it would be nice if MSTSC.exe could do it without any other mucking about but hey this is just as good.

    Tuesday, January 14, 2014 10:04 AM
  • Use Microsoft Remote Desktop Connection Manger v2.2. <snip> It does exactly what you want scaling the remote session, select "Same as client area" under Size on the Remote Desktop Settings tab to avoid scrolling around the remote window.

    This actually comes quite close - amazing that it has been available since 2010!

    As you say, it does enlarge pixels. But it is fixed to enlarging pixels according to your local DPI setting, so you may not be able to fit the remote desktop on the local screen without resizing the remote desktop (causing windows to be moved to the top-left corner).

    Ideally this would work more like Remote Assistance where scaling is performed according to the current window size on the local desktop, and always fits the remote desktop without resizing remote windows.

    Also, the full screen mode is not great. The local desktop's taskbar hides parts of the remote host window (known bug for high DPI settings), and if I switch to Windows Basic theme to fix that, the scaling stops working altogether.

    But this definitely shows that Microsoft have had the code to do Remote Desktop upscaling for a long time, so it's just a matter of exposing it in the client with some sensible settings :-)

    Friday, January 17, 2014 12:52 PM
  • I think www.mremoteng.org as metioned by gleach represents what I was looking for, especially if you open any existing imported RDP file in full screen mode. I have the same excellent readable element size on my Surface Pro with full HD as on the Surface RT 1. And even in Windows mode I can perfectly work on the remote system without the need for Windows' magnifying glass.
    Friday, January 17, 2014 1:23 PM
  • I think www.mremoteng.org as metioned by gleach represents what I was looking for, especially if you open any existing imported RDP file in full screen mode. I have the same excellent readable element size on my Surface Pro with full HD as on the Surface RT 1. And even in Windows mode I can perfectly work on the remote system without the need for Windows' magnifying glass.

    I tried this out and it definitely seems like mremoteng wants to enable what I want to do, i e scale the full desktop of the remote host to a target size I decide myself. The setup is a little clunky to get going, but can be done like this:

    • In connection settings enter the actual resolution of the remote host (1600x1200 in my case).
    • Connect to the remote host
    • Now right-click on the "host tab" in mremoteng and select SmartSize
    • If you desire, right-click again on the host tab and select Fullscreen

    The problem I see at the moment is that the SmartSize function causes the remote display to become somewhat blurry. It's fine without SmartSize (with magnification according to the local host's DPI setting) but going back towards 1:1 scaling causes blur.

    Sunday, January 19, 2014 8:51 PM
  • So was there any update with win 8.1 that might make this work? I'm really wanting to buy the surface 3 pro as it looks like an incredible device, but since 90% of my work is in an RDP session on a win 2008 r2 server I can't work with text being unreadable and prefer the store RDP app. Mac is great, but I kind of want to go back to windows. 
    Friday, May 23, 2014 5:51 AM
  • You really should try www.mremoteng.org. It does exactly (!) what you desire and I am using on my Surface Pro and other high dpi devices: simply "import" any (or all) RDP files, doubleclick on it, finished. Set the properties - only if you like - of the connection to full screen in mRemoteNG and you only see a perfect standard Windows 8.1 RDP session with the same size as e. g. on a Surface RT with 720p display.

    Even your credentials remain in and are used from the Windows credential cache. So it is just kind of a wrapper around the standard RDP client. Microsoft has such a tool, too, but it by far not that handy as mRemoteNG.

    You can try is on your current Windows PC, don't need to buy a Surface Pro first :-)

    Friday, May 23, 2014 7:36 AM
  • This will not help if the host is something older than Windows 8.1 or Windows Server 2012 R2.
    Wednesday, June 04, 2014 5:23 PM
  • This will not help if the host is something older than Windows 8.1 or Windows Server 2012 R2.

    This is wrong, mremoteng works perfectly with e. g. Windows XP, Vista, 7, Windows Server 2000,...
    Just give it a try and you'll see. I am using it for months now on my Surface Pro with a lot of old servers and clients.

    Wednesday, June 04, 2014 5:33 PM
  • This is an excellent RDP client that does a great job clearly scaling the display.  Thanks for the tip.  I love it.
    Wednesday, June 04, 2014 5:58 PM
  • You are welcome.
    Wednesday, June 04, 2014 6:05 PM
  • Finally!  mremoteng works perfectly when remoting into windows 8/7 from my surface pro 3.  I just use "full screen" and get a perfectly readable remote desktop that I can actually work with.  Come on Microsoft, get a clue.

    Even gestures work from the track pad, i.e. - scrolling, etc.

    Many thanks!


    • Edited by j0hnth0m Thursday, June 26, 2014 5:18 AM
    Thursday, June 26, 2014 5:18 AM
  • Thank you! A great bit of software - worked straight out the box for me on my mac with retina display - I didn't even need to configure any settings, it just scaled up to a sensible resolution. This will save me hours of staring at a tiny screen! Come on microsoft - how difficult can it it be to detect a screen resolution and scale accordingly?
    Monday, January 05, 2015 10:42 AM
  • Windows 8 / Windows Server 2012 R2 does exactly this - for years now!
    If you log off the user session and connect via RDP e. g. in full screen from another modern Windows OS you get a screen resolution that fits your DPI.

    Only if you want to control older systems you need the free "Remote Desktop Connection Manager" from Microsoft or mRemoteNG. Or if you want to "jump into" an existing RDP session, e. g. with 1024x768 that I use for some servers, indepedant of the client or mobile device that I use for connecting.

    RDCM or mRemoteNG however are more for the professionals, because the normal user would "complain" how complicate the different "automatic" settings are. You can't do it right for all. Except: just use a modern OS and just don't care. Or use professional support tools such as TeamViewer which however is a little less efficient than RDP - and not free of charge.


    Monday, January 05, 2015 10:52 AM
  • Actually, it only does it well if you use the client's desktop resolution for the remote desktop session host's resolution.  This works well if all you are using is standard client side RDP rendering commands.

    **However**, if you are using RemoteFX and rendering your desktops on the server side/remote session host side, then *resolution becomes an issue* as you are now sending image updates to the client side vs. RDP render commands...so a 1920x1200 screen would become an issue in regards to bandwidth as it can send upwards of 10 to 50Mbps per connection!

    Thus, the *PRIMARY* issue at hand is that "smartsizing" only works when the window containing the remote desktop session is smaller than the remote desktop session host's resolution (i.e. scale down)...but if you want to go "full screen" then you will (as many have noted) end up with black borders around the edges of the desktop...

    So... what seems to need to happen if RemoteFX Server side rendering is going to be of any use to pure Microsoft based desktop virtualization solutions would be that the smartsizing feature needs to be able to scale *UP* as well as scale down...as you would want to limit the desktop size in the case of using RemoteFX server/host side rendering in order to conserve bandwidth.

    Otherwise, if you had 20 employees that were remote users and each were doing random rendering intensive things (i.e. large portions of a 1920x1200 desktop were changing) then the desktop duplication element of server side rendering would be sending large image chunks at 30fps or more!

    This would mean that 20 users could consume between 200Mbps to 400Mbps of bandwidth...of which makes RemoteFX server side rendering a problematic scenario...unless you just scale down the desktops  to something like 1280x1024 and force users to squint their eyes in order to see the desktop on a 1920x1200 client side desktop...because you can't *scale up*...

    Of which, if anyone at Microsoft is reading this thread... adding the ability to *scale up* from a lower resolution remote session host is really the only way to make RemoteFX server side rendered desktops a viable "remote user" solution... I think many people would look past any anti-aliasing artifacts presented by scaling up in exchange for a more reasonable bandwidth consumption per session (only for server side RemoteFX rendering).

    Just my two cents on all of this...

    Tuesday, January 27, 2015 4:27 PM
  • Windows 8 / Windows Server 2012 R2 does exactly this - for years now!
    If you log off the user session and connect via RDP e. g. in full screen from another modern Windows OS you get a screen resolution that fits your DPI.

    Only if you want to control older systems you need the free "Remote Desktop Connection Manager" from Microsoft or mRemoteNG.

    This is not entierly true.

    We have customers on our terminal server that has this high resolution issue on their devices, when they has Yoga 2 Pro users with 3200x1800 in Windows 8.1 are connecting to your Server 2008 R2.
    It will not help them that we give them a terminal server running 2012 R2, because there is a LOT of programs out there that are shitty on DPI support. Even Microsoft own "Live Writer", or software like Dropbox has a serious problems if you temper with DPI from the old school DPI from Windows 7 and older.

    Microsoft needs to address this issue quickly and pref. in an RDC for Windows 10 the latest. There will only be more and more high resolution screens and devices, but there will still for many years be software that are not built for changes to DPI. For my world that would be software like "Uni Micro", "Visma Business", "SuperOffice", "Mamut" and a lot of other special software for accounting and CRM, designed for a Windows world where XP was _the shit_ (and still is).

    Making a RDC for Windows, running on 3200x1800, telling the server that it is actually 1600x900 and do the scaling on the client side - IT HAS to happen! Soon rather than later.

    Thursday, January 29, 2015 1:51 PM
  • Well, mRemoteNG does exactly that and RDCM, as far as I understand. At least I can jump in existing old RDP sessions on my Surface Pro 3 and have a nice big UI.

    So if there is very bad and old software that will not be updated to run smooth on any (!) new client with high dpi (independent of that you want to run it over RDP) and you do not want to or cannot update or exchange that piece of sh..., then I think it is OK to use nRemoteNG for this really old and bad stuff. High DPI displays are not that new, but people get older and worse eyes... .-)

    I just binged Live Writer and saw that it is from 2009, the last decade, nearly before the TFT display was invented... .-) I think Microsoft would like you to upgrade to SharePoint or any other web based CMS. At least in an enterprise environment that we are talking about.

    Thursday, January 29, 2015 2:03 PM
  • In case it could help someone else: I had some issues recently with RDP using either mRemoteNG or RDCM: mouse clicks were not handled correctly when I clicked on the edges of the remote desktop. It seems to be an issue of the RDP client component in High DPI (4k) mode.

    --> I downloaded MobaXterm ( http://mobaxterm.mobatek.net ) which I had already used for SSH and VNC connections. In the RDP session settings, I checked "Adapt remote DPI (Remote desktop will open in external window on high-resolution monitors)" and it worked: my remote desktop DPI value is now the same than the local DPI value automatically!

    Now I will try to find out if there is a way to have this in non-fullscreen mode...
    Thursday, March 12, 2015 12:48 PM
  • mRemoteMG FINALLY did it. That was what I was looking for.
    Thursday, April 02, 2015 7:59 PM