Event ID's 257 & 491 updates not installing


  • I am having multiple errors when attempting to install updates, there may be other problems

    My backups had failed and after bouncing the server they seem ok, however I was still unable to install updates on this box which are no different than several other 08  r2 servers I have running.

    Anyone have an idea???


    The Cryptographic Services service failed to initialize the Catalog Database. The ESENT error was: -1032.

    Catalog Database (1160) Catalog Database: An attempt to determine the minimum I/O block size for the volume "C:\" containing "C:\Windows\system32\CatRoot2\" failed with system error 5 (0x00000005): "Access is denied. ". The operation will fail with error -1032 (0xfffffbf8).


    Tried this...

    Repair the catalog database by using Esentutl

    To repair the catalog database by using Esentutl:

    1. Click Start, point to All Programs, and then click Accessories.
    2. Right-click Command Prompt, and then click Run as administrator.
    3. If the User Account Control dialog box appears, confirm that the action it displays is what you want, and then click Continue.
    4. In the command prompt window, type net stop cryptsvc to stop Cryptographic Services, and then press ENTER.
    5. Type esentutl /p <%systemroot%>\System32\catroot2\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\catdb, and then press ENTER.

    The above cmd produces the error "Access is Denied" why would this be? I am working as the domain Admin and a member of the local admin group which seems to have the rights to C:\

    Wednesday, September 22, 2010 6:23 PM

All replies

  • Hi, I suggest you first try the solutions in the following two KB articles:


    You cannot install some updates or programs


    ESENT event IDs 1000, 1202, 412, and 454 are logged repeatedly in the Application log

    Hope this helps! 

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 24, 2010 6:15 AM
  • These event IDs 1000, 1202, 412, and 454 are not my issues

    This KB item does not seem applicable to Server 08 kb/822798. It seems applicaible to XP or Server 03, any more ideas from anyone?


    Monday, September 27, 2010 8:49 PM
  • this finally worked for me:


    1. services > cryptographic services > properties >logon (identity)

    2. give the identity account (usually 'network service') full permission on the C: drive.

    • Proposed as answer by Shaojun Wang Monday, December 24, 2012 4:47 PM
    Tuesday, December 13, 2011 2:46 PM
  • Kerry,

    I got same issue and thanks lot for your information!

    George Wang

    Monday, December 24, 2012 4:49 PM