locked
File replication Error in 2003 DC RRS feed

  • Question

  • Dear Team,

    Before some days, I added the Additional Domain with 2008 STD in my 2003 PDC.

    But in new Additional Server 2008, SYSVOL & NEtlogon not shared, and also in 2003PDC & 2008ADC, showing same following event error.

    NTFRS Service is alredy started in both & in 2003 PDC, I checked the registry entry for "Enable Journal Wrap Automatic Restore" i.e. value is 1.

    Please help me for this issue.

    Error :

    The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.

     Replica set name is : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"

    Replica root path is : "c:\windows\sysvol\domain"

    Replica root volume is : "\\.\C:"

    A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found. This can occur because of one of the following reasons.

     

    [1] Volume "\\.\C:" has been formatted.

    [2] The NTFS USN journal on volume "\\.\C:" has been deleted.

    [3] The NTFS USN journal on volume "\\.\C:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.

    [4] File Replication Service was not running on this computer for a long time.

    [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\C:".

    Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.

    [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.

    [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.

     

    WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.

     

    To change this registry parameter, run regedit.

     

    Click on Start, Run and type regedit.

     

    Expand HKEY_LOCAL_MACHINE.

    Click down the key path:

    "System\CurrentControlSet\Services\NtFrs\Parameters"

    Double click on the value name

    "Enable Journal Wrap Automatic Restore"

    and update the value.

     If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.

     

    Kiran Wagh

    System Admin.


    Kiran W. System Admin, MCSA
    Tuesday, April 27, 2010 6:36 AM

Answers

  • Howdie!
     
    On 27.04.2010 08:36, Kiran W wrote:
    > The File Replication Service has detected that the replica set "DOMAIN
    > SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
     
    If it is a Journal wrap error, you'll have to authoritatively restore
    the data:
    http://support.microsoft.com/?id=292438
    http://support.microsoft.com/?id=328492
     
    Cheers,
    Florian
     

    Microsoft MVP - Group Policy (http://www.frickelsoft.net/blog)
    • Proposed as answer by Meinolf Weber Tuesday, April 27, 2010 10:57 AM
    • Marked as answer by Bruce-Liu Monday, May 3, 2010 11:17 AM
    Tuesday, April 27, 2010 6:45 AM

All replies

  • Howdie!
     
    On 27.04.2010 08:36, Kiran W wrote:
    > The File Replication Service has detected that the replica set "DOMAIN
    > SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.
     
    If it is a Journal wrap error, you'll have to authoritatively restore
    the data:
    http://support.microsoft.com/?id=292438
    http://support.microsoft.com/?id=328492
     
    Cheers,
    Florian
     

    Microsoft MVP - Group Policy (http://www.frickelsoft.net/blog)
    • Proposed as answer by Meinolf Weber Tuesday, April 27, 2010 10:57 AM
    • Marked as answer by Bruce-Liu Monday, May 3, 2010 11:17 AM
    Tuesday, April 27, 2010 6:45 AM
  • i had same problem.

    i resovled this issue by modify registry entry.

    HKLM --> System --> CurrentControlSet --> Services --> ntfrs --> Parameters --> Backup/Restore --> Process at Startup --> BurFlags --> changed value as "D2" (Non-Authrotive Restore).

    then restarted "File replication services" service.

    this may be due to inproper shutdown


    kesav
    Monday, September 19, 2011 9:17 AM
  • This is what fix it for me:

    Run Regedit

    Click on Start, Run and type regedit.

    Navigate to:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtFrs\Parameters

    Double click on the value name

    "Enable Journal Wrap Automatic Restore"

    and update the value to 1.

    If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above and set the parameter to 1

     

    • Proposed as answer by RK7L Friday, January 6, 2012 9:23 AM
    Tuesday, October 25, 2011 8:59 PM
  • it also solves

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtFrs\Parameters

    Double click on the value name

    "Enable Journal Wrap Automatic Restore"

    and update the value to 1.


    kesav
    • Proposed as answer by Ahmed Manara Monday, May 7, 2012 12:27 PM
    Friday, January 6, 2012 9:26 AM
  • Adding the "Enable Journal Wrap Automatic Restore" at:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NtFrs\Parameters

    and setting it's value to 1, restarting the server works fine for me.

    You may have to wait for 5 min for the replication to take place. meanwhile you'll lose access to SYSVOL.

    make sure to restore the key value to 0. otherwise you'll get the restore applied after every restart.

    Ahmed

    Monday, May 7, 2012 12:38 PM
  • This work for me as well thanks for sharing the same:)
    Wednesday, September 5, 2012 10:29 AM
  • Hi,

    i m using win2k3 last few days showing same following event error.

    The File Replication Service has detected that the replica set "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)" is in JRNL_WRAP_ERROR.

     

     Replica set name is    : "DOMAIN SYSTEM VOLUME (SYSVOL SHARE)"

     Replica root path is   : "f:\windows\sysvol\domain"

     Replica root volume is : "\\.\F:"

     A Replica set hits JRNL_WRAP_ERROR when the record that it is trying to read from the NTFS USN journal is not found.  This can occur because of one of the following reasons.

     

     [1] Volume "\\.\F:" has been formatted.

     [2] The NTFS USN journal on volume "\\.\F:" has been deleted.

     [3] The NTFS USN journal on volume "\\.\F:" has been truncated. Chkdsk can truncate the journal if it finds corrupt entries at the end of the journal.

     [4] File Replication Service was not running on this computer for a long time.

     [5] File Replication Service could not keep up with the rate of Disk IO activity on "\\.\F:".

     Setting the "Enable Journal Wrap Automatic Restore" registry parameter to 1 will cause the following recovery steps to be taken to automatically recover from this error state.

     [1] At the first poll, which will occur in 5 minutes, this computer will be deleted from the replica set. If you do not want to wait 5 minutes, then run "net stop ntfrs" followed by "net start ntfrs" to restart the File Replication Service.

     [2] At the poll following the deletion this computer will be re-added to the replica set. The re-addition will trigger a full tree sync for the replica set.

     

    WARNING: During the recovery process data in the replica tree may be unavailable. You should reset the registry parameter described above to 0 to prevent automatic recovery from making the data unexpectedly unavailable if this error condition occurs again.

     

    To change this registry parameter, run regedit.

     

    Click on Start, Run and type regedit.

     

    Expand HKEY_LOCAL_MACHINE.

    Click down the key path:

       "System\CurrentControlSet\Services\NtFrs\Parameters"

    Double click on the value name

       "Enable Journal Wrap Automatic Restore"

    and update the value.

     

    If the value name is not present you may add it with the New->DWORD Value function under the Edit Menu item. Type the value name exactly as shown above.

     

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     



    Wednesday, January 9, 2013 12:35 PM
  • I've tried everything for an automatic restore mentioned above, to a D2 non-authoritive restore and even a D4 authoritive restore before I made it to this website. I thought for the first time I'd throw my issue out there like a net to see if I have any suggestions. My forest is currently in 2003 mode because I have 1 2003 DC and 2 2012 DC's. I swapped all FSMO roles to the first and good 2012 DC way before I decided to purchase my second 2012 DC to eventually replace my old 2003 DC and in effect raise my forest functional level. The FSMO role transfers went fine by the way. The issue lies with my third DC which is the second 2012 DC. It constantly enters the journal wrap error state despite what recovery method I use. Sometime it enters 1 -3 1/2 hours after a restore is successfully performed. I've reached out to those more versed at the MS Stack then myself and even they are stumped. I also demoted the bad DC and changed its name as well. Any suggestions?
    Wednesday, September 30, 2015 2:43 PM