none
Server 2008 DHCP assigns leases but never displays leases in the GUI

    Question

  • Well, the subject says it all.

    I have a newly installed 2008 Server with a DHCP role.  It correctly assigns new machines IP addresses but when I use the GUI MMC the leases do not show.

    The DHCP database was imported from a Server 2003.  I don't know if that caused some problems.

    Any ideas on how to fix this problem?

    David Hidding
    Dana Molded Products

    Tuesday, January 27, 2009 11:14 PM

All replies

  •  hi there,

    did you use dhcp exim tool to migrate the dhcp data base ? here are the steps for cross verify

    The DHCP database can be moved or migrated from a Windows Server 2003 server to a Windows Server 2008 server, or from one Windows Server 2008 server to another.  The information below details the necessary steps.

    Export the DHCP database from a server that is running Microsoft Windows Server 2003 or Windows Server 2008

    To move a DHCP database and configuration from a server that is running Windows Server 2003 or Windows Server 2008 to another server that is running Windows Server 2008:

    1.   Log on to the source DHCP server by using an account that is a member of the local Administrators group.

    2.   Click Start, click Run, type cmd in the Open box, and then click OK.

    3.   Type netsh dhcp server export C:\dhcp.txt all , and then press ENTER.

    Note: You must have local administrator permissions to export the data.

    Configure the DHCP server service on the server that is running Windows Server 2008

    1.   Click Start, click Administrative Tools, click Server Manager. If needed acknowledge User Account Control.

    2.   In Roles Summary click Add Roles, click Next, check DHCP server, and then click Next.

    Import the DHCP database

    1.   Log on as a user who is an explicit member of the local Administrators group. A user account in a group that is a member of the local Administrators group will not work. If a local Administrators account does not exist for the domain controller, restart the computer in Directory Services Restore Mode, and use the administrator account to import the database as described later in this section.

    2.   Copy the exported DHCP database file to the local hard disk of the Windows Server 2008-based computer.

    3.   Verify that the DHCP service is started on the Windows Server 2008-based computer.

    4.   Click Start, click Run, type cmd in the Open box, and then click OK.

    5.   At the command prompt, type netsh dhcp server import c:\dhcpdatabase.txt all , and then press ENTER, where c:\dhcpdatabase.txt is the full path and file name of the database file that you copied to the server.

    Note When you try to export a DHCP database from a Windows 2000/2003 domain controller to a Windows Server 2008 member server of the domain, you may receive the following error message:

    Error initializing and reading the service configuration - Access Denied

    Note You must have local administrator permissions to import the data.

    6.   To resolve this issue, add the Windows Server 2008 DHCP server computer to the DHCP Admins group at the Enterprise level and redo steps 4 & 5.

    7.   If the “access is denied” error message occurs after you add the Windows Server 2008 DCHP server computer to the DHCP Admins group at the Enterprise level that is mentioned in step 6, verify that the user account that is currently used to import belongs to the local Administrators group. If the account does not belong to this group, add the account to that group, or log on as a local administrator to complete the import and redo steps 4 & 5.

    Authorize the DHCP server

    1.   Click Start, point to All Programs, point to Administrative Tools, and then click DHCP.

    Note You must be logged on to the server by using an account that is a member of the Administrators group. In an Active Directory domain, you must be logged on to the server by using an account that is a member of the Enterprise Administrators group.

    2.   In the console tree of the DHCP snap-in, expand the new DHCP server. If there is a red arrow in the lower-right corner of the server object, the server has not yet been authorized.

    3.   Right-click the server object, and then click Authorize.

    4.   After several moments, right-click the server again, and then click Refresh. A green arrow indicates that the DHCP server is authorized

     

    PS : you need to have a working database / not a corrupted database. so issue might be occured because of database.

     

    you can Jet the database and use netsh utility to import "netsh dhcp import"

    To jetpack the DB here are the steps

    1. Compact the DHCP database by using the JetPack utility:
    2. Click Start, click Run, type cmd in the Open box, and then click OK.
    3. At the command prompt, type cd %systemroot%\system32\dhcp, and then press ENTER.
    4. Type jetpack dhcp.mdb temp.mdb, and then press ENTER.
    5. After the database is compacted successfully, type exit, and then press ENTER.
    6. Export the DHCP database by using the DHCP Export Import utility (Dhcpexim.exe)

     


    sainath Windows Driver Development
    Wednesday, January 28, 2009 6:35 AM
    Moderator
  • ok, I'll try these steps.

    I imported the database by backing it up from the 2003 box and restoring it onto the 2008 box.

    Wednesday, January 28, 2009 3:03 PM
  • Well, I followed your steps but ended with the same result. 

    The database exported and imported without errors, but the MCC still shows nothing for leases (actually there is a red "X" by the tree object "Address Leases".

    "Reservations" is also blank.  There should be about 20 items here.

    The Scope, Address Pool, and Scope Option all came across correctly.

    Essentially, this looks just as it did when I imported the first time.

    David Hidding

    Wednesday, January 28, 2009 3:17 PM
  • hi david,

     

    i have seen many posts regarding the same red x issue  after exporting dhcp database from windows 2003 to windows 2008 , but microsoft devlopment should release suitable fix until then you can still use windows 2003 or configure the scope manually / without exporting them ( i understand it would be tedious if you have several 10's / 100's of scopes )

    let us wait for some more repsonses


    sainath Windows Driver Development
    Wednesday, January 28, 2009 5:20 PM
    Moderator
  • ok, thanks for your time.
    Wednesday, January 28, 2009 5:22 PM
  • Any progress on this? I have the same problem.
    Wednesday, June 3, 2009 9:46 PM
  • Hi, I was with the same problem and resolved the problem following this:

    +++++++++++++++++++++++++++++++++++++++++++++++++++++++++

    Export the DHCP database from Windows 2003:

    1.                   On the Windows 2003 DHCP server, navigate to a command prompt

    2.                   Type the following Command: netsh

    3.                   Type the following Command: DHCP

    4.                   Type the following Command: server <\\Name or IP Address>

    5.                   Type the following Command: export c:\w2k3DHCPdb all

    Note You must have local administrator permissions to export the data.

    Import the DHCP database

    1.       Copy the exported DHCP database file to the local hard disk of the Windows Server 2008-based computer.

    2.       Install the DHCP Role on the server.

    3.       Stop the DHCP server service on the server.  To do this, follow these steps:

    a.       Log on to the source DHCP server by using an account that is a member of the local Administrators group.

    b.      Click Start, click Run, type cmd in the Open box, and then click OK.

    c.       At the command prompt, type net stop DHCPserver , and then press ENTER. You receive a "The Microsoft DHCP Server service is stopping. The Microsoft DHCP Server service was stopped successfully" message.

    d.      Type exit, and then press ENTER.

    4.       Delete the DHCP.mdb file under c:\windows\system32\DHCP folder.

    5.       Start the DHCP server service.

    6.       Right-click on the Command Prompt (cmd) and select run as administrator, to open the cmd prompt using elevated privileges.

    Note You must have local administrator permissions to import the data.

    7.       Type the following Command: netsh

    8.       Type the following Command: DHCP

    9.       Type the following Command: server <\\Name or IP Address>

    10.   Type the following Command: import c:\w2k3DHCPdb

    11.   Restart DHCP and verify the database has moved over properly.

    • Proposed as answer by Serjevski Thursday, July 2, 2009 7:22 AM
    Saturday, June 20, 2009 1:46 PM
  • Angelowrege , thank You! It works fine.
    Thursday, July 2, 2009 7:23 AM
  • Angelowrege, I'm glad this works (believe there's a KB on this). However, I'm already migrated to W2K8 DHCP and no longer have access to the W2K3 DHCP to export the data. I'd love to know if there's a way to simply fix the existing condition (though I haven't spent a lot of time on it as DHCP is actually handing out leases). I've removed and re-added the role but the problem still exists.
    Thursday, July 2, 2009 4:14 PM
  • shorinsean, i just know about this way. 

    If you start the DHCP service with a clean database, GUI display the leases? If the answer Yes, i think that you have to make the process manually!
    Thursday, July 2, 2009 5:40 PM
  • Thank you! This worked perfectly.

    Just performing an export from the gui in 2003 for an import in 2008 will not work or you will see the red "x" on the address lease as listed above.
    Wednesday, January 6, 2010 8:32 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    • Proposed as answer by Parsons66 Wednesday, March 9, 2011 9:39 PM
    Wednesday, March 9, 2011 9:38 PM
  • This worked perfectly for me without having to bring my 2003 server back up. Thank you!
    Friday, March 25, 2011 7:30 PM
  • Parsons66, you da man. That worked for my DHCP issue!
    Wednesday, May 4, 2011 4:48 PM
  • I had the same issue. resolved legend! thanks
    Thursday, June 2, 2011 8:55 PM
  • Parsons66 you are the man!!!  Thank you!

    Jose Angel Rivera
    Tuesday, September 27, 2011 4:26 AM
  • I had similar issue where I could see all my options except my DHCP leases. NICE JOB Parsons66!!!!
    Sunday, June 3, 2012 7:16 AM
  • Ditto.  Thank you 66.
    Thursday, July 19, 2012 2:15 PM
  • This worked perfectly. Now that Server 2012 is available I finally have some of my clients convinced into moving to 2008 form their 2003 environments! Glad I stumbled across this thread.
    Saturday, October 20, 2012 3:09 AM
  • Parson66's method corrected the issue after I had moved many scopes over from a 2003 server to a new 2008R2 server - using backup/restore from the GUI.

    thanks a million!

    Friday, November 9, 2012 5:54 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    worked perfectly!
    Monday, November 12, 2012 6:05 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    Worked perfectly for me... a much appreciated bump to this thread for those in similar situation.. 
    Tuesday, December 11, 2012 1:04 AM
  • Hello,

     I recently had the same issue, and this worked perfectly.

    Tuesday, January 22, 2013 3:24 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    Worked like a charm!
    Thursday, February 28, 2013 2:50 PM
  • Perfect !

    It worked with Windows 2012 DHCP server too. I had the same problem after exporting from Win 2003

    to Win 2012.

    Thank you

    Tuesday, November 26, 2013 8:55 AM
  • Good Lord, I'm glad I found that fast enough.

    Parson - your proposal with the export and import on the same new server was the solution for me after migrating DHCP from 2003 to 2012. The problem with me was: no leases and no reservation could be seen, but PC got leases and when I tried to add previous reservations 'the specified ip address or hardware address is being used by another client' always prompted.

    'And I can see clearly now, no other rapper is near me now' :)

    Wednesday, March 12, 2014 4:35 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     


    Worked !!!!!   Thank you !!!
    Wednesday, March 12, 2014 7:07 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    Top post Parsons66 just saved me a load of work ....... many thanks :-)

    Friday, July 25, 2014 9:10 AM
  • Same applies to 2012 R2 - thanks for the help.  Note that my import "hung", a server reboot was necessary as DHCP was unresponsive, but once rebooted, everything magically reappeared.  Cheers,  Ben.


    HTH, Ben [MVP]

    Thursday, September 25, 2014 3:09 PM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh

    At this point I was able to view all of my Address Leases.  All entries had a Name that was equal to its Client IP Address, a Lease Expiration of the time of my export, a Type of DHCP/BOOTP, and a very long Unique ID (32 characters).  After performing a "Ipconfig /renew" from a workstation, the workstation's Name appeared correctly, the Type changed to just DHCP, and the Unique ID was the MAC address of the workstation.

    I then created a command file (renew.cmd) with the command Ipconfig/renew as the only contents.  I placed this file on a UNC path (\\fileserver\sharename\renew.cmd) that I knew all domain users had access to and then sent them an email with the link to the file and instructions to select "Open" after clicking the link.  The proper DHCP registrations just started rolling in after that.

    Hope this works for anyone still experiencing this issue.

     

    This worked perfectly for me.  I didn't want to blow away all the scopes though so I was able to just remove and re-import the one I needed with these commands:

    netsh dhcp server v4 export c:\dhcpv4.txt 192.168.2.0  <-- Selectively exported the IPv4 scope with the error

    netsh dhcp server v4 import c:\dhcpv4.txt 192.168.2.0  <-- Imported it back in

    Tuesday, December 23, 2014 8:25 PM
  • This was my solution in the end. Thank you.

    (I tried the other steps on the KB and it still didn't help.)

    • Proposed as answer by Russel.C Thursday, January 8, 2015 11:56 AM
    • Unproposed as answer by Russel.C Thursday, January 8, 2015 11:56 AM
    Thursday, January 8, 2015 11:56 AM
  • I know this is an ancient thread, but I just ran into your same issue.  My solution was:

    Perrform these steps from my new W2K8 DHCP server:

    1. Open DHCP mmc
    2. Open Command prompt: cmd
    3. Type: netsh dhcp server export C:\dhcp.txt all in command prompt and press Enter
    4. Delete ALL scope information from within the DHCP mmc
    5. Type: netsh dhcp server import C:\dhcp.txt all in command prompt and press Enter
    6. Right-click server name within DHCP mmc and choose refresh


    Received an error: An attempt was made to load a program with an incorrect format.

    Please help

    Friday, March 6, 2015 6:53 PM
  • Same applies to 2012 R2 - thanks for the help.  Note that my import "hung", a server reboot was necessary as DHCP was unresponsive, but once rebooted, everything magically reappeared.  Cheers,  Ben.


    HTH, Ben [MVP]

    No need for command prompt, just Backup from DHCP mmc, delete Scope and Import again.

    Win2012R2 DHCP will hung, but no need for restart - use Task Manager to kill DHCP server, then Start service again.

    bJako


    Jako

    Friday, June 19, 2015 9:47 PM
  • Since I didn't have the old server online anymore, this worked for me as well. Exporting and reimporting the database must clean out the differences between 2003 backup and 2008+ restore functions. All my unique IDs were MAC addresses after the fix so I think I'm good to go now. Glad to find a fix for this puzzling issue. Just wish an MS article hadn't shown me the wrong way beforehand.

    Tuesday, July 19, 2016 10:08 PM
  • Thank you so much for the post.  This worked for me for windows 2012 as well 
    Wednesday, January 17, 2018 9:23 PM
  • 7 years later and your solutions saved me a lot of work ! Txs !!
    Sunday, February 11, 2018 5:43 PM