Upgrade to R2 failing with LSI Logic LSI Adapter, Ultra320 SCSI 2000 series, w/1020/1030 driver RRS feed

  • Question

  • Hi , 

    I am getting error for "LSI Logic LSI Adapter, Ultra320 SCSI 2000 series, w/1020/1030 driver not compatible with win2012" during upgrade to 2012R2... Can anybdy provide solution or have similar problem?

    Tuesday, November 19, 2013 6:08 AM


All replies

  • Give a look at compatibility list


    Here is another good source




    • Edited by Milos Puchta Tuesday, November 19, 2013 11:42 AM
    Tuesday, November 19, 2013 11:40 AM
  • I have a similar problem, it's for my tape backup drive. 

    in this dell blog http://en.community.dell.com/techcenter/b/techcenter/archive/2013/09/05/windows-server-2012-r2-rtm-inbox-driver-support-on-dell-poweredge-servers.aspx?dgc=SM&cid=259733&lid=4904601

    it mentioned Dell Tape Adapters device drivers are included 2012 R2, but clearly it is not. 

    • Marked as answer by Mandy Ye Monday, November 25, 2013 1:36 AM
    Tuesday, November 19, 2013 5:21 PM
  • Same Problem here on a VMWare 5.1
    Got a solution already ??


    Monday, December 30, 2013 8:35 AM
  • I installed the driver from LSI offsite http://www.lsi.com/support

    Search Results
    You searched for:
    Component type: Storage Component
    Product Family: Legacy Host Bus Adapters
    Product: LSI22320-R
    Asset Type: Driver

    You must choose a third top - LSIMPT_SCSI_W2k8. The zipfile contains a folder lsimpt_scsi_srv08_x64. After installing the driver, HP Dataprotector 8 (mounted on Windows 2012 R2) saw MSL2024 SCSI connected to the controller.

    • Proposed as answer by Sacrificer Sunday, January 5, 2014 5:19 PM
    • Edited by Sacrificer Thursday, August 6, 2015 3:19 AM
    Sunday, January 5, 2014 4:57 PM
  • That's it !!!

    Many thanks from Bavaria !!

    Thursday, January 9, 2014 9:04 AM
  • This driver worked great. Thanks Sacrificer!
    Thursday, January 9, 2014 8:46 PM
  • Sacrificer,

    Perfect. Thanks! I Voted UP your answer.

    If you would please, because I am always running into this kind of problem (old hardware on a new OS) - Just how did you figure out that a HP SC11Xe HBA is really a LSI22320-R? So that you could find the LSI driver?

    Friday, January 17, 2014 6:08 PM
  • For AGlassman

    Reinstall the server to OS Windows 2012 R2 done from home. See, what really stands HBA, was not possible. Go to work in the New Year holidays was too lazy (back and forth 70 km). Looked properties Unknown device in Device Manager. Searched in Google, determined that this device obviously chipset LSI Ultra SCSI 320.
    Thought so:
    LSI22320-R: 320 - this is obviously a standard SCSI, 22 - 2xxx Series HBA, LSI - manufacturer, R - I'm from Russia, just like the letter :).

    it's all just!

    Saturday, January 18, 2014 6:20 AM
  • I created an account just to say thank you!
    Wednesday, February 12, 2014 2:55 PM
  • Thankyou, that was a lifesaver and worked as described!!
    Friday, February 14, 2014 12:45 AM
  • You are my new favorite person!
    Tuesday, March 18, 2014 7:57 PM
  • Thanks!

    I have HP DL360 G6 and try to make scsi connector work for server 2012! you are my hero!

    Friday, June 6, 2014 2:15 PM
  • I´m using VMware 5.1 and it looks like works

    Thank you...

    Jefe Sioux

    Sunday, August 17, 2014 6:33 PM
  • Thanks!
    Thursday, August 21, 2014 9:52 PM
  • Ha, works!

    Get a load of that: 2012 Server on ESXI, virtual SCSI host controller, latest ESXI (5.5), latest VMware Tools installed, virtual driver is from 2012... but 2012R2 setup prefers this stone age driver from 2008? Crazy. Thanks soo much, Sacrificer!

    Wednesday, September 3, 2014 9:53 PM
  • Thank you very much. Life saver! Be blessed.
    Friday, September 12, 2014 2:18 AM
  • I couldn't get the LSI W2K8 driver to install on W2012 R2 so I used the one from the Adaptec site:


    For reference, my PCI IDs for the card were:

    Vendor Id: 0x9005

    Device ID: 0x8017

    Saturday, November 8, 2014 2:39 PM
  • The LSI Driver worked for me also.
    Friday, December 5, 2014 5:22 PM
  • Thank you very Much. Downloaded drivers from LSI. Installed onto our 2012r2 DPM server and worked like a charm.

    Many thanks!

    Thursday, December 11, 2014 4:34 PM
  • AWESOME! Saved me from GEEK purgatory. Happy Holidays.
    Tuesday, December 16, 2014 11:27 PM
  • Thanks sooo much!
    Saturday, January 31, 2015 10:16 AM
  • I had the same issue and followed your steps and its proceeding with the install now. Great help!
    Sunday, May 10, 2015 1:38 AM
  • Worked Perfect for me !!!! thanks Sacrificer...
    Wednesday, August 5, 2015 9:16 PM
  • Thanks Sacrificer, this works for my LSI20320IE on http://www.lsi.com/support

    Searched for:

    Product Family: Legacy Host Bus Adapters
    Product: LSI20320IE
    Asset Type: Driver


    ;-) !!

    Friday, October 2, 2015 10:46 AM
  • that works, thanks a bunch
    Friday, November 20, 2015 9:55 PM
  • Saved me as well :)


    Monday, December 21, 2015 1:55 PM
  • This worked for me also. Old thread but good answer.
    Wednesday, March 2, 2016 7:10 PM
  • Hi, could someone post some performance stats for the HDD. On our system (RAID 5 on a PERC 4 DI) we get about 35MB/s sustained when copying from one Virtual disk to another on the same array. System just seems a bit sluggish.


    Sunday, April 24, 2016 4:22 AM
  • I did this and now the controller shows up in devices and so does the tape reader, but when I put a tape in to view, nothing happens at all.
    Monday, June 27, 2016 7:43 PM
  • I did this and now the controller shows up in devices and so does the tape reader, but when I put a tape in to view, nothing happens at all.
    Monday, June 27, 2016 7:46 PM
  • Many thanks for the tips! Could not have guessed that the latest and greatest likes old drivers.
    Wednesday, July 13, 2016 3:20 PM
  • Try this Drivers :
    For windows driver 2012.


    You need to extract first the file.exe ( Use Zip ).
    Open the folder ex: LSI-FORCED-5x64-LSImpt_6.5.0-drp -> drivers  -> DP_MassStorage_16065

    Install the driver from device manager -> update driver -> and select to the driver.

    Thursday, July 14, 2016 2:49 AM
  • does anybody have a Driver being compatible with 2012r2 ?
    Thursday, October 13, 2016 12:26 PM
  • Hi Der_lala,

    Hopefully you were able to resolve this issue already but if you havent. Please see the link below there is a download for the drivers at the bottom of the page. Took me several hours of hunting and finally found a working copy of the driver. 


    I highly suggest you save the drivers as I'm not sure when this person will decide to remove it from their site.

    Friday, December 23, 2016 3:48 AM
  • Hello everyone! I just wanted to update this feed since many folks may still run in to this issue. The link to LSI no longer works and Broadcoms site isn't the easiest to search.

    Here is the URL search query I used to find the driver: https://www.broadcom.com/broadcom-search?q=Ultra320+SCSI+2000+server+2008

    The file you want to download is labeled: LSImpt_sas_Windows7_Windows_Server_2008_R2_P20 

    Use the same process of updating the driver as listed in this feed and you should be set. I hope this helps someone down the line. Good luck! Have a great day! 

    Best Regards,

    Chris Murdaugh 

    Sunday, January 15, 2017 6:58 PM
    • Proposed as answer by Borgy333 Friday, July 7, 2017 9:51 AM
    Thursday, April 20, 2017 9:49 PM
  • Thanks this solution worked for me. Very hard to find on the Broadcom site!
    Friday, July 7, 2017 9:51 AM
  • Much Appreciated, It worked!!!
    Thursday, August 24, 2017 9:05 AM
  • click on this link https://docs.broadcom.com/docs/12349638 to access the download page


    Wednesday, September 13, 2017 1:58 PM
  • Great One !! Sacrificer

    Thanks & Regards Natty Kannvy

    Sunday, January 7, 2018 5:41 AM
  • Hi Sacrificer, 

    Thanks so much for your help!

    It was the perfect driver suggested by you and it worked absolutely fine for me!!!!

    Best regards,


    Thursday, February 1, 2018 1:55 PM
  • That is perfect - thank you!!
    Monday, April 30, 2018 7:03 AM
  • Thanks,

    Problem Got resolved.

    Thursday, May 24, 2018 1:08 PM
  • Many thanks man! It worked and I was able to upgrade from W2K12 to W2K12R2. This saved us a lot of work, becuase, otherwise, we would have to rebuild the server. Much appreciated!
    Saturday, June 9, 2018 2:22 AM
  • You are life saver. This worked for my upgrade from 2008R2 to 2012R2. 

    Only the homepage has changed. 

    direct url to these downloads now :


    • Edited by subglo Monday, June 25, 2018 11:08 AM
    Monday, June 25, 2018 11:07 AM
  • Just working my way up from 2008r2 to 2016. Thanks for a great tip, saved hours of headaches.
    Friday, November 2, 2018 4:49 AM
  • Thank you!!!!

    It's so glad to have this when I got the issue years later.

    Really appreciate it!

    Saturday, May 11, 2019 10:15 AM
  • Thank you. That was a time saver.
    Monday, June 17, 2019 10:51 AM
  • This worked for me as well on VMWARE 6.0 with a 2008 R2 upgrade to 2012 R2.  Not sure why we suddenly had this show up, but it did and this fixed it.
    Monday, September 23, 2019 6:25 PM
  • Thank you! Saved me lots of time. I would have missed my flight.
    Friday, October 11, 2019 8:37 PM
  • Hi,

    Use the drive in Windows Server 2012 R2 over DL380 G5 it Work!!

    Thursday, October 31, 2019 5:44 PM
  • That is actually pretty good for that card.   PERC4 was ancient in in 2016/
    Wednesday, November 27, 2019 7:50 PM
  • Thanks so much man! it works in a wmware 5.01 environment
    Monday, December 16, 2019 6:25 PM
  • It worked for me !

    Thank you very much!

    Monday, April 13, 2020 3:22 PM
  • Thanks

    LSI site and driver was moved to https://docs.broadcom.com/docs/12349638

    Saturday, May 30, 2020 5:30 PM
  • This one worked for me . Thanks Sacrificer

    Friday, July 17, 2020 6:50 PM
  • Thank you @Sacrificer - This worked for me!!
    • Proposed as answer by Shyam123nz Monday, July 20, 2020 8:09 PM
    • Unproposed as answer by Shyam123nz Monday, July 20, 2020 8:09 PM
    Monday, July 20, 2020 8:09 PM