none
Server 2008 R2: Access denied in Remote Desktop Services managers

    Question

  • Server: Windows Server 2008 R2 with Remote Desktop Services.

    Environment has a SBS 2008 as the PDC.

     

    Error: When logging on as a Administrator via RDP, I launch Remote Desktop Services Manager. Once there, I select Sessions, and right click on the session I would like to monitor/assist and select 'remote control' Once the dialogue box appears telling me about the hot keys, I click ok, and instead of connecting to the user, I get an 'Access Denied'

     

    Anyone have this issue?

     

    Any help would be appreciated.

     

    Cheers

    Friday, February 25, 2011 8:38 PM

Answers

  • Hi,

     

     

    Have you checked whether this user has enough remote control permission on the RDS server?

     

    RD session host configuration -> connection -> RDp-Tcp -> Security Tab

     

    Also, the following GPO   setting is used for configuring Remote Control:

     

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections

     

     

     

    Thanks.

    Monday, February 28, 2011 8:06 AM
    Moderator

All replies

  • Please check the Remote Desktop Configuration and Group Policy settings regarding session remote control.

    Benny

    Saturday, February 26, 2011 11:19 AM
  • Hi,

     

     

    Have you checked whether this user has enough remote control permission on the RDS server?

     

    RD session host configuration -> connection -> RDp-Tcp -> Security Tab

     

    Also, the following GPO   setting is used for configuring Remote Control:

     

    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Connections

     

     

     

    Thanks.

    Monday, February 28, 2011 8:06 AM
    Moderator
  • Alan and Benny, thank you for your replies.

     

    Alan, based on your instructions, this is what I did.

     

    RD session host configuration > connections -> Right clicked on RDp-Tcp -> Security Tab


    SYSTEM - Has full control

    LOCAL SERVICE - Special Permissions, all others are not selected

    NETWORK SERVICE - SAME AS ABOVE

    Administrators - full control

    Remote Desktop Users - User access and Guest Access

    Interactive - Special access

     


    I added the Domain admin account with full access, that did not fix the issue.

     

    The domain Admin account which I am using, is part of the Administrators and RDP users group, however I've added the admin account under the security tab with full permissions.

    I've also verified the Group Policy settings, located here:

    Local Computer Policy \ Administrative Templates \ Windows Components \Remote Desktop Services\Remote Desktop Session Host\Connections

    none of the policies located under the 'Connections' key are configured, all are set to 'Not configured'

    Cheers,

     

    Anil

     

    Wednesday, March 02, 2011 4:59 PM
  • Hi,

     

     

    Please let’s know the detail Event log including Event ID when this issue happens for the further research, Thanks.

    Thursday, March 03, 2011 2:48 AM
    Moderator
  • Alan, just recreated the error, checked the event log,

     

    Description: Faulting application name: Showcase.exe, version: 1.0.0.44, time stamp: 0x4a5ad5a3 Faulting module name: jscript.dll, version: 5.8.7600.16732, time stamp: 0x4d240066 Exception code: 0xc0000005 Fault offset: 0x00016425 Faulting process id: 0x4d28 Faulting application start time: 0x01cbda75bd763880 Faulting application path: C:\Users\xxxxx\AppData\Roaming\Amadeus\Viewer\Showcase.exe

    Faulting module path: C:\Windows\SysWOW64\jscript.dll Report Id: 152d5b06-4669-11e0-ac47-0050568252ca

    Friday, March 04, 2011 3:29 PM
  • Hi.

     

     

    This issue seems like an application conflict when doing shadow, so I would perform a clean boot to isolate this issue, and you might find some useful clue by a mini dump if possible.

     

    How to read the small memory dump files that Windows creates for debugging

    http://support.microsoft.com/kb/315263

     

     

     

     

    Thanks.

    Monday, March 07, 2011 3:49 AM
    Moderator
  • I've been looking for an answer to this same issue for days now.  Same issue as described above:

    Error: When logging on as a Administrator via RDP, I launch Remote Desktop Services Manager. Once there, I select Sessions, and right click on the session I would like to monitor/assist and select 'remote control' Once the dialogue box appears telling me about the hot keys, I click ok, and instead of connecting to the user, I get an 'Access Denied'

    Both users local administrators.  This problem exists on all my 2008 R2 servers. 

    Not sure this will help anyone but the source of our problem turned out to be an older version of mstsc.exe on my colleagues desktop.  He did not realize this was an .exe in lieu of a shortcut to the proper version included with his Windows 7 OS.  (This was copied with data to his new computer)  Really frustrating for all of us to identify. (older mstsc.exe not synchronized with correct mstscax.dll)

    • Proposed as answer by kmacarthur Monday, March 05, 2012 8:28 PM
    • Edited by kmacarthur Monday, March 05, 2012 8:31 PM
    Friday, March 02, 2012 7:32 PM