none
Add Node to Cluster - Keyset does not exist

    Question

  • Hi,

    I am trying to add third node to a Windows 2012 fail over cluster, but gets the following error.

    The server 'DR.domain.com' could not be added to the cluster.
    An error occurred while adding node 'DR.domain.com' to cluster 'domain-fc'.

    Keyset does not exist

    The User I am using to Add Node is Domain Admin, so it may not be a permission issue.

    All nodes are Windows 2012 R2 VMs on Azure


    Usman Shaheen MCTS BizTalk Server http://usmanshaheen.wordpress.com


    Tuesday, March 31, 2015 4:41 AM

All replies

  • Hi Usman,

    This error was created by azure or hyper-v cluster ?

    Could you please try to find if there is  any related event log in cluster manager/windows event log  then post it here for us ?

    Generally , when you add a server to a cluster, we strongly recommend that you start by connecting the server to the cluster networks and storage and then run the cluster validation wizard, specifying both the existing cluster nodes and the new node .

    Best Regards,

    Elton Ji


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .

    Thursday, April 2, 2015 2:31 AM
    Moderator
  • Hello,

    I'm interested for a solution as-well, I am facing the same problem with "Keyset does not exist" while adding a node. The node was previously added, then I removed it for machine renaming as recommended by MSFT articles

    My Cluster is under 2008 R2, with simple services like MSMQ, SQL, DTC. I don't use it for VMs or Azure

    Every time now I try to add a node, I see the following message bellow. The node is added to the list of Nodes and right after removed with "unable to successfully cleanup" in the end.

    The server 'node_machine.dom.lan' could not be added to the cluster.
    An error occurred while adding node 'node_machine.dom.lan' to cluster 'cluster_name'.
    Keyset does not exist

    • Trying to add another machine give the same error
    • Keyset problems are certificates related, I regenerated them and gave read permission to folder RSA for the account NETWORK SERVICE
    • Deleted all the archived certificates and old certificates and kept only the machine certificate
    • Can be this related to SHA256 algorithm ? I recently regenerated the CA certificate to SHA256, my renewed certificated are in SHA256

    Some help would be great, I start to get dry of ideas

    Thanks

    Wednesday, May 6, 2015 7:41 AM
  • I am facing an identical issue, if by any chance you have come across the solution, please update.
    Wednesday, May 6, 2015 5:02 PM
  • +1 

    I am also seeing the same issue

    Kerberos status shows Keyset does not exist.

    Monday, June 8, 2015 10:06 PM
  • Hello,

    The following solution worked for me: http://chrishayward.co.uk/2015/07/02/windows-server-2012-r2-add-cluster-node-cluster-service-keyset-does-not-exist/

    The fix was to correct the permissions on the C:\ProgramData\Microsoft\Crypto\RSA folder.

    Regards


    Thursday, July 2, 2015 2:43 PM
  • Hi

    does not Work for me... help ?

    Monday, September 14, 2015 7:17 PM
  • Are you still experiencing the problem?
    Monday, March 12, 2018 10:27 AM
  • Are you still experiencing this problem?
    Monday, March 12, 2018 10:28 AM
  • Yes we are, facing the same issue for Sql Server 2016(on Windows Server 2016) while trying to add a VM from a second site(which is our proposed DR Site, over a S2S connection), both sites are on Azure Stack multimode environment.
    Monday, April 15, 2019 8:01 AM