none
GPP - Task scheduler bug?

    Question

  • Found this bug (?) in GPP task scheduler.
    Notice the "Start task only if the computer is idle for" checkbox is deselected on the left side.
    On the right side is is the settings from Group Policy Management Console. Notice it is set for 5 minutes.
    If you select the box make changes to either"start task" or "wait for idle", click apply, unselect the box, click apply and then refresh the policy those changes will be there.

    Took me a while to figure out why scheduled tasks weren't running correctly
    Thursday, September 22, 2011 1:20 PM

All replies

  • Hi,

    Have you configure some special policy setting that will block it?

    Please try to check the related event warning and error first.

    Regards!

    Friday, September 23, 2011 6:10 PM
  • I don't think you understand what is going on with the problem.

    1.) Open group policy
    2.) Create a new policy
    3.) Create a scheduled task
    4.) Leave the "Start the task..." unchecked.
    5.) Click Apply, Ok and then Close the policy
    6.) Highlight the policy and then on the right hand side select settings
    7.) Expand the Scheduled task and you will find that the "Start the task..." is enabled even though it is not selected in step 4.)

    Change any of the "Start the task..." settings and deselect the "Start the task..." you will find that the task keeps that setting.


    (UPDATE)
    The main issue is that you need to wait for the computer to idle.  The task eventually ran about 20 minutes later when the computer was idle.
    I need the task to run 30 seconds after login, not 5 minutes after the computer is idle.

    • Edited by HaroldG Friday, September 23, 2011 6:21 PM
    • Proposed as answer by Yan Li_Moderator Tuesday, September 27, 2011 9:36 AM
    • Unproposed as answer by Yan Li_Moderator Tuesday, September 27, 2011 10:09 AM
    Friday, September 23, 2011 6:17 PM
  • Hi,

     

    We have performed a test on my side. We could reproduce the issue. Although we have not configured the “Start task only if the computer is idle for" option, it is listed in the GPMC management console. However, this is only a GPMC display problem. When we verify the property of the resulting schedule task, the “Start task only if the computer is idle for” option is not checked. The following is my test steps and corresponding result:

     

    1.) Open group policy
    2.) Create a new policy
    3.) Create a scheduled task, set the Trigger as “On a schedule” in “Begin the task” list box, select “One time” in the “Settings” check box, and configure a time. In my case, I configured a time which is only 2 minutes after the current time.

    4.) In the Action tab, add an action to start NotePad.
    5.) Leave the "Start the task..." unchecked, click Apply.

    6.) Refresh the group policy by running “gpupdate /force”.

     

    Result:

    1.       In the GPMC console, the “Start the task only if the computer is idle for” option is displayed.

    2.       On the computer which applies the group policy, open the Task Scheduler snap-in, and highlight the Task Scheduler Library item. You will find the deployed schedule task. The “Start task only if the computer is idle for" option is not configured when you open the property dialog of this schedule task.

    3.       Notepad is launched properly 2 minutes later.

    Based on the test result, this should only be an issue with GPMC display. The task is created properly. Please perform the same test on your side to see whether it works.


    Laura Zhang - MSFT

    Wednesday, September 28, 2011 6:31 AM
    Moderator