none
Where are tsadmin.msc and tsconfig.msc? RRS feed

  • Question

  • I just installed a copy of Windows Server 2012 but I'm not able to configure RDP Settings and manage RDP Connections as usual because the specific MMC snapins (tsconfig.msc and tsadmin.msc) appears to be missing.

    The tools also seem to be missing from "Server Manager/Add Role and Features".

    There is a new way to perform these tasks?

    Friday, August 17, 2012 3:17 PM

Answers

All replies

  • Hi,

    From the Understand and Troubleshoot Remote Desktop Services guide:

    RDS management tools used in previous version of Windows such as TSADMIN and TSCONFIG are no longer present in Windows Server "8" Beta, and management functions that administrators were used to performing with these tools are now accomplished by the new RDMS user interface.

    -Greg


    P.S What's new in RDS
    Saturday, August 18, 2012 8:37 PM
  • OK, but the new scenario is applicable only to domain systems and does not consider the RDP service usage for Remote Server Administration only.

    Monday, August 20, 2012 9:37 AM
  • Yes this is a real pain ....

    I to need to get this set up as out the box it only appears to allow 1 session per user as was the case with 2008.

    I can't find any PowerShell cmdlets to help so I assume it's a matter of looking in the registry.

    Monday, August 20, 2012 8:25 PM
  • For remote adminstration purposes, all you have to do is Enable remote management.  This can be done from Server Manager > Local Server.  And, I had two users with admin privileges logged in with no problem.  From a licensing standpoint, this is what is allowed.

    I'm curious.  What more are you trying to accomplish?


    tim

    Monday, August 20, 2012 9:59 PM
  • For remote adminstration purposes, all you have to do is Enable remote management.  This can be done from Server Manager > Local Server.  And, I had two users with admin privileges logged in with no problem.  From a licensing standpoint, this is what is allowed.

    I'm curious.  What more are you trying to accomplish?


    tim


    For example, with Windows Server 2012 and RDP in Admin Mode Only there is no way to change the certificate used to encrypt the RDP traffic.
    Tuesday, August 21, 2012 8:58 AM
  • With server 2008 for remote desktop Admin mode the default setting was to restrict each specific user account to a single session although you could indeed have 2 concurrent admin connections if they were different accounts.

    Can't see how to change this in 2012?

    Tuesday, August 21, 2012 6:58 PM
  • I needed to alter the certificate as well.  I ran TSConfig.msc on a Windows Server 2008 R2 server then right clicked and choose to connect to another machine.  I entered the IP Address of my 2012 server and it let me adjust the certificate.  I was not able to figure out how to do this directly within Server 2012.
    Tuesday, October 23, 2012 7:51 PM
  • With server 2008 for remote desktop Admin mode the default setting was to restrict each specific user account to a single session although you could indeed have 2 concurrent admin connections if they were different accounts.

    Can't see how to change this in 2012?

    Hi:

    Simply disable the “SingleSessionPerUser” Terminal Services setting. This works immediately with no reboot required.

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server]
    "fSingleSessionPerUser"=dword:00000000

    Thursday, November 8, 2012 3:39 PM
  • Hi 
    I have found a solution to the tsadmin problem. Copy these files from a 2008 server to the Windows 2012/8 computer under c:\windows\system32

    tsadmin.dll
    tsadmin.msc
    umcRes.dll
    wts.dll


    Then import these registry settings and you have Tsadmin.msc working again! :) 

    --------------------------------------------------------------------------------------------------------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}]
    "ApplicationBase"=hex(2):43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,77,00,\
      73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,00,00
    "About"="{00000000-0000-0000-0000-000000000000}"
    "VersionStringIndirect"="@C:\\Windows\\System32\\umcRes.dll,-106"
    "ProviderStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,\
      00,6f,00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,\
      5c,00,75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,\
      00,31,00,30,00,32,00,00,00
    "NameString"="Remote Desktop Services Manager"
    "HelpTopic"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,\
      74,00,25,00,5c,00,68,00,65,00,6c,00,70,00,5c,00,74,00,73,00,5f,00,6d,00,61,\
      00,6e,00,61,00,67,00,65,00,72,00,2e,00,63,00,68,00,6d,00,00,00
    "AssemblyName"="tsadmin"
    "RuntimeVersion"="v2.0.50215"
    "Description"="Manage Remote Desktop Services sessions"
    "DescriptionStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,\
      64,00,6f,00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\
      00,5c,00,75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,\
      2d,00,31,00,30,00,34,00,00,00
    "LinkedHelpTopics"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,\
      00,6f,00,74,00,25,00,5c,00,68,00,65,00,6c,00,70,00,5c,00,74,00,73,00,5f,00,\
      6d,00,61,00,6e,00,61,00,67,00,65,00,72,00,2e,00,63,00,68,00,6d,00,00,00
    "NameStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,\
      00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
      75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,\
      00,30,00,33,00,00,00
    "IconIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,77,\
      00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,\
      6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,00,31,\
      00,31,00,00,00
    "FxVersion"="2.0.1.7"
    "Type"="Microsoft.TerminalServices.Monitor.SnapIn.TSManagerSnapIn, tsadmin, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    "FolderBitmapsColorMask"=dword:00000000
    "ModuleName"="tsadmin.dll"
    "Provider"="Microsoft Corporation"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}\NodeTypes]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}\Standalone]

    --------------------------------------------------------------------------------------------------------
    • Proposed as answer by Vovanexe Tuesday, April 1, 2014 9:51 AM
    Tuesday, March 11, 2014 4:50 PM
  • Hi 
    I have found a solution to the tsadmin problem. Copy these files from a 2008 server to the Windows 2012/8 computer under c:\windows\system32

    tsadmin.dll
    tsadmin.msc
    umcRes.dll
    wts.dll


    Then import these registry settings and you have Tsadmin.msc working again! :) 

    --------------------------------------------------------------------------------------------------------

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}]
    "ApplicationBase"=hex(2):43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,77,00,\
      73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,00,00
    "About"="{00000000-0000-0000-0000-000000000000}"
    "VersionStringIndirect"="@C:\\Windows\\System32\\umcRes.dll,-106"
    "ProviderStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,\
      00,6f,00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,\
      5c,00,75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,\
      00,31,00,30,00,32,00,00,00
    "NameString"="Remote Desktop Services Manager"
    "HelpTopic"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,\
      74,00,25,00,5c,00,68,00,65,00,6c,00,70,00,5c,00,74,00,73,00,5f,00,6d,00,61,\
      00,6e,00,61,00,67,00,65,00,72,00,2e,00,63,00,68,00,6d,00,00,00
    "AssemblyName"="tsadmin"
    "RuntimeVersion"="v2.0.50215"
    "Description"="Manage Remote Desktop Services sessions"
    "DescriptionStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,\
      64,00,6f,00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,\
      00,5c,00,75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,\
      2d,00,31,00,30,00,34,00,00,00
    "LinkedHelpTopics"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,\
      00,6f,00,74,00,25,00,5c,00,68,00,65,00,6c,00,70,00,5c,00,74,00,73,00,5f,00,\
      6d,00,61,00,6e,00,61,00,67,00,65,00,72,00,2e,00,63,00,68,00,6d,00,00,00
    "NameStringIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,\
      00,77,00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,\
      75,00,6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,\
      00,30,00,33,00,00,00
    "IconIndirect"=hex(2):40,00,43,00,3a,00,5c,00,57,00,69,00,6e,00,64,00,6f,00,77,\
      00,73,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,\
      6d,00,63,00,52,00,65,00,73,00,2e,00,64,00,6c,00,6c,00,2c,00,2d,00,31,00,31,\
      00,31,00,00,00
    "FxVersion"="2.0.1.7"
    "Type"="Microsoft.TerminalServices.Monitor.SnapIn.TSManagerSnapIn, tsadmin, Version=6.1.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
    "FolderBitmapsColorMask"=dword:00000000
    "ModuleName"="tsadmin.dll"
    "Provider"="Microsoft Corporation"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}\NodeTypes]

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MMC\SnapIns\FX:{3FCE72B6-A31B-43ac-ADDA-120E1E56EB0F}\Standalone]

    --------------------------------------------------------------------------------------------------------

    Thanks, it works!
    Tuesday, April 1, 2014 10:00 AM
  • Great! It works except one thing, when I want to remote control a user i get "Access Denied". Any Idea?
    • Proposed as answer by SkyHawkTech Friday, September 5, 2014 8:08 PM
    Monday, April 7, 2014 6:33 AM
  • It doesn't seem to work with Server 2012 R2..
    Friday, September 5, 2014 8:08 PM
  • try RD Admin http://software.spoit.de, maybe this will help you
    Monday, November 24, 2014 6:30 PM
  • I think the truly easy answer was missed.  The local server functionality of TSAdmin was moved into Task Manager.  Just go to the Users tab.  All of the previous functionality is there, just right click the user name.
    • Proposed as answer by ngroon Wednesday, January 14, 2015 8:25 PM
    Wednesday, January 14, 2015 8:24 PM
  • Except for SHADOWING / REMOTE CONTROL

    Monday, June 29, 2015 8:35 AM
  • how about connecting to other servers - can't do that with task manager
    Monday, July 20, 2015 1:20 AM
  • microsoft - removing features we like.

    i'm seriously wondering if the design team are trying to make the OS less admin-friendly on purpose.

    Monday, September 14, 2015 8:23 AM
  • Hi All,

    You can do the same via powershell using the below commands.

    Query session /server:YOURSERVER NAME
    Reset session YOURSESSION ID /server:YOURSERVER NAME


    Gautam.75801

    • Proposed as answer by Felyjos Friday, October 27, 2017 11:54 PM
    Thursday, October 22, 2015 1:19 PM
  • Thanks Gautam. PS did the trick for me.
    Thursday, January 21, 2016 10:49 PM
  • Good to hear that 

    Gautam.75801

    Friday, January 22, 2016 4:11 AM
  • Thanks for pointing this out...  Totally stumped until you pointed this out.
    Thursday, January 28, 2016 3:16 AM
  • That's not true, there is no way to see how long a user has been idle there.
    Monday, September 25, 2017 11:03 AM
  • Now THAT was the answer I was looking for.

    Monday, November 5, 2018 4:38 PM