The RPC server is unavailable


  • I have installed the Microsoft KMS service version 1.1 on a Windows 2003 server with SP2 and have successfully activated using a Windows 2008 STD/ENT KMS license.
    However, when I try to activate Windwos 2008 clients using the slmgr.vbs -skms Server_FQDM:port I keep getting the following error message: Error 0x800706AB occurred in connecting to server -skms. Error description The RPC service is unavailable.
    However, I have been able to telnet from the clients into the KMS host using the KMS service port without any problem.
    I have also tried using /skms instead of -skms but in this case I get a different error indicating that the parameter used is invalid.
    I do have way over 5 Windows 2008 clients but none of them is communicating with the KMS service for activation.
    On the KMS host the KMS service v1.1 has been installed, a patch has been installed, the KMS service has been activated and reports to be licensed and active.
    Does any one has any idea on how to solve thsi issue?   Or any idea on how further troubleshoot it?
    Saturday, February 21, 2009 7:24 AM

All replies

  • Hello,
    Do you mean  0x800706BA rather than  0x800706AB?

    Open an elevated CMD prompt on the KMS client machines:
    from that prompt run:
    Slmgr -dlv

    From that output what is on the Description line?

    Also check the Firewall settings on both the KMS client machines and KMS host machines.

    Thanks, Darrell Gorter[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Saturday, February 21, 2009 10:28 PM
  • Yes, you're right that is the correct error code number.
    The information displayed when I run the slmgr -dlv command is "Software Licensing Service Version 6.0.6001.18000
    The Windows firewall has been truned off on the cleints and KMS host.

    Thanks for you help.
    Sunday, February 22, 2009 12:12 AM
  • Hello,
    When you run slmgr -dlv from the elevated cmd prompt is the only line you get the one you posted?
    You should see output similar to this:

    Microsoft (R) Windows Script Host Version 5.7                                         

    Copyright (C) Microsoft Corporation. All rights reserved.                                                                                                                    

     Software licensing service version: 6.0.6002.16670                                    

    Name: Windows(TM) Vista, Enterprise edition                                           

    Description: Windows Operating System - Vista, VOLUME_KMSCLIENT channel                

    Activation ID: <XX>                                  

     Application ID: <XX>                                  

    Extended PID: <XX>                                  

    Installation ID: <XX>                                                   

    Partial Product Key: 4BWMV                                                           

     License Status: Licensed                                                               

    Volume activation expiration: 256260 minute(s) (177 day(s))                           

    Evaluation End Date: 6/1/2010 4:59:59 PM                                                                                                                                      

    Key Management Service client information                                                 

    Client Machine ID (CMID): 0d87690a-0172-439b-a562-93980caa1ba9                       

     KMS machine name from DNS: <XX>                                  

     KMS machine extended PID: <XX>                                             

    Activation interval: 120 minutes                                                      

    Renewal interval: 10080 minutes                                                    


    Thanks, Darrell Gorter[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Monday, February 23, 2009 12:36 AM
  • Yes that is the only line that I get from the clients (Windows server 2008 standard edition).

    From the host I get more information but only form the host.
    Monday, February 23, 2009 5:27 PM
  • Hello cr_m,
    I would re-enter the product key on the clients then.
    Use slmgr -ipk with the generic Volume license keys for the edition that you have installed.
    Thanks, Darrell Gorter[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Monday, February 23, 2009 6:50 PM
  • Thanks, I already tried that and it did not work since it throws an error indicating that it is an invalid license.
    Monday, February 23, 2009 7:05 PM
  • Hello cr_m,
    What is the exact error code that you are getting when you do that?

    Thanks, Darrell Gorter[MSFT] This posting is provided "AS IS" with no warranties, and confers no rights
    Tuesday, February 24, 2009 7:38 PM
  • I have this same problem.  Has anyone that has gotten this problem solved it?

    This doesn't happen to me if I install Windows 2008 Core manuelly.  But if I use an unattend.xml file to control the setup of the system I can never get it to activate.  The error is 

    Error 0x800706BA occurred in connecting to server -skms.
    Error description: The RPC server is unavailable. .

    I have also tried using the generic activation code from the pid.txt and it fails as well with the same error.

    Since this only happens when I use an unattend.xml I assume that there is a problem/setting with the xml file that I don't know about and as of yet can't find.  If anyone has any ideas I would be grateful.  Thanks.
    Monday, March 09, 2009 2:46 PM
  • In my case, I found an answer.  My unattend.xml file was a modified version of an xml that had been used to install a normal Windows 2008 standard server.  The original server xml used the 

        <Key>PRODUCT KEY</Key>

    in the Microsoft-Windows-Setup component.  When I finally noticed this in the XML for my Core Server setup and removed it my "The RPC server is unavailable" problem went away.
    Tuesday, March 10, 2009 7:14 PM
  • Pleasse...I am having the same issue, but ONL:Y when I use a second log in account, (my wife's, heh heh)...Please talk to me like I am 7 and tell me exactly what to do to rid this problem...i too get the 0x800.....and my script host response seems normal...alot of info...not just a few lines...ALSO...I have WV 64-bit...thx

    I've got nasty habits...
    Tuesday, March 17, 2009 12:58 AM