none
Windows 7 backup/restore not working RRS feed

  • Question

  • Nothing related to windows backup, restore, restore points, or vss seems to be working.

    It has been like this for some time.

    Platform: windows 7 SP1 x64

    Keeps pretty current with patches (meaning it's also had some bad ones from MS over the years)

    Also running Acronis True Image 2016 without issues.

    Not even basic vss functionality seems to be working:

    C:\Windows\system32>vssadmin list writers
    vssadmin 1.1 - Volume Shadow Copy Service administrative command-line tool
    (C) Copyright 2001-2005 Microsoft Corp.
    Error: A Volume Shadow Copy Service component encountered an unexpected error.
    Check the Application event log for more information.

    C:\Windows\system32>

    sfc /scannow:

    Windows Resource Protection did not find any integrity violations.

    The above vssadmin shows this in application log:

    Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {e579ab5f-1cc4-44b4-bed9-de0991ff0623} and Name IVssCoordinatorEx2 is [0x80040154, Class not registered
    ]. 

    Operation:
       Instantiating VSS server

    I've tried most of the options here:

    https://social.technet.microsoft.com/Forums/office/en-US/2b1f44e0-725a-4fc5-bc1d-69437871fe90/wierd-volume-shadow-copy-service-errors?forum=winserverfiles

    and here

    http://social.technet.microsoft.com/Forums/en-US/w7itprogeneral/thread/5587519b-6a84-45b0-9948-36f4f3416379/?prof=required]

    (eg deleting com3)

    Without any change.

    I would like to get the restore point capability back.

    Any ideas or suggestions?

    Thanks.

    Sunday, October 9, 2016 7:17 PM

All replies