none
Hyper-V Live Migration to Windows Server Technical Preview and Not All Migrated VMs Visible RRS feed

  • Question

  • Hello

    I am busy trying out Hyper-V on Windows Server Technical Preview and I moved some VMs from a Windows Server 2012 R2 machine using the live migration feature within the Hyper-V Manager but after moving 6 VMs only 3 appear in Hyper-V manager in the Windows Server Technical Preview instance although all 6 VMs are running from there.

    One VM that hasn't shown up is running Ubuntu 14.04 and the other two are running Windows Server 2012 R2. The 3 that appear are the first ones I migrated.

    After migration the other ones appear initially but after I refresh they disappear again.

    Thanks

    Robin

    Edit: If I run Get-VM in PowerShell then all 6 are listed







    Sunday, October 5, 2014 6:36 PM

Answers

  • Unfortunately, this is a known bug in the Technical Preview release.

    The specific issue is that Hyper-V Manager gets confused if a virtual machine returns basic heartbeat information, and does not include application health state.  Luckily - there is a simple work around.  If you run the following PowerShell line:

    get-vm | ?{$_.heartbeat -eq "OKApplicationsUnknown"} | Disable-VMIntegrationService "Heartbeat"

    This will turn off the Heartbeat service for any virtual machine that is not returning application state.

    Cheers,
    Ben


    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    • Proposed as answer by TP []MVP Monday, October 6, 2014 7:08 PM
    • Marked as answer by robinwilson16 Wednesday, October 8, 2014 9:42 PM
    Monday, October 6, 2014 2:55 AM

All replies

  • Unfortunately, this is a known bug in the Technical Preview release.

    The specific issue is that Hyper-V Manager gets confused if a virtual machine returns basic heartbeat information, and does not include application health state.  Luckily - there is a simple work around.  If you run the following PowerShell line:

    get-vm | ?{$_.heartbeat -eq "OKApplicationsUnknown"} | Disable-VMIntegrationService "Heartbeat"

    This will turn off the Heartbeat service for any virtual machine that is not returning application state.

    Cheers,
    Ben


    This posting is provided AS IS with no warranties, and confers no rights. You assume all risk for your use.

    • Proposed as answer by TP []MVP Monday, October 6, 2014 7:08 PM
    • Marked as answer by robinwilson16 Wednesday, October 8, 2014 9:42 PM
    Monday, October 6, 2014 2:55 AM
  • Hello Ben

    Thanks for the reply.

    I can confirm this has worked and all the VMs appeared as soon as I ran this which has to be run as administrator.

    All the VMs (apart from one) run on Windows Server 2012 R2 so is there any reason why some would be returning that information whilst others do not?

    Will turning this off have any effect and I assume I should probably turn it back on again once I migrate to the next preview build.

    Thanks for the help.

    Robin


    Robin Wilson

    Wednesday, October 8, 2014 8:01 PM