none
Error executing Enable-PSRemoting or Set-WSManQuickConfig on XP Home RRS feed

  • Question

  • I receive the following error when I execute Enable-PSRemoting and confirm I want to continue:

    Set-WSManQuickConfig : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="5" Machine="cav"><f:Message>Access is denied. </f:Message></f:WSManFault>
    At line:50 char:33
    +             Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

    The same error - just a different line number - occurs when I run Set-WSManQuickConfig.

    I have seen this similar post here (http://social.technet.microsoft.com/Forums/en/winserverpowershell/thread/e1eabe4c-0796-420e-b03e-dffc71760b8d) but the solution - running secpol.msc to set the local security policy to Classic - doesn't work since XP Home doesn't include secpol.msc.

    Does anyone have any suggestions? 

    Thanks,
    Tim
    Saturday, December 5, 2009 3:39 PM

All replies

  • Yes, this is a known issue.

    Can you try setting this registry key:
    The following line will turn off forceguest, set the security model to classic:
    Set-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Control\Lsa forceguest 0

    The following line will turn on forceguest.
    Set-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Control\Lsa forceguest 1

    Now, I don't have XP Home, so I can't confirm which of these may be required actually as I'm just copying this from elsewhere.
    Saturday, December 5, 2009 3:51 PM
    Moderator
  • Thanks for the help.  The second suggestion doesn't seem to change anything - I get the same error.  Perhaps I'm making some progress using your first suggestion though as I do get a different error message.

    Executing Enable-PSRemoting after setting forceguest to 0, I get this:

    Set-WSManQuickConfig : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="12004" Machine="cav"><f:Message>An internal error occurred in the Microsoft Windows HTTP Services </f:Message></f:WSManFault>
    At line:50 char:33
    +             Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

    Any thoughts on where to go from here?

    Thanks again,
    Tim
    Tuesday, December 8, 2009 4:53 PM
  • Scratch that... I'm not sure what the new error message was all about as I've not been able to repeat it again.  Regardless of which way I set forceguest, I'm getting the original error. 
    Tuesday, December 8, 2009 4:59 PM
  • Anyone else have any thoughts on how to fix this error?
    Thursday, December 10, 2009 5:31 PM
  • *shameless bump* 
    Wednesday, January 6, 2010 6:27 PM
  • I forgot about this.  I installed XP Home, and didn't get any further...  Reviewed some of my archives and didn't get any hints that helped other than what we've already tried.

    I wonder if I change the winrm quickconfig setup to "clear text only", maybe that will work.  I will work on it...
    Wednesday, January 6, 2010 10:39 PM
    Moderator
  • Hi Tim,

    The Set-WSManQuickConfig cmdlet configures the computer to receive PowerShell remote commands that are sent by using WSMan

    The cmdlet performs the following:

        1. Checks whether the WinRM service is running. If the WinRM service is not running, the service is started.

        2. Sets the WinRM service startup type to automatic.

        3. Creates a listener to accept requests on any IP address. By default, the transport is HTTP.

        4. Enables a firewall exception for WSMan traffic.

    And the error is "An internal error occurred in the Microsoft Windows HTTP Services", I would like to confirm if IIS was installed on your Windows XP Home system? By default, IIS cannot be installed on Windows XP Home and Microsoft doesn’t support IIS on Windows XP Home.

    You may try to run Enable-PSRemoting on Windows XP Pro to test.

    Thanks.

    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, January 8, 2010 6:33 AM
  • Hi Mervyn,

    I definitely do not have IIS installed on my machine, and that particular error - "An internal error occurred in the Microsoft Windows HTTP Services" - I get when I run Set-WSManQuickConfig.  The Access Denied message comes when I run Enable-PSRemoting.

    In any event, are you suggesting that IIS must be installed on a machine for remote scripting to work?  If so, it's a shame remote execution can't be done natively on XP Home.  It seems it should be possible, as the sysinternals psexec app runs on XP Home.

    Is it possible to perform the Enable-PSRemoting commands manually?  Steps 1, 2 & 4 are easily doable - though I'd need to know what the ports should be for step 4 - but I'm not sure what 3 entails.  Does this require IIS?

    If remote scripting simply isn't supported and can't be enabled, it's worth adding to the PS 2.0 release notes and docs.

    Thanks for the help. 
    Tim
    Friday, January 8, 2010 6:55 PM
  • I forgot about this.  I installed XP Home, and didn't get any further...  Reviewed some of my archives and didn't get any hints that helped other than what we've already tried.

    I wonder if I change the winrm quickconfig setup to "clear text only", maybe that will work.  I will work on it...
    Thanks for looking at it.  If it simply won't work on XP Home, I'd just like to know and it ought to be added to the notes.  But if for some reason the config steps have to be done manually but it can otherwise be enabled, I'd love to know how.  A lot of people have a network environments at home with many flavors of Windows.  Having PowerShell working on all and remotely invokable would be great.
    Friday, January 8, 2010 6:59 PM
  • Maybe it's just winrm that doesn't really work on XP Home.  Or at least, something on my machine is configured or misconfigured to make it behave badly.  I get the same errors just checking it's config.

    C:\Documents and Settings\Tim>winrm get winrm/config/client
    WSManFault
        Message = An internal error occurred in the Microsoft Windows HTTP Services

    Error number:  -2147012892 0x80072EE4
    An internal error occurred in the Microsoft Windows HTTP Services

    C:\Documents and Settings\Tim>winrm get winrm/config/client
    WSManFault
        Message = Access is denied.

    Error number:  -2147024891 0x80070005
    Access is denied.


    Friday, January 8, 2010 7:18 PM
  • Maybe it's just winrm that doesn't really work on XP Home.  Or at least, something on my machine is configured or misconfigured to make it behave badly.  I get the same errors just checking it's config.




    Yes agreed, PowerShell remoting is built-on WinRM.
    Friday, January 8, 2010 7:27 PM
    Moderator
  • According to info I found here:

    • WinRM is not dependent on any other service except WinHttp. If the IIS Admin Service is installed on the same computer, you might see messages that indicate WinRM cannot be loaded before Internet Information Services (IIS). However, WinRM does not actually depend on IIS .
    Also, I didn't notice it until now, but running Enable-PSRemoting, Set-WSManQuickConfig or winrm quickconfig, it get one more tidbit than just the error:

    WinRM already is set up to receive requests on this machine.
    Set-WSManQuickConfig : <f:WSManFault xmlns:f="http://schemas.microsoft.com/wbem/wsman/1/wsmanfault" Code="5" Machine="cav"><f:Message>Access is denied. </f:Message></f:WSManFault>
    At line:1 char:21
    + Set-WSManQuickConfig <<<<  -force
        + CategoryInfo          : InvalidOperation: (:) [Set-WSManQuickConfig], InvalidOperationException
        + FullyQualifiedErrorId : WsManError,Microsoft.WSMan.Management.SetWSManQuickConfigCommand

    So, it apparently got through a brief part of the setup, just not sure how far.  And like I said, I like to be able to confirm that it really can't run on XP Home if it can't.  I could very well be a config issue on this machine though.
    Friday, January 8, 2010 9:58 PM
  • I'd love to have this working here too. I have one machine with WinXP Pro (and yes, IIS is installed and running, that could cause me trouble later with Enable-PSRemoting) and one with WinXP Home. Both machines are SP3, both machines have the new WMI (or whatever it's now called) installed for XP. However on Home, I get the same error message as above, except for the "Internal error", I don't get that error.

    Just the "Access is denied". To the best of my knowledge, my user's in the Administrator group, and the title on the PowerShell window says:  Administrator: Windows PowerShell.

    Any further clues to getting this going on XP Home would be much appreciated.

     

    Cheers, Eric.

    Monday, July 26, 2010 4:56 AM
  • Have you made any more progress on solving this problem? I am having the same problem and am also running on a windows xp home computer. I did not find anything that said it would not run on this OS.

    Thanks,  Stan

       

    Thursday, September 2, 2010 4:44 PM
  • No progress on my end.  It would be nice to know for certain that it doesn't work on XP Home - other than just wondering if my machine has a busted config - or even better to have someone confirm that it does indeed work.  I have tried on one other XP Home machine though and received the same message, so my guess is it simply won't work.
    Thursday, September 2, 2010 8:11 PM
  • Looks like the link from previous post is dead.  Maybe this is the post that was being referred to.  

    Changing the prescribed setting did resolve the access denied error message on a Windows XP Pro machine.  Even though there is no secpol.msc on Windows XP Home, you can make the same change by manually modifying the following registry key like so:

    HKEY_LOCAL_MACHINE\system\currentcontrolset\control\lsa\forceguest  REG_DWORD       0x0

    This change however did not resolve the winrm quick config access denied error on a Windows XP Home computer.  The previous poster made no specific mention of XP Home Edition, so I can only assume the "fix" worked on an XP Pro computer.

    I also tried adding:

    HKEY_LOCAL_MACHINE\software\microsoft\Windows\currentversion\policies\system\LocalAccountTokenFilterPolicy       REG_DWORD       0x1 

    As suggested by this post:  http://www.shirmanov.com/2011/04/winrm-access-is-denied-on-local.html

    ...but that did not help either.

    I think this has something to do with fact that the administrator account is prohibited from logging into the desktop on a normal XP Home boot.  So far I have not figured a way around this except for booting into safe-mode.  

    I did try running winrm "quickconfig" while logged as the administrator during a safe-mode with network support boot and got the same error message.   

     

    WSManFault
    
    Message = Access is denied.
    
    Error number:  -2147024891 0x80070005
    
    Access is denied.

    The only other thing that I can think to try right now is to clone the built-in administrator account, then log as the cloned account during a normal boot, and try running winrm quickconfig.


    Wednesday, July 27, 2011 4:19 PM
  • Mentioned registry tricks won't work on Windows XP Home because this edition has hardcoded guest logon model. This model cannot be changed through registry (even if you change specified registry key). This is by design.


    My weblog: http://en-us.sysadmins.lv
    PowerShell PKI Module: http://pspki.codeplex.com
    Windows PKI reference: on TechNet wiki
    Tuesday, August 2, 2011 9:44 AM
  • "HKEY_LOCAL_MACHINE\system\currentcontrolset\control\lsa\forceguest  REG_DWORD       0x0"

    This one worked for me. I had the key but the value was set to 0x1 instead of 0x0.

    Tuesday, November 29, 2011 4:11 AM
  • Terasuma,

    Can you recap what you did exactly? And was it on WinXP Home?

    Thanks.

    Wednesday, November 30, 2011 3:09 PM
  • Thanks! The article to the link you provided resolved the issue.
    Monday, July 2, 2012 3:23 AM
  • I encountered a similar issue with Windows Server 2008 (non-R2).  Same error messages.

    Very interesting fix!..

    • I tried to reinstall .NET and .NET 2.0 SP2, the setup wouldn't complete
    • I extracted the netfx20sp.exe and tried to run setup.exe, which just didn't appear to start at all
    • By chance I ran 'dir' on the command line which crashed
    • Had a quick google for the dir appcrash and this was related to having no regional/language set correctly.
    • Open 'Control Panel' and go into 'Regional and Language Options'
    • The current language format didn't appear to be set correctly , so had defaulted to the format displayed at top of the list 'Afrikaans (South Africa)'.
    • Set to English and applied
    • Ran the 'Enable-PSRemoting' command again
    • Everything now works!
    Friday, June 13, 2014 9:42 AM