none
The Specified service has been marked for deletion

    Question

  • Dear All

    We are trying to start a service on my windows server 2003 sp2 based computer, the service is on stop state but when we try to start the service we face the message "The specified service has been marked for deletion".

    Please an urgent response is required from your side as this is a production server in our environment.

    Thanks in advance

    Hasnain 

      

    Monday, July 23, 2012 7:55 AM

Answers

All replies

  • What service? If its a windows service might check the event log for more error details. If it is third party service you may need to get in touch with developer.

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Monday, July 23, 2012 2:04 PM
  • Hi Dave

    Thanks for your reply, it is basically an application service. Can you tell me that in what circumstances this error occurs?

    Thanks

     

    Tuesday, July 24, 2012 5:13 AM
  • Hello,


    Can we know the name of the application and application service? If this is a 3rd-party application, then I agree with Patrick that it’s best to ask the software developer.


    If it’s a Microsoft Windows built-in service, such error can occur if the service was marked for deletion.  Do you see the DeleteFlag entry of this service in Registry HKLM\SYSTEM\CurrentControlSet\Services\YourService\DeleteFlag. If there is and the value is set to "1", reset it to "0".


    For your reference, take a look at the below MSDN blog.

    FTP service gets deleted on server restart
    http://blogs.msdn.com/b/httpcontext/archive/2012/05/10/ftp-service-gets-deleted-on-server-restart.aspx


    Thanks
    Zhang


    Tuesday, July 24, 2012 7:42 AM
    Moderator