Win7 Offline files exclusions not working as expected


  • Hi

    we have enabled offline files through Administratively assigned offline files (points to the redirected documents folder for each user)

    we try to exclude pst files from the sync but that does not work. Existing pst files are synchronized while the user is unable to create new ones.

    Does anybody else see the same behaviour ?

    We user windows 7 on client/ Windows 2008r2 on Server

    I guess the fact that the policy blocks the creation of the files at the server means only the upload is blocked, not the download...

    thanks in advance


    Wednesday, August 31, 2011 4:38 PM

All replies

  • Hi,


    I would like to confirm that do you mean the GPO had been applied but the files cannot be updated?


    Also I have concluded a similar thread here, please refer to it for further research:

    How to administratively assign offline "My Documents" folder?


    Hope this helps.

    Best Regards,

    Yan Li

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, September 05, 2011 2:53 AM
  • Hi

    What i mean is that the policy for folder redirection works fine

    the offline files policy also works, so it is applied.

    my problem lies with the presuposed functionality of the offline files settings.

    when i set the policy to filter out pst files, what i get is that the existing pst files on the network folder are synchronized down to the client. Also the user can't create Pst files anymore on the network folder.

    what i want to achieve is for users to be able to create pst files on the network folder without having those synchronized, as well as pre-existing pst files should not be downloaded to the client.

    for what i remember this is what storage policies were doing in the past, but this is somewhat misleading, as what you do is avoid file creation so that they are not downloaded, not filter the donwload itself.


    Monday, September 05, 2011 6:52 AM
  • Hi,

    As per the below article the .pst files are by default excluded from Offline file sync. Is there any error in event viewer

    Monday, September 05, 2011 8:34 AM
  • Hi


    the article applies to Windows XP, not Win7/Win2008R2


    Monday, September 05, 2011 8:39 AM
  • Hi,

    In windows 7 you have a policy Computer Configuration\Administrative Templates\Network\Offline Files\Exclude files from being cached

    Registry value is


    Check the below link

    Monday, September 05, 2011 1:26 PM
  • Hi

    that's the one I am using and that works only according to part of the documentation:

    first it states this

    On Windows 7, administrators can use the Offline Files exclusion list feature to prevent files of certain types (for example, MP3 files) from being synchronized.

    (I understand that sync does not take care of those files)

    then the document states what seems to be the reality

    Use this setting to exclude certain file types from being made available offline. You need to specify the file extensions of the file types that should be excluded. A user will then be unable to create a file of this type in the folders that have been made available offline.

    Those are of course two different ways to look at the problem. One way is to filter the files at sync time, the other one is preventing the user to create them, then sync all (which is aparently what is done)

    I guess the documentation should be more clear on this. I opened a call to Microsoft support.

    I will post update when/if there is a workaround

    Monday, September 05, 2011 1:34 PM
  • Hi,

    What is the issue status now? Have you got an result? If you have any issue please feel free let us know.


    Best Regards,

    Yan Li

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 07, 2011 1:12 AM
  • I am having the same issue... :(

    ExcludedFileTypes in registry HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetCache shows *.pst so policy applied fine.

    I disabled offline files on the client computer and re-enabled. Set my network folder to sync again.

    This time noticed it hang on my archive file backup.pst for 2-3 minutes.

    When I check the offline files folder I see the Outlook Data File there. Isn't it supposed to exclude the file??  Any help would be appreciated.



    Monday, October 24, 2011 10:24 PM
  • Same issue here....

    I want to exclude .pst files from being avaialble offline because they're too big.  This setting only stops me from creating NEW .pst files in the offline folder.  All of the existing .pst files are available offline but I don't want them to be.

    Did you get an answer on this?

    Monday, December 12, 2011 4:13 AM
  • same issue too... i cant believe there is no solution.

    please help me :)

    Friday, June 01, 2012 11:39 AM
  • Same. Would really appreciate if there would be some clarification on how this is used properly.
    Thursday, June 28, 2012 11:40 AM
  • Same issue, is there any solution available for this?



    Friday, February 08, 2013 8:52 AM
  • Same problem here too.

    We need an answer from Microsoft ASAP.

    This is a big issue,
    since as per Microsoft itself, Folder Redirection is a good practice, but
    Office 2010 creates PSTs files in My Docs folder, so this is a terrible contradiction.

    Even with you use Microsoft Exchange for e-mail,
    if an user creates a PST to do archiving or to synchronize with SharePoint
    features, the problem happens.

    I know many, many
    companies that use Folder Redirection and they are having many issues because
    of this.

    I think Microsoft
    need to post a workaround if is there a minimal respect for your costumers.

    Sunday, June 02, 2013 6:22 PM