locked
Error - The user name or password did not work - RDP APP RRS feed

  • Question

  • Microsoft Remote Desktop for iPhone keeps giving me an error, even tho I know the Userid and Password are correct.  Please advice on how to fix it. 

    This started happening after the new version release.  Previous version was working fine.  .


    Wednesday, September 10, 2014 2:30 PM

Answers

  • Just to report the latest 8.1.5 version which includes the NTLMv2 patch has fixed the problem.

    We are now able to login to our Server 2008 R2 terminal servers again.

    How MS released an update missing support for it in the first place I don't know, but thank you fox fixing it.

    • Marked as answer by nirav00 Tuesday, November 4, 2014 3:44 PM
    Friday, October 31, 2014 2:53 AM
  • Version 8.1.5 fixed the problem... Thanks
    • Marked as answer by nirav00 Tuesday, November 4, 2014 3:45 PM
    Tuesday, November 4, 2014 3:45 PM

All replies

  • The error " The user name or password did not work
    Wednesday, September 10, 2014 2:31 PM
  • Hi Nirav00,

    Can you please provide some more information:

    • Is this part of a RemoteResource feed?
    • Is this a desktop or a RemoteApp you are trying to connect to?
    • What server version are you connecting to? (Windows 8.1, Windows Server 2012 R2)?
    • Are you connecting via RDS Gateway?

    Regards,

    Tim

    Wednesday, September 10, 2014 2:35 PM
  • I am trying to connect as PC or Server Option.  When you go to app to add by your IP address.  Its the first option

    It is a Desktop that I am trying to connect. 

    Windows 7 Pro - SP1 64 Bits

    Unsure.  Once I enter the IP, it ask for domain and userid detail.  

    The app was working fine as is before the new release. 

    Wednesday, September 10, 2014 2:44 PM
  • This is the app https://itunes.apple.com/us/app/microsoft-remote-desktop/id714464092?mt=8
    Wednesday, September 10, 2014 2:52 PM
  • I am having the same issue.  App was functioning just fine until the update.  THis is the error:

    When the App is in "Admin Mode", I am able to connect with my Admin account.  If a regular user has "Admin Mode" enabled, they get further than this error message, but are met with: "The requested session access is denied"

    This shows that it appears to be a problem when the app is authenticating credentials.  The session see's the server, certificates are processed, but connection cannot be made due to the app not properly passing user credentials.

    • Proposed as answer by Saban Nurcan Saturday, September 13, 2014 2:19 PM
    • Unproposed as answer by Saban Nurcan Saturday, September 13, 2014 2:19 PM
    • Proposed as answer by ひなせ Sunday, September 14, 2014 5:10 AM
    • Unproposed as answer by ひなせ Sunday, September 14, 2014 7:48 AM
    Wednesday, September 10, 2014 5:01 PM
  • It's been reported that Remote Desktop Client for IOS is swaping '\' for '@' at the users credentials. Can you try to login with the user's UPN (user@domain)?
    Wednesday, September 10, 2014 6:57 PM
  • Not working for me.  I get:  "Error: The user name or password did not work."  Which is different, but still effectively the same result.
    Wednesday, September 10, 2014 7:00 PM
  • I have also tried this and it will not allow me to login.  Is it possible to revert to the previous version so things will work until this issue is resolved?
    Wednesday, September 10, 2014 9:05 PM
  • Tried it and it doesn't work.  The previous version was much better.  Very simple add IP, Enter UserID and Password.

    Way to go Microsoft....

    Thursday, September 11, 2014 9:17 PM
  • Is your user id a local account, domain account, or Microsoft account?

    For Microsoft accounts you no longer need to enter microsoftaccount\MyAccount@outlook.com, instead you can enter MyAccount@outlook.com.

    For domain accounts you can use any of the following formats:

    • <domain>\<username>
    • <username>@<domain>
    • <email>

    There is another thread tracking with people reporting issues with NTLM auth for HTTPS based GW.

    [Link]

    For local accounts you can just enter the <username> or <computer name>\<username>. Note using .\<username> will not work as . would resolve to the hostname of your iOS device.



    Thursday, September 11, 2014 9:26 PM
  • I am unable to login when I use a Microsoft ID (microsoftaccount\ removed already). Logging in with a local user account works just fine. This only noticed to be happening with the 8.1.0 update (new UI). Before the update it worked great. I am using both iPad and iPhone to connect to a Windows 8.1 desktop on the local network. The odd thing is that I have always had this issue with the Windows Phone RDC client (Microsoft account can't log in but local account can).
    Friday, September 12, 2014 7:08 AM
  • I've tried to connect with <username>@<domain> instead of <domain>\<username>, bur this doesn't work.
    After the update, version 8.1.0 iPad's and iPhone's could'nt cennect any more...

    Please downgrade the app version in de Appstore and fix the problem first.

    In admin mode, I can see the first screen of our Windows Server 2008, but I don't have a admin account for this so I see a error of this server.

    Friday, September 12, 2014 11:14 AM
  • Hi Yotech;

    I got same problem on my IPAD and IPHONE. I asked to microsoft they dont answer but fortunately I fixed the problem. It doesnt matter you write your IP ADRESS \ USER or just USER. But in if you have an unknown character in your user name which is like İ,Ö,^', this, ıt doesnt work on rdp. So you must change the username with known characters. 

    For example my user name was '' HİKMET'' . But it doesnt work on this user name and it gives same error message on my IPHONE. But after I change the user name to '' HIKMET '' on the rdp setting on my server. It starts to work now on my IPHONE and IPAD. So you must check the user name.

    I hope it helps for everybody.

    Saturday, September 13, 2014 2:26 PM
  • After a update, version 8.1.3, it seems that the problems are resolved.

    Update date is 14th September.

    Monday, September 15, 2014 8:18 AM
  • Hi,

    I would like to check if version 8.1.3 could help you to resolve the issue.

    https://itunes.apple.com/us/app/microsoft-remote-desktop/id714464092

    Thanks.


    Jeremy Wu

    TechNet Community Support

    • Proposed as answer by yoTech Monday, September 15, 2014 6:49 PM
    Monday, September 15, 2014 8:54 AM
  • It still does not work.  I have same issue.  Apparently I can not post the screenshot since it doesn't allow me saying " they need to verify my account".

    I just love MSFT. 

    Monday, September 15, 2014 1:43 PM
  • Still same problem for me too. Using release 8.1.3. Local user logon works OK, but when using domain user I get error in username/password. I have tried to reset settings in rdclient, tried using user@domain, but to no avail. Hope you can resolve this issue soon.
    Monday, September 15, 2014 6:44 PM
  • The issue has been rectified via the new update.  Anyone who may have had similar issues to me should also try and update the app to the latest version.

    Hi,

    I would like to check if version 8.1.3 could help you to resolve the issue.

    https://itunes.apple.com/us/app/microsoft-remote-desktop/id714464092

    Thanks.


    Jeremy Wu

    TechNet Community Support


    Monday, September 15, 2014 6:50 PM
  • I have the same problem. Isn't possible to downgrade to 8.0.8 by any way?
    I now have the 8.1.3 bad version.
    Monday, September 15, 2014 7:12 PM
  • I reported similar issue on another thread, 

     iOS RD client update 8.1.0 users in one-way trust can't login

    Not fixed in v8.1.3 unfortunately. Users in the local domain can login successfully but our users from a domain we have a one-way trust with and which has NTLM v1 disabled get the bad username or password error when attempting to connect with the new iOS RD client. 

    Tried numerous changes but no difference - appears that when the new iOS client start to negotiate the connection something fails. Could be due to it not properly using NTLM v2 and/or combination of it not enumerating some AD information from the one-way trust. In this configuration the v8.0.9 client worked fine.

    We've warned most of our iOS users to not update if at all possible as there doesn't appear any way to downgrade.

    Monday, September 15, 2014 9:32 PM
  • I have had similar issues but v8.1.3 solved the logging in issues. The problem I have is accessing the Remote Desktop resource. Why when something is working changes it?
    Monday, September 15, 2014 10:04 PM
  • Logon still broken to domain accounts. Two versions back worked. Targets win7 and win 8.1 fully patched. 2008r2 AD full functional level ntlmv2 required
    Monday, September 15, 2014 11:54 PM
  • Screenshots for my issue.

    • Proposed as answer by pclucky Saturday, August 19, 2017 11:41 AM
    • Unproposed as answer by pclucky Saturday, August 19, 2017 11:41 AM
    • Proposed as answer by pclucky Saturday, August 19, 2017 11:41 AM
    Tuesday, September 16, 2014 5:06 PM
  • Exact same message we're getting. The login fails even though the username/pw are correct. On the RD server we only get the null session audit failure message. 

    The only logging of a problem is in event view Security Audit Failure event id 4625,
    Source:        Microsoft-Windows-Security-Auditing
    Date:          9/11/2014 12:18:50 PM
    Event ID:      4625
    Task Category: Logon
    Level:         Information
    Keywords:      Audit Failure
    User:          N/A
    Computer:      xxxx.xxxx.washington.edu
    Description:
    An account failed to log on.
    Subject:
                    Security ID:  NULL SID
                    Account Name:  -
                    Account Domain: -
                    Logon ID:  0x0

    Logon Type:   3
    Account For Which Logon Failed:
                    Security ID: NULL SID
                    Account Name: xxxteam
                    Account Domain: NETID
    Failure Information:
                    Failure Reason:  Unknown user name or bad password.
                    Status: 0xC000006D
                    Sub Status: 0xC000006A
    Process Information:
                    Caller Process ID: 0x0
                    Caller Process Name: -
    Network Information:
                    Workstation Name: workstation
                    Source Network Address: -
                    Source Port: -
    Detailed Authentication Information:
                    Logon Process: NtLmSsp 
                    Authentication Package: NTLM
                    Transited Services: -
                    Package Name (NTLM only): -
                    Key Length: 0

    Tuesday, September 16, 2014 8:18 PM
  • I am running 8.1.4 and still have the problem.  8.0.8 worked great, would love to have it back while this is resolved.
    Wednesday, October 8, 2014 6:06 PM
  • I am also getting this same error message supposedly saying that my user name of password did not work. I am able to use the Microsoft Remote Desktop app to connect to my machine at work, but when I try to connect to my home machine, it fails with that error message. I am able to connect to my home machine successfully with 2 other iOS RDP apps.

    I am using iOS 8.1 on an iPhone 5s and Microsoft Remote Desktop app version 8.1.4

    Home machine is the following:

    OS: Windows Server 2008 R2

    NLM is not turned on

    Workgroup machine

    It is a local user that I am using

    I have tried many different username and machine name combinations without any luck.

    Is there anything I'm missing?  Should I open another thread?  Is there anyone from MS watching this thread?  Is this app an MS supported app?

    I love the new changes to the functionality and would love to use this app as my primary RDP app, but this bug is stopping me from switching from my other apps.

    Please fix this.  Thanks.

    Thursday, October 30, 2014 2:04 AM
  • Same issue. Still doesn't work after the past couple of updates. Can't login to a Domain machine using either (user) or (domain/user) or (user@domajn) after connecting via VPN THis problem was reported several updates ago and still doesn't work after today's 10/29/14 latest update for iOS Can you please roll back the version??
    It has nothing to do with troubleshooting. We are doing the exact same thing as before but you guys messed it up now Maybe it's related to authenticating via VPN??
    EVERYONE - NOBODY NEEDS TO CHANGE WHAT THEY ARE DOING. KEEP TRYING THE WAY IT USED TO WORK. THIS IS A DEFECT
    • Edited by Lazee Thursday, October 30, 2014 1:02 PM
    Thursday, October 30, 2014 12:59 PM
  • I had this exact same issue with this app, but I have resolved the problem, and it is not an issue with the app.  It is an issue with your machine configuration. 

    1. First I was getting the "This might be due to an expired password." error message. 
    2. I also noticed that I was getting some successful security audits in my event viewer, and they were all mentioning the Guest user account.  I thought I had the Guest account disabled though.
    3. I then checked my user accounts on the machine, and noticed the Guest account was enabled.
    4. I disabled the Guest account
    5. Then I started getting the "The user name or password did not work." error message
    6. The event viewer was now showing audit failure logs with - for account name and domain.
    7. Solution is this: The Local Security Policy was changed somehow.  So, I changed it back: Open Local Security Policy from Administrative Tools menu, go to Local Policy > Security Options, then in the Policy double click on "Network access: Sharing and security model for local accounts" and change the setting to "Classic - local users authenticate as themselves".  Click OK
    8. Now when I connect, I can connect fine with the iOS app.

    I hope this helps others fix this problem.  The Microsoft Remote Desktop app has grown into a very useful tool.  Thanks!!

    **Note: I haven't had a chance to test my local shares to ensure I can still connect as before, but the Local Security Policy change may have an effect on any shared folders. **Update: I have been able to test the file shares, and there has been no change in accessibility**


    • Proposed as answer by B.Adam Thursday, October 30, 2014 4:18 PM
    • Edited by B.Adam Friday, October 31, 2014 12:58 PM
    Thursday, October 30, 2014 4:16 PM
  • That's not a solution. Thats a possible workaround. Are you connecting via VPN by the way? Just want to see if this is a factor. However I got an easier workaround for everyone that trying to repair apps problem. Again this was working until about 3 updates ago. Use a different app. Even the free RDP Lite works as intended. Or rollback this app
    Thursday, October 30, 2014 5:19 PM
  • Just to report the latest 8.1.5 version which includes the NTLMv2 patch has fixed the problem.

    We are now able to login to our Server 2008 R2 terminal servers again.

    How MS released an update missing support for it in the first place I don't know, but thank you fox fixing it.

    • Marked as answer by nirav00 Tuesday, November 4, 2014 3:44 PM
    Friday, October 31, 2014 2:53 AM
  • @Lazee

    I don't know how you can say it isn't a solution.  I will give you a little more background into what I experienced.  When I disabled the Guest account and was getting the "user name or password did not work" error message, I was also unable to RDP to that same machine from a Windows 7 machine using the built-in RDP Client.  So, if the standard RDP Client on a windows machine doesn't work, I wouldn't expect any other application to work either.

    I'm guessing what is going on is Microsoft is utilizing the full RDP standard that they designed in their ios app.  While the other apps are using shortcuts in the RDP standard which didn't expose this vulnerability.  I am personally happy that I was able to discover that my Guest account was active, and that security setting was set to an insecure method.

    As an added note, I have been able to test my file shares, and there has been no change in accessibility.

    Take my solution for what it is, use it if you'd like, do your own research on it.  I just figured i'd post my solution to this issue that also makes the machine more secure.

    BTW, I was using version 8.1.5 when I was still having this problem, and had to change the Local Security Policy in order to fix it still.

    Friday, October 31, 2014 12:56 PM
  • Version 8.1.5 fixed the problem... Thanks
    • Marked as answer by nirav00 Tuesday, November 4, 2014 3:45 PM
    Tuesday, November 4, 2014 3:45 PM
  • Any we thought this was ridiculous back at 8.1.5. As of yesterday mornings update to 8.1.19, this issue has returned. Access via gateway completely broken. The username and password did not work. Same creds work on my IOS device, as I disabled auto update to apps after this thread in 2014. I'm good at 8.1.17.
    Wednesday, April 20, 2016 6:44 PM
  • Urgent issue.....Microsoft please fix this issue as it's back in version 8.1.19. We have over 100 clients who are currently down for the past few days. Basically when you try to access the Remote resource feed, you get the username and password did not work and the credentials on AD lock up. PLEASE bring back 8.1.17 or give us an update.
    Thursday, April 21, 2016 7:52 PM