none
Win2008 server is accessible, but not visible in “net view” or “network”

    Question

  • Win2008 server is accessible, but not visible in “net view” or “network”

     

    So I’m working with two Windows 2008 servers. Let’s name them Serv2 and Serv3. When looking under “Network” in Windows Explorer I can see several workstations and Serv2. However Serv3 is not displayed. This is the case on both servers.

    -If I type in the path \\Serv3 I can then see all of the shared folders on Serv3 and can browse them. This causes Serv3 to show up on the left side of Windows Explorer under “Network”, but if I have “Network” highlighted Serv3 does not show up on the right (tried F5 to refresh).

    -If I type “net view” in the cmd window, again I see several workstations and Serv2, but not Serv3.

    -If I type “net view Serv3” I see a list of shares.

    -Pinging both computer name and IP are working.

    -Both servers are Windows Server 2008 SP2

    -Checked on a workstation. Same results, I can see Serv2 but can’t see Serv3 unless I type in the path.

    -Compared network settings on the two servers. The only difference I could find was that Serv2 has Printer and File sharing enabled and Serv3 only has file sharing enabled.

    -Both are domain controllers.

     

    Thank you in advance,

    Jim


    90% of the laws are made because of 10% of the people.
    Monday, October 31, 2011 8:29 PM

Answers

  • Hi Jim,

    Thank you for your post.

    Please try steps below:
    1. Verify NetBIOS over TCP/IP enabled in your NIC
    2. Check "TCP/IP NetBIOS Helper" and "Computer Browser" service if running on Server 2008

    If there are more inquiries on this issue, please feel free to let us know.

    Regards,
    Rick Tan

    Friday, November 04, 2011 2:11 AM
    Moderator

All replies

  • Hi,

    Try check  Windows Firewall with Advanced Security if you need to enable inbound connection for files & print sharing.


    Hope you find the info useful
    Monday, October 31, 2011 8:55 PM
  • Hello Justohelp.

    The Windows firewall is disabled on both servers (infact all stationary machines behind company firewall). I checked the Exceptions anyway and found that both of the servers have File and Print Sharing listed in the Exceptions list for the Windows Firewall Settings.

    The following is from the Inbound Rules for Windows Firewall with Advanced Security. Outbound seems to have everything Allowed too. Hopefully irrelavent with the firewall turned off, but it's always worth checking. :)

    Thank you,

    Jim


    90% of the laws are made because of 10% of the people.
    Tuesday, November 01, 2011 4:13 PM
  • Hi Jim,

    Did you check this http://support.microsoft.com/?kbid=265284

    This setting can also be changed using the following command:

    net config server /hidden:yes|no

    To hide the computer from the Browser List, type net config server /hidden:yes at the command prompt, and then press ENTER.

    To unhide the computer from the Browser list, type net config server /hidden:no at the command prompt, and then press ENTER.


    Hope you find the info useful
    Thursday, November 03, 2011 7:02 PM
  • Hi Justohelp,

      I have never seen that setting before. You are quite resourceful. The setting didnt' exist in the servers registry until I used the command. I toggled it a couple of times, but it did not make the server visible on the network.

      There is a scheduled restart of the server this weekend. I will check to see if the restart helped when I get back in on Wednesday.

    Thank you very much for your help!!

    Jim


    90% of the laws are made because of 10% of the people.
    Thursday, November 03, 2011 10:43 PM
  • Hi Jim,

    Thank you for your post.

    Please try steps below:
    1. Verify NetBIOS over TCP/IP enabled in your NIC
    2. Check "TCP/IP NetBIOS Helper" and "Computer Browser" service if running on Server 2008

    If there are more inquiries on this issue, please feel free to let us know.

    Regards,
    Rick Tan

    Friday, November 04, 2011 2:11 AM
    Moderator
  • Sorry about the slow response. I had a couple days of vacation.

    Rick Tan,

    Thank you for the suggestions. When comparing the two Windows 2008 servers, all of the settings you recommended I check are the same. And yet Serv3 doesn't show up and Serv2 does.

    Turned on "NetBIOS over TCP/IP" in the properties of TCP/IPv4 on the Local Area Connection. - This did not help. Reverted setting.

    "TCP/IP NetBIOS Helper" service was already on. Restarted it just in case. - This did not help.

    "Computer Browser" services on Serv03 was disabled. Set it to Automatic. - Serv03 is now showing up in the Network view and Net View list.

    We have a winner!!!!

    Thanks again for everyone's input.

    Jim


    90% of the laws are made because of 10% of the people.
    Wednesday, November 09, 2011 8:21 PM
  • This is working fine.thanks for your info......

    from INDIA

    Tuesday, May 22, 2012 6:32 AM
  • Thanks JimL500 and Rick Tan.
    This just helped me today with my Win10, and it is from 2011.
    That's just awesome.
    Wednesday, March 08, 2017 8:19 PM
  • Thanks! Much Appreciated!
    Wednesday, March 08, 2017 8:19 PM