none
Hyper-V Hosts having same processor but showing Compatiability issues RRS feed

  • Question

  • Hi Team 

    I have created a new cluster of 6 hosts DL380 G10 with Intel(R) Xeon(R) Gold 6132 CPU @ 2.60GHz processors in them, they are on same ROM update as well. 

    if I try to Live migrate via SCVMM following message occurs in Select host tab. 

    "The Virtual Machine (VM Name) is not compatible with the virtualization host (Host name). the virtual Machine may not start or operate correctly on the Host. This may be due to inconsistent processor combability information. "

    When I Try with the Failover Cluster Manager it gives me following error 

    Live migration of 'SCVMM DCUTL01' failed. Virtual machine migration operation for 'VMNAME' failed at migration destination 'HOSTNAME'. (Virtual machine ID xxxxxxxxxxxxxxxxxxx) The processor settings for virtual machine 'VMNAME' are not compatible with physical computer 'HOSTNAME'. To migrate this virtual machine, you must first shut it down. After shutdown, you can migrate this virtual machine or export it and then import it on the destination physical computer with the correct processor settings. (Virtual machine ID xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx)

    I have not tried it with allow from compatibility mode on as that will not be a resolution. all my processors are the same.

    Thanks

    Saqib Ahmed


    Saturday, March 10, 2018 1:59 AM

All replies

  • Ensure that all processors are at the same stepping level.  Two processors of the same model, but at different stepping levels, can cause this occur.

    Or, you can configure the VMs to operate in processor compatibility mode.  Compatibility mode rarely, if ever, causes a performance issue.


    tim

    Saturday, March 10, 2018 2:10 PM
  • Hi ,

    Just want to confirm the current situations.

    Please feel free to let us know if you need further assistance.                   

    Best Regards,

    Candy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 12, 2018 8:50 AM
  • Have the same issue. Identical processors, processor compatibility is on but live migration is not working. 

    Dont know why. 

    Thursday, November 8, 2018 11:10 AM
  • I'm having the exact issue.

    SCVMM 2016, Windows server 2016 Datacenter with Hyper-V Role installed, all the updates installed in every server, same processor, same stepping.. but i cannot live migrate to this specific node of the cluster, i can migrate if the vms are stopped.

    Btw. It was working a few days ago.
    Thursday, February 14, 2019 4:36 PM
  • Exact same issue here using VMM 1807, and Windows Server Datacenter 2019 with Hyper-V role installed.

    When trying to migrate a VM between hosts using VMM the Migrate VM Wizard reports this error, and interestingly enough if I click into the host that the VM is already running on - it gives me the same error - which is clearly not correct because it is already running on that host, and was able to be migrated to it at some point as none of my VMs are new.

    Monday, March 4, 2019 9:34 AM
  • Got the same issue but checked the stepping, its the same. Is there no other solution except processor compatibility mode? We are running a HA Datacenter and it would be a huge afford to set the options to every VM for a mass of customers. 
    Thursday, July 18, 2019 11:55 AM
  • I have also seen this, under Server 2019 Standard and Hyper-V Server 2019. Migrating between identical servers, with the same CPU/stepping

    e.g. Intel64 Family 6 Model 85 Stepping 4 GenuineIntel

    I have seen this legitimately happen where a VM was migrated from a lower model CPU to a higher model e.g. a Xeon X series to a Xeon E5 series. People have forgotten where it came from and then after many months it refuse to migrate again until the VM was shutdown and started again - even though the request is to now migrate from an E5 to an identical E5.

    Under 2019, I've been seeing the occasional issue where the VM was never on a lower-spec processor (i.e. it was built on the CPU it was currently hosted on). It will then refuse to move to an identical peer. In all cases however, they've sorted themselves out after 20 minutes or so with no explicit interference from me.

    Sunday, July 21, 2019 10:46 AM