none
home directory not mapping..... RRS feed

  • Question

  • Recently we deployed a Windows 2008 File Server in our Win2k3 domain. Problem i am having is, randomly i get users complaining their home drive does not map at logon.  I reviewed the properties of their logon profile and see nothing out of the ordinary.... share & NTFS permission look fine to.. This is happening to only a few users..... 

    This behavior  is true with  mapped drives via a logon script... (replication look fine also)...  

    The storage they are connecting to is a Netapp via iSCSI   I understand their are alot of varibles here..... I am wondering if their is any bugs or hotfixes for this issue...


    any ideas?

    thanks r davis  


    Rob Davis
    Tuesday, May 12, 2009 12:42 PM

Answers

  • Hello Rob,

     

    Thank you for posting here.

     

    As the issue happens on a few users, we may need to confirm some information with you to isolate the cause of the issue.

     

    1. What is the operation system version of the problematic client?

     

    2. Did the network driver disappear when the client reboot?

     

    According to the research, the issue may be caused by the several possible reasons:

     

    Possible reason1. The problematic client doesn't reconnect to the target share at logon.

     

    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.

     

    Steps:

     

    a. Open "My Computer"

    b. Click on "Tools" and then select "Map Network Driver"

    c. input the \\ipaddressofserver\sharename to give the path of the share

    d. Check "Reconnect at logon"

    e. Drive gets mapped

    f. Double click on the drive to check.

     

    Possible Reason 2. Antivirus software or Windows Firewall may block the SMB protocol on clients.

     

    Please check if there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.

     

    Possible Reason3. Fast Logon Optimization is enabled on the clients.

     

    The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. He may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.

     

    Please configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.

     

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon

     

    When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.

    Please note: As this is a computer configuration, please run "Gpupdate /force" and then reboot the problematic clients to make it take into effect.

    For more information about Fast Logon Optimization feature, please check the following KB article.

     

    305293 Description of the Windows XP Professional Fast Logon Optimization feature

    http://support.microsoft.com/?id=305293

     

    831998 Mapped network drive shows no drive letter or will not allow you to create new long-named files or folders

    http://support.microsoft.com/kb/831998

     

    297684 Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

     

    If the issue still exists on the problematic clients, please also try adding the following registry subkey on the problematic client to check it works.

     

    Steps:

     

    a. Click Start, click Run, type REGEDIT, and then click OK.

    b. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

    c. Click Edit, point to New, and then click DWORD Value.

    d. Type SilentForcedAutoReconnect , and then press ENTER to name the value.

    e. Double-click SilentForcedAutoReconnect .

    f. In the Value data box, type 1, and then click OK.

     

    Please feel free to let me know if you have any concen.

     

    Hope the information can be helpful for you.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Monday, May 18, 2009 5:21 AM
    Wednesday, May 13, 2009 7:12 AM

All replies

  • Hello Rob,

     

    Thank you for posting here.

     

    As the issue happens on a few users, we may need to confirm some information with you to isolate the cause of the issue.

     

    1. What is the operation system version of the problematic client?

     

    2. Did the network driver disappear when the client reboot?

     

    According to the research, the issue may be caused by the several possible reasons:

     

    Possible reason1. The problematic client doesn't reconnect to the target share at logon.

     

    Please follow the steps to re-configure the mapped driver on the client and then check if the issue will re-occur.

     

    Steps:

     

    a. Open "My Computer"

    b. Click on "Tools" and then select "Map Network Driver"

    c. input the \\ipaddressofserver\sharename to give the path of the share

    d. Check "Reconnect at logon"

    e. Drive gets mapped

    f. Double click on the drive to check.

     

    Possible Reason 2. Antivirus software or Windows Firewall may block the SMB protocol on clients.

     

    Please check if there is any Antivirus software and the Windows Firewall is enabled on the problematic client. If so, please disable them to check if the issue can be resolved.

     

    Possible Reason3. Fast Logon Optimization is enabled on the clients.

     

    The fast logon feature may affect the display and drive letter assignment of a mapped network drive. As a result, the drive may have been mapped; however, the user on client cannot see it in Windows Explorer. He may recognize it as a failed network drive mapping. This is the reason why we usually suggest you to disable fast logon on the clients via a GPO, and please check if the mapped network drive will be occur under this circumstance.

     

    Please configure the following group policy setting to disable Fast Logon Optimization to see if the issue still exists on the problematic clients.

     

    Computer Configuration\Administrative Templates\System\Logon\Always wait for the network at computer startup and logon

     

    When this policy is enabled, a Windows XP client behaves in the same manner as a Windows 2000 client at both system startup and at user logon.

    Please note: As this is a computer configuration, please run "Gpupdate /force" and then reboot the problematic clients to make it take into effect.

    For more information about Fast Logon Optimization feature, please check the following KB article.

     

    305293 Description of the Windows XP Professional Fast Logon Optimization feature

    http://support.microsoft.com/?id=305293

     

    831998 Mapped network drive shows no drive letter or will not allow you to create new long-named files or folders

    http://support.microsoft.com/kb/831998

     

    297684 Mapped Drive Connection to Network Share May Be Lost

    http://support.microsoft.com/kb/297684

     

    If the issue still exists on the problematic clients, please also try adding the following registry subkey on the problematic client to check it works.

     

    Steps:

     

    a. Click Start, click Run, type REGEDIT, and then click OK.

    b. Locate and click the following registry subkey:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\NetCache

    c. Click Edit, point to New, and then click DWORD Value.

    d. Type SilentForcedAutoReconnect , and then press ENTER to name the value.

    e. Double-click SilentForcedAutoReconnect .

    f. In the Value data box, type 1, and then click OK.

     

    Please feel free to let me know if you have any concen.

     

    Hope the information can be helpful for you.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Marked as answer by David Shen Monday, May 18, 2009 5:21 AM
    Wednesday, May 13, 2009 7:12 AM
  • Hello Rob,

     

     

    I want to see if the information provided was helpful. Please keep us posted on your progress and let us know if you have any additional questions or concerns.

     

     

    We are looking forward to your response.


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, May 15, 2009 7:52 AM