C Drive reporting 0 bytes free however can not account for disk usage - Windows Server 2008 Terminal Server


  • C Drive on my Windows Server 2008 Terminal Server is reporting 0 bytes free, however I can not account for where the space is going. 

    The C Drive is 63.4GB and when I use Explorer to check disk usage, it reports 19.5GB used.

    I have unhidden all hidden folders and system folders.

    When I clear some space it fills up in seconds.

    The page file is not on the C Drive... it has it's own partition. 

    I can not find any unknown prcesses running.

    Can anyone offer any suggestions on how I can find where the space is going and what is doing it? 

    Thanks for your help.

    Tuesday, July 21, 2009 5:57 AM

All replies

  • Hi,


    You mentioned that "C Drive on my Windows Server 2008 Terminal Server is reporting 0 bytes free". Did you mean the Low Disk Space Notification reported that there is 0 bytes free?


    You also mentioned that "The C Drive is 63.4GB and when I use Explorer to check disk usage, it reports 19.5GB used." Did you mean you open "Computer" to check the disk usage?


    I recommend that you boot the computer into Safe Mode to see whether the same issue occur. Please also open Disk Management to check whether you can see the same symptom as you saw in Explorer.



    Best Regards,

    Vincent Hu


    Thursday, July 23, 2009 8:18 AM
  • Hi  ,

    Did you find a solution for this ? I have the same isue . I had to rebuild this server last time when I retart it to access the safemode  . Have a 465GB "C" drive and only 86GB are all data & have no idea how the balance space is filled . 
    Tuesday, August 18, 2009 1:23 AM
  • Just a thought but this couldn't be something like WSUS filling up the drive by downloading updates could it so as soon as more space is cleared it resumes the downloads?

    Also you haven't got disk quotas enabled on the drive have you?

    Tuesday, August 18, 2009 9:40 AM
  • Hi.

    Did any of you ever resolve this issue? We are expiriencing the same issues on 3 out of 5 Windows 2008 terminal servers.

    - No disk quotas
    - No WSUS download

    Thursday, October 01, 2009 6:50 AM
  • Hi All,

    I would say explorer is an applicaiton whcih populates the disk info, there might be chances that it is displaying incorrect memory usage where as the original disk free space is different.

    can you run the following command from dos and post the output

    fsutil volume diskfree C

    Also would recommend to run chkdsk.

    As vincent suggested please do check the behavior in safe mode.

    sainath !analyze
    Monday, October 05, 2009 2:01 AM
  • Hi,

    Same problem with a customer's new SBS 2008 server, running exchange and sharepoint - had approx. 400mb free on 149Gb drive.

    I've run treesize pro which can only find 68Gb of data, another 15Gb is used in system volume information folder (hidden system restore files).

    Ran disk cleanup (thanks for making it part of the desktop experience feature package btw!!) which found 86mb of stuff to delete but reduced freespace to 147mb by installing the tool and the associated stuff.

    Cannot explain where the 60Gb+ of hard disk space has gone.

    Any ideas people?  I've done some searching and I am finding a lot of complaints about this exact problem - only with 2008.
    Monday, October 26, 2009 2:21 PM
  • Some places you can check:

    C:\Windows\Temp (global temp files)
    C:\Users\<YOUR USERNAME>\Local Settings\Temp (Temp files for your account)
    C:\Windows\winsxs (old driver/file versions from updates etc)
    C:\hiberfil.sys (hibernation file)
    C:\pagefile.sys (page file)
    Maybe disable system restore
    Maybe disable shadow copies

    To see all the folders you may need to go to Organize > Folder and Search Options then press the view tab and untick "Hide protected operating system files (Recommended)
    Robin Wilson
    Thursday, October 29, 2009 8:32 PM
  • I have seen this problem twice now, one was a 2008 Server Member and the other a 2008 TS, both Dell servers

    For one of the servers a simple reboot gave me back over 70GB of space ( basically what i should have had )
    For the TS a reboot didn't fix the fault, as mentioned in earlier posts, this is not a disk usage fault, I know I should have over 100GB of free space ( it was there a few hours ago )!!!

    Windows Reports 0 bytes free, if you do a properties of each directory on the root, the disk space is nothing like the total disk size, on my TS 38GB usage reported on a 135GB drive, but the disk is reporting 0 bytes free

    The way i fixed it was by doing a "Run as Admin" command prompt, do a dir /a/s to list all the files/dirs on C:\, to find out if it is reporting correctly, once it finished listing all the files, suddenly i had 100GB of free space again???

    this makes me believe that the fault is something to do with the table of condense miss calculating the disk space, and i suspect a Dir /a/s causes the system to calculate the size of every file and may be fixing the problem

    Worked for me, may not work for you, give it a go


    Sunday, December 06, 2009 8:05 PM
  • I have the same issue can any one help me out in this regard. It's urgent for me as the server is not able to access anything.

    waiting for the reply

    Thanks in advance

    Wednesday, March 24, 2010 4:53 AM
  • Hi Satish,


    Please open a new thread and attach this link.

    Wednesday, March 24, 2010 4:55 AM