service --> WMI --> HyperV = access denied


  • Hi,


    I've looked at John Howard's articles but they don't address a service running under the LocalSystem account making WMI calls to a remote HyperV box. I can authenticate successfully with domain admin credentials, successfully issue a WQL call, but when I attempt to access the result, I get 0x80041003 (WBEM_E_ACCESS_DENIED). Specifically, IEnumWbemClassObject::Next is returning this error.


    Even if my service thread impersonates the domain admin I still get this error.


    If I run wbemtest.exe under the LocalSystem account it can successfully get the results of the remote WQL query (provided I specify the domain admin credentials in its dialog), so I assume this scenario is possible. Any ideas how I can do the same in my service?




    Friday, April 18, 2008 3:36 PM


  • Michael Michael at Microsoft gave me the answer. I just needed to add the machine account on which my service is running to the local administrators group on the hyperv box. This alleviates the need for the domain admin credentials. It just works using the LocalSystem account.


    thanks Michael !

    Friday, April 18, 2008 9:58 PM