Cannot see my virtual machine in overview RD Virtualization Host Servers


  • Hi,
    I am creating a RDS environment. No I got all the hyper-v servers running, all the RDS roles/features installed. Even had it working before with a test. 
    Now I created a virtual machine with win7 on it. But when I go to the Remote Desktop Connection Manager and to RD Virutalization Host Servers, I don't see my virtual machine added in the 'Total Virtual Machines' count with the proper RD Host. If I want to assign the virtual machine to an user it is not possible since I cannot select the virtual machine.

    The VM is registered in hyper-v manager with the FQDM name. Changed that later on since at first it was only the hostname.
    On the VM I have run Configure-VirtualMachine.ps1 script from I also tried it manually, but everything was already correct.

    If I try "gwmi -computer RDSERVER -Namespace root\virtualization Msvm_ComputerSystem" from the VM it goes alright.
    If I try gwmi -computer VDESKTOP -Namespace root\virtualization Msvm_ComputerSystem" I get an error:

    Get-WmiObject : The RPC server is unavailable. (Exception from HRESULT: 0x800706BA)

    At line:1 char:5

    + gwmi <<<<  -computer VDESKTOP -Namespace root\virtualization Msvm_ComputerSystem

        + CategoryInfo          : InvalidOperation: (:) [Get-WmiObject], COMException

        + FullyQualifiedErrorId : GetWMICOMException,Microsoft.PowerShell.Commands.GetWmiObjectCommand

    Already tried stopping and starting the RPC service.
    Anyone an idea?

    Wednesday, February 23, 2011 9:01 AM

All replies

  • Hi,


    From your description, I understand that you would add host virtualization to RD Connection Broker, but it shows 0 virtual machines.


    According to the description above, follow these steps to check:


    1.       Make sure that you have installed Remote Host Virtualization role in host virtualization server.

    Check steps:

    Open Server manager console, click Roles in the left column, click Add Roles in the right panel, then check the Remote Host Virtualization role have been installed in Remote desktop service .

    2.       Open the Remote Desktop Connection Manager in Server manager, then click RD Connection Broker for personal virtual desktop --Configure in the middle of the panel.

    3.       In specify an RD Virtualization Host Server to add the Remote Host Virtualization server. (Enter the NetBIOS name or FQDN)

    4.       Confirm Changes and click finish.


    It will show the number of virtual machine in RD Connection Manager.


    Please refer to the following article to deploy the VDI:

    Deploying Personal Virtual Desktops by Using Remote Desktop Web Access Step-by-Step Guide


    Technology changes life……
    Thursday, March 03, 2011 12:28 PM
  • Yes, did all that allready. But the fact was that there were problems connecting to the VM, see the RPC error. I fixed that, but still there are problems seeing the VM in the count of the VM host.

    Futhermore, the host server in question is a Hyper-v server (standalone). Altough it already should have the RD host role, could you give me a guide how to install that role on a hyper-v server (via powershell?)


    ==== edit ===

    Found it already

    And was already done.

    I now manually assigned the VM to the domain user using the User management of the Domain. Now I see the desktop icon in RD Webaccess. But when I log in, I end up on the rd broker server (assigned user as admin rights). 
    The error I find in the Eventlog under TerminalServices Session Broker is:
    EventId 1280
    RD Connection Broker failed to find Personal Desktop ( assigned to user xxx\USERNAME in RD Connection Broker database. Hr=0x80070490

    EventId 802

    RD Connection Broker failed to process the connection request for user xxx\USERNAME

    Load Balancing failed OR Specified endpoint could not be found.

    HRESULT = 0x80070490.

    Friday, March 04, 2011 11:51 AM
  • And I found a failure in the eventlog of the hyper-v server with the RD virtualization host:
    Failed to connect to RD Connection Broker.
    Verify server address and permissions. Address=RDHOST, Hr=0x80070005
    Friday, March 04, 2011 4:25 PM
  • Did you find the answer to the no VMs showing on the broker?
    Thursday, November 24, 2011 2:47 PM
  • I did actually and got it all working. But sorry to say, I dont know what it was anymore.
    As far as I still know, I researched all the event logs everywhere and I found more things underneath in some specific RD event logs. There were some problems with Domain connections etc. There was something that the Connection broker didnt connect that well.

    In the end I did multiple things/fixes and after that it worked, so the specific solution I dont know.
    Good luck still.

    Monday, November 28, 2011 9:27 AM
  • THanks for letting me know


    Very kind

    Monday, November 28, 2011 7:12 PM
  • If anyone is interested. to Solve this problem you need to add port 4189 to the Broker as an inbound TCP connection.
    Friday, April 13, 2012 8:59 AM