none
Microsoft Remote Desktop APP Windows 10 - Timeout issue RRS feed

  • Question

  • Hi,

    I have recently downloaded the Remote Desktop app from the store on windows 10 and have configured to connect to our Head Office server via the app. The app works perfectly other than the connection times out on idle of 2 minutes, I cannot see any settings within the app itself to clear off idle timeout, can anyone assist me? thanks

    Tuesday, September 27, 2016 9:34 AM

Answers

  • Hi,

    Thanks for your post.

    Please try to check and disable the "Session Time Limits" policies on your Windows 10 PC:

    1. Open gpedit.msc

    2. Navigate to:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    3. Disable any active policies.

    4. Navigate to:

    User Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    5. Disable any active policies.

    6. Reboot the computer.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 28, 2016 10:20 AM
    Moderator

All replies

  • Hi,

    Thanks for your post.

    Please try to check and disable the "Session Time Limits" policies on your Windows 10 PC:

    1. Open gpedit.msc

    2. Navigate to:

    Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    3. Disable any active policies.

    4. Navigate to:

    User Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    5. Disable any active policies.

    6. Reboot the computer.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 28, 2016 10:20 AM
    Moderator
  • Hi,

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 6, 2016 9:27 AM
    Moderator
  • I came upon this post trying to diagnose an issue. I have been RDP from home PC (Win7Pro) to the office PC (Win7Pro) for many years for hours per day without problem. Since i recently did a new install (1/15/19) of Win 10 Pro on my home PC, RDP connects just fine, however it times out within 5 to 15 minutes. I have checked my settings that you recommend in this post and find Time Session Limits are all disabled. I have tried other suggestion settings on the Win7Pro PC and still consistently times out and takes 20 to 30 seconds to reconnect. Not sure why this is happening now, but quite disrupting.

    If you or anyone is still following this thread, I would appreciate any help.

    Thanks, Floyd

    Friday, August 16, 2019 2:48 PM
  • Floyd

    Have you found the cause? We just started seeing that about a month ago.

    Thx


    eburch@lasertel.com

    Monday, December 9, 2019 8:19 PM
  • Same thing here, exactly after 60 seconds the remote service interrupts the connection. But it is only one PC, all other, which have the same Windows 10 Version keep the connection open. Nothing relevant in the windows event protocol.

    Winver is 1909, it happenc since 2-3 weeks, before that everything is fine, but I don't which Update trigger this.

    All policies are disabled on the server and client side.


    Freudi

    Thursday, January 16, 2020 5:01 PM
  • Ditto on the post. Verified that no GP policies exist that set session limits are set at any level in the domain. Seems to be affecting both some Windows 10 and some Windows 7 desktops.

    eburch@lasertel.com

    Tuesday, January 21, 2020 4:59 PM
  • I have similar issue with windows 10 version 1803. None of the terminal services policies are defined yet RDP stops responding until the service is restarted manually.

    Friday, January 24, 2020 10:23 PM