Remote Desktop Connection adding prints to default printer


  • Hi,

    We have an odd one going on ATM.

    One day out of the blue we started to have prints sent to the remote server we were connecting to e.g.

    Windows Remote Desktop Connection-> Connect to a Server -> Logon -> And have a print job added to our default print.

    I've taken the steps to do some research and found that under the Local devices and resources the option "Printers" was ticked.

    I un-ticked it and the prints have stopped.

    My question how can this happen all of a sudden? I'd like to fix for a number IT staff?

    Thanks :)


    Monday, February 06, 2012 3:04 AM

All replies

  • Hi,

    terminal server first tries to use the TS Easy Print driver. If the client computer does not support this driver, the terminal server looks for a matching printer driver installed on the terminal server (Session host server).

    Did you mean the drive is set to Remote Desktop Easy Print printer driver by default?

    If you want using Printer Redirection, you must install a matching printer driver on the terminal server and client computer.
    You can disabled the "Use easy print driver first" setting in Terminal server local Group Policy and using printer redirection to test whether the same issue still exists.

    For details:

    Computer Configuration\Policies\Administrative Templates\Windows Components\Terminal Services\Terminal Server\Printer Redirection\Use Remote Desktop Easy Print printer driver first

    Using Remote Desktop Easy Print in Windows 7 and Windows Server 2008 R2

    In addition, please also make sure there is no related policy to prevent users from redirecting print jobs from the remote computer to a printer attached to their local (client) computer

    For details:

    Do not allow client printer redirection

    Hope this helps!

    Please remember to click “Mark as Answer” on the post that

    Elytis Cheng

    TechNet Community Support

    Tuesday, February 07, 2012 8:15 AM
  • Hi Elytis,

    I’ve had a look into our Group Policy’s and have found nothing to do with terminal services and printers enabled for redirection.

    I guess what I’m looking for how could this setting just apply itself to a number of users?

    Can I ask a question, has there been a Windows update that may have caused this to happen?

    Can it be anything else that may of cause this setting to apply?


    • Edited by The Decrypter Tuesday, February 21, 2012 1:24 AM
    • Marked as answer by The Decrypter Wednesday, February 29, 2012 2:00 AM
    • Unmarked as answer by The Decrypter Wednesday, February 29, 2012 2:00 AM
    Tuesday, February 21, 2012 1:23 AM
  • Hi Elytis,


    We have been able to resolve this issue by enabling some group policies to stop terminal service printer redirects.

    One thing we have not been able to answer is how this happened all of a sudden.


    I'm marking this as resolved.



    The Decrypter

    • Marked as answer by The Decrypter Wednesday, February 29, 2012 2:03 AM
    • Unmarked as answer by The Decrypter Tuesday, March 13, 2012 1:48 AM
    Wednesday, February 29, 2012 2:00 AM
  • One of the TS developer said it's due to an application on the client.   I'm pretty sure the application is not a MS product.  It's not the spooler service, but as the TS guy stated, you need to look on the client.  I realize you most likely can't set a breakpoint in a kernel debugger but I figured I would included the full quote.

    "You have an app on your Remote Desktop server which opens and closes the printer port. If you have a kd but a breakpoint on rdpdr!RDPDYN_Create

    I remember this was reported in the past but I forgot what apps was doing this"


    "The machine that submitted the job is the one that acted as an RDP client, you have to look at the machine to which you were connecting from that machine. Does it make sense?"

    Alan Morris Windows Printing Team

    • Marked as answer by The Decrypter Tuesday, March 13, 2012 1:47 AM
    • Unmarked as answer by The Decrypter Friday, April 13, 2012 4:10 AM
    Thursday, March 01, 2012 5:31 PM
  • Must be the good old date of the 13th,

    We are having the same issue again...... We created a GPO that would block Remote desktop prints but out of the blue we have the same issue again.

    The only thing that has change is Windows Updates have been applyed to worlstations and server.

    Any help would be great.

    The name of the file in the printer is "Remote Desktop Redirected Print doc"


    Friday, April 13, 2012 4:15 AM
  • Did you get a list of applications that could be causing the issue? 

    Alan Morris Windows Printing Team

    Friday, April 13, 2012 6:57 PM
  • The only program that would be in the way was Cute PDF. I ran the test by uninstalling and still the same issue :(

    Monday, April 16, 2012 2:20 AM