none
RD Gateway - Client issue RRS feed

  • Question

  • I have RDS server setup with gateway and several applications.   I have a lot of users using the applications without issue.  I have 1 user that has a new Windows 7 laptop and since getting the new laptop can't connect to the applications.  I can use his credentials from several other computers without issue, it's his computer with the issue.

    When he signs on he is prompted for the domain credentials,  keys them in and then gets the screen showing the applications.  when he clicks on the application instead of being prompted for the user id again, he gets a prompt of RDS Gateway and when he keys in his user it fails that it can't find the remote server.

    He is the only user having this issue.

    thanks,

    Friday, January 24, 2014 1:03 PM

Answers

All replies

  • Hello,

    The version of Remote Dekstop is the same on all the computer ? If the user account work from an other computer, I think the problem is related to the new desktop, like you said.

    Do you use certificate ? If yes, the certificate is installed on the new computer ?


    Regards

    Saturday, January 25, 2014 6:49 PM
  • Hi,

    In addition to Sebastian comment please provide some more details.

    Have you placed any policy for the system to login?
    Did you receive any particular Event ID\Error for this issue?

    As per the comment it seems that some authentication issue. Here providing you guide, you can go through for more information.

    1.  Remote Desktop Gateway client fails authentication with “Your user account is not authorized to access the RD Gateway”
    2.  TS Gateway Certificates Part II: How to deploy a certificate on TS Gateway

    Hope it helps!

    Thanks,
    Dharmesh
    Sunday, January 26, 2014 11:04 AM
    Moderator
  • Hi,

    Do you need any other assistance? If there is anything we can do for you, please let us know.

    Thanks,
    Dharmesh
    Tuesday, January 28, 2014 8:11 AM
    Moderator
  • Hi,

    Here writing to ensure that the problem has been completely resolved. If there is anything we can do to help on this issue, please feel free to let me know.

    Thanks,
    Dharmesh
    Friday, January 31, 2014 8:30 AM
    Moderator
  • Same RDP versions on desktops, same versions of OS and SPs.    We do have a certificate and I did have him install it.


    Monday, February 3, 2014 7:59 PM
  • Sorry folks,  I was out of town at a Technical conference and unavailable.   this is a customer and i have no access to their IT policies.   They can access from XP but not Windows 7.  I can access the same app via Windows 7.  I'm sure it's a network setting, I just don't know where to look.  I've checked:

    permissions

    RDP version

    Browser settings

    browser versions

    OS versions and SPs

    RDP settings screen for RDS gateway,  all our screens are identical.

    The RDS gateway user id/prompt he gets,  he shouldn't see that prompt ever.  It should be a prompt for another userid.   


    • Edited by MS724 Monday, February 3, 2014 8:06 PM
    Monday, February 3, 2014 8:02 PM
  • Hi,

    Did you check the link information for RD Gateway client fails authentication?

    Here I can suggest you to try remote session for that user by installing RDP 8.0 and check the result. Also uncheck the Bypass RD Gateway for local address option and check the result. In addition, please check the authorization policy for RD gateway server (RD CAP & RD RAP)configure correctly.

    Apart from this you can try “Allow users to connect to any network resource” for remote users to connect through RD gateway to internal network resources.

    Please check below article for more information.

    Understanding Authorization Policies for Remote Desktop Gateway
    http://technet.microsoft.com/en-us/library/cc731435.aspx

    Configure Network Level Authentication for Remote Desktop Services Connections
    http://technet.microsoft.com/en-us/library/cc732713.aspx

    Other than this there is Hotfix (KB 976484) you can check for following scenario.

    Hope it helps!

    Thanks,
    Dharmesh
    Tuesday, February 4, 2014 4:57 AM
    Moderator
  • Thanks Dharmesh.   

    It isn't a server issue, the hot fix is for the server.   I believe it is some unique network type setting on this users laptop.   They should not be seeing the RDS Gateway prompt at all, no other users sees that.  

    User connects from another laptop, he can sign in without issue.   When he tries from his Windows 7 laptop he gets the prompt for RDS Gateway.

    When I connect as the user on my windows 7 laptop, I can connect without issue.

    I've attached am image:  the logon screen to the left that says "Enter your Credentials" is what all users see and can connect when entering their user id's.    the screen to the right "RD Gateway Server Credentials" is the prompt this user is getting from his new laptop and when entering his domain credentials, it won't connect.

    I've been through all the settings I can think of and have found trying to research this prompt and his settings match those on my windows 7 laptop.


    Tuesday, February 4, 2014 12:42 PM
  • Hi,

    Thanks for comment.

    When connecting from client laptop in RDC, you need to check that he has selected “Use RD Gateway Server setting” and also specify the RD gateway name in Server and in Logon setting you can check “Use my RD Gateway Credential for remote computer. Please refer below article for more information.

    Securing Remote Desktop for System Administrators

    Hope it helps!

    Thanks,
    Dharmesh
    Wednesday, February 5, 2014 6:40 AM
    Moderator
  • Hi,

    How is everything going on there? Please share us the update for further assistance.

    Thanks,
    Dharmesh
    Friday, February 7, 2014 4:01 AM
    Moderator
  • Hi,

    Thanks for your comment.

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.
    If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

    Thanks,
    Dharmesh
    Monday, February 10, 2014 2:01 AM
    Moderator