none
WDS clients giving TFTP errors on PXE boot

    Question

  • Hello Everyone

     

    I am running a Native WDS server. I have added boot.wim and created a capture image with help. I have also done sysprep on a ref computer to be Imaged. The sysprep i used was from the installation CD of the ref computer.

     

    When I start the client with pxe it comes up with the following error messeges:

    TFTP

    PXE-T01: FILE NOT FOUND

    PXE-E3B: TFTP ERROR FILE NOT FOUND

    PXE-M0F: EXITING "PXE Manufacturer" PXE ROM

     

    Is there any explanation as to what this means and how it can be solved.

    Any ref to TFTP error walkthroughs will be much appretiated.

     

    Many Thanks

     

    Khan

    Monday, April 02, 2007 2:47 PM

Answers

  • ok, found out a little bit more about this.

     

    After installing SP2 you need to configur WDS or clients can't seem to get a RIS/WDS server. Once you have configured a WDS server, you need to add an appropriate architecture image to it or clients get TFTP errors. eg, if you are booting a x86 system, then make sure you add an x86 boot image to WDS server so that clients can boot to PXE.

     

    If you monitor your Reminst\boot\x86/x64 folder you will see there are only like 5- 7 files in it. After you add appropriate boot image the reletive folder will have more files in it allowing that TFTP error to vanish.

     

    Will post more as soon as I find out more about this puzzle.

     

    Ohh yea, you must have a copy of vista, x64<>x86 depeding on your architecture. Without a WIM boot image your pxe boot is not going to work.

     

    I tried to use a WIM file from WAIK to bypass these errors, but it does not work. Looks like it has to be from a Vista CD.

    Tuesday, April 03, 2007 12:35 PM

All replies

  • ok, found out a little bit more about this.

     

    After installing SP2 you need to configur WDS or clients can't seem to get a RIS/WDS server. Once you have configured a WDS server, you need to add an appropriate architecture image to it or clients get TFTP errors. eg, if you are booting a x86 system, then make sure you add an x86 boot image to WDS server so that clients can boot to PXE.

     

    If you monitor your Reminst\boot\x86/x64 folder you will see there are only like 5- 7 files in it. After you add appropriate boot image the reletive folder will have more files in it allowing that TFTP error to vanish.

     

    Will post more as soon as I find out more about this puzzle.

     

    Ohh yea, you must have a copy of vista, x64<>x86 depeding on your architecture. Without a WIM boot image your pxe boot is not going to work.

     

    I tried to use a WIM file from WAIK to bypass these errors, but it does not work. Looks like it has to be from a Vista CD.

    Tuesday, April 03, 2007 12:35 PM
  • To enable WDS to act as RIS did prior to SP2 update do the following:


    1) Open WDS Console.
    2) Right Click Server name and select Properties.
    3) Select the 'Boot' Tab
    4) Change the path from: boot\x86\pxeboot.com toSurpriseSChooser\i386\Startrom.com

    Phil.

     

    Wednesday, July 18, 2007 9:33 AM
  • Just one quick addition to the above...

    OSChooser\i386\Startrom.n12

    will start the client program without the insertion of the f12 key to get it started

    Monday, July 30, 2007 6:31 PM
  • Pretty goog! It works for me!
    Tuesday, July 08, 2008 2:43 PM
  • what is startrom.n12 and startrom.com
    Thursday, January 29, 2009 6:35 PM
  • Another work around is to change the PXE Response Settings:

    WDS Console --> ServerName --> Properties --> PXE Response Settings --> Try "Respond to all".

    After trying numerous things, this worked for me. My build network is in an isolated subnet, so secure enough to use this setting.

    Good Luck :-)
    Wednesday, January 13, 2010 3:50 AM
  • Make sure that everything is on the same subnet, it works better that way. Also make sure that the services you need are running on the pxe server.  and if you are using sccm 2007, make sure u assign the pxe role to that server.
    Wednesday, January 13, 2010 1:13 PM
  • Thanks  a lot it wrkd for me Chew :D please use OSChooser\i386\Startrom.com only,As this command will not start the installation auto.
    Thursday, April 01, 2010 11:21 AM