none
RDP client freezes randomly but frequently RRS feed

  • Question

  • Hi you experts,

    When I'm in home office, I connect from my home pc to my office pc through a VPN (Securepoint SSL VPN Client). For several weeks I'm having the problem that the client screen freezes ramdomly (say every 30 mins average during a whole day). I have to reconnect again to fix the situation. Sometimes (but not very often) even my office pc freezes too and a colleague has to reboot.

    Unfortunately at the time when the problem began, I both changed my home and office pcs, so I cannot say which change was the cause. Noone else in the company has or had this problem.

    Our IT department borrowed me a company laptop for one day, and I had no problems at all during this day. So I thought my home pc was the cause, and I bought a new one. Unfortunately, I have the same problem with it too.

    Both, home and office pcs run Windows 10. I did already a lot of research in the forums and the like, but no solution applied for me. To me it looks somehow like a bandwith issue, because mostly the freeze occurs when I'm doing a task switch (Alt-Tab) where a lot of screen content is replaced. I often recognize a delay here, or the screen needs a short delay until it is displayed in normal resolution. Of course, there is no general bandwith problem with my Internet connection. 

    WinVer:

    - office: Windows 10, Version 1809 (Build 17763.737)

    - home: Window 10, Version 1903 (Build 13362.418)

    Me, and our IT department has no more ideas. Can you help?

    Thanks, Michael





    • Edited by msms843 Thursday, November 7, 2019 3:44 PM
    Sunday, October 20, 2019 1:14 PM

Answers

  • I think my problem has been solved. Indeed, deactivation of UDP protocol did it. But deactivation on the client side as suggested above by Jenny didn't help for me.

    Instead I had to deactivate it with gpedit.msc on the server side at Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\Remote Desktop services\Remote Desktop Session Host\Connections\Choose RDP Transport protocols followed by a restart of the Remote Desktop Services in services.msc. The forced protocol setting is logged in event viewer at Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\Remote DesktopServices-RdpCoreTS on the server when a client connects.

    The problem has now been gone on both my pc and laptop.

    BTW, it sounds strange that UDP deactivation on the client side didn't work for me. Maybe the reason is that I'm using Windows 10 Home and the inofficially activated (see above) gpedit wasn't working correctly. Eventually with Windows 10 Pro this would work.




    • Marked as answer by msms843 Thursday, November 7, 2019 2:39 PM
    • Edited by msms843 Thursday, November 7, 2019 4:27 PM
    Thursday, November 7, 2019 2:39 PM

All replies

  • Hi,

     

    1. Have you got a chance to event logs on client and your PC office when freezing issue happened.

     

    Event log checking:

     

    TerminalServices-RemoteConnectionManager and TerminalServices-LocalSessionManager logs to view information about connections.

     

    Step 1: Press Windows+R to open the Run dialog, enter eventvwr (or eventvwr.msc) and hit OK.

     

    Step 2: Navigate to Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\ TerminalServices-*

     

     

    2.Per my research, some people experienced similar issue and resolved by turn off UPD on client PC.

     

    • Run Group Policy Editor. 

     

    • Navigate to Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client.  Set the "Turn Off UDP On Client" setting to Enabled.

     

    • GP update and no need to reboot.

     

    Please try the suggestion and let us know if any error message have been recorded.

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, October 21, 2019 5:53 AM
  • Hi Jenny,

    thanks for helping! Here are the event messages I found that look like problems:

    Home PC
    TerminalServices-ClientActiceXCode / Microsoft-Windowos-TerminalServices-RDPClient/Operational
    RDPClient_SSL: Fehler beim Übergang von "TsSslStateHandshakeInProgress" zu "TsSslStateDisconnecting" in Reaktion auf "TsSslEventHandshakeContinueFailed" (Fehlercode: 0x80004005) (Translation: Error at transition from ... to ...).
    This warning several times followed by some informational messages of category "Connection sequence", first one is: "Die Mehrfachtransportverbindung wurde getrennt" (Translation: The multiple transport connection was disconnected)

    Office PC
    TerminalServices-LocalSessionManager / Operational
    - lot of informational messages "Session "xx" was disconnected. Reason code y" (Codes 0, 5, 11, 12)

    Regarding the UDP setting. Yes, I found this advice in other postings too. I was not sure whether it had be changed also on the office PC, in which case I had to ask our IT guys to change the group policy setting. But I understood you it only must be changed on the client. But this feature is not available with Windows 10 Home. So what should I do here?

    Unfortunately (or lucky for me), I'm two weeks off now. I will read my mail, but will not work remotely.So I'll come back with feedback in two weeks. Thanks so far.

    Best regards

    Michael


    • Edited by msms843 Monday, October 21, 2019 2:01 PM
    Monday, October 21, 2019 1:58 PM
  • But this feature is not available with Windows 10 Home.

    Found instruction how to activate gpedit and disabled UDP as described.

    Monday, October 21, 2019 5:36 PM
  • A quick test after the UDP setting change showed the same event log messages on local and remote PC as before. Whether the connection is more stable now, I cannot tell unless I work for a longer time.
    • Edited by msms843 Monday, October 21, 2019 5:54 PM
    Monday, October 21, 2019 5:53 PM
  • Hi Michael,

     

    Thanks for the update with details and will wait for your next reply when you are back to work.

     

    Meanwhile, have you found any error code when checking event logs? The details you shared are some descriptions only but we need error code to investigate further.

     

    And please confirm if the freezing client issue happened randomly or each time you remote?

     

    Thanks,

    Jenny


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, October 22, 2019 7:09 AM
  • Hi Jenny,

    > Meanwhile, have you found any error code when checking event logs? The details you shared are some descriptions only but we need error code to investigate further.

     

    What I found in the event logs is written in my comments above.  What are you missing?

    <p>

    > And please confirm if the freezing client issue happened randomly or each time you remote?

    Yes, it feezes several times during a work day. Sometimes every few minutes, so that working becomes impossible.




    • Edited by msms843 Sunday, November 3, 2019 3:35 PM
    Sunday, November 3, 2019 3:33 PM
  • Hi Jenny,

    As announced I'm back at work. This is my today experience after a whole day of remote work in home office with disabled UDP on home PC as commented on October, 21.

    In the morning working went quite well. I observed slight latency problems (1-2 seconds), but it wasn't too annoying. Around noon latency increased to about 10 seconds and I had to reconnect again.

    In the afternoon the situation became worse. Latency was annoying and I had to reconnect several times.

    In Event Viewer on the office PC I found  Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\Remote DesktopServices-RdpCoreTS where the latency issues were beeing logged (Event ID 137, Minimum 1 KBit/s). 

    I wanted to attach a screenshot of my event viewer here, but I'm not allowed.

    As conclusion I would say the UDP deactivation had no effect on the problem. Tomorrow I'll try another thing.

    Best regards

    Michael

    Wednesday, November 6, 2019 3:52 PM
  • BTW, there's no general bandwith problem with the VPN connection. I can download a big file with SSH with 800 KB/s.
    Thursday, November 7, 2019 8:35 AM
  • I think my problem has been solved. Indeed, deactivation of UDP protocol did it. But deactivation on the client side as suggested above by Jenny didn't help for me.

    Instead I had to deactivate it with gpedit.msc on the server side at Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\Remote Desktop services\Remote Desktop Session Host\Connections\Choose RDP Transport protocols followed by a restart of the Remote Desktop Services in services.msc. The forced protocol setting is logged in event viewer at Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\Remote DesktopServices-RdpCoreTS on the server when a client connects.

    The problem has now been gone on both my pc and laptop.

    BTW, it sounds strange that UDP deactivation on the client side didn't work for me. Maybe the reason is that I'm using Windows 10 Home and the inofficially activated (see above) gpedit wasn't working correctly. Eventually with Windows 10 Pro this would work.




    • Marked as answer by msms843 Thursday, November 7, 2019 2:39 PM
    • Edited by msms843 Thursday, November 7, 2019 4:27 PM
    Thursday, November 7, 2019 2:39 PM