none
TASK SCHEDULER: scheduler status is being “RUNNING” always

    Question

  • Hi,

    I 'm having a problem while getting to run a .exe with windows task scheduler(I'm using Windows 2008 R2) Even after its tasks is finished, scheduler still shows status of "running". I want to get the status as "ready" after the exe file gets executed completely.

    I have checked in task manager the process is not showing after the job is completed. but the scheduler status is being "RUNNING" instead of "READY".

    Thanks

    Mayil.M

    Wednesday, April 10, 2013 10:35 AM

Answers

  • What’s the executable scheduled to run?  Here, RUNNING means the task is running not the executable. This actually should not cause problem if you have the option "If the running task does not end when requested, force it to stop" enabled in Settings tab.

     

    In Settings tab, you can also enable the option "Stop the task if it runs longer than" to stop this task. Then the task statues would be READY.

      

    Regards,

    TechNet Subscriber Support

    If you are TechNet Subscriptionuser and have any feedback, please send your feedback here.

    Thursday, April 11, 2013 6:43 AM
    Moderator
  • To me this says that the task you're running isn't properly stopping after it's done. You might want to check in the task manager (+show tasks from all users) to see if it is indeed still running. 

    A solution to this depends entirely on what it is you're running, whether it's GUI based (generally a bad idea) or you've got some of the command line parameters incorrect. Can generally fall down to permissions that the 'script' or command line tool has when it runs, or just a very badly coded program.

    Thursday, April 11, 2013 8:58 AM

All replies

  • Hi,

    I 'm having a problem while getting to run a .exe with windows task scheduler(I'm using Windows 2008 R2) Even after its tasks is finished, scheduler still shows status of "running". I want to get the status as "ready" after the exe file gets executed completely.

    I have checked in task manager the process is not showing after the job is completed. but the scheduler status is being "RUNNING" instead of "READY".

    How to solve this problem, How can we make task scheduler automatically set the status as "READY" once the exe file gets executed completely

    Thanks

    Mayil_Gilli

    Wednesday, April 10, 2013 10:24 AM
  • What’s the executable scheduled to run?  Here, RUNNING means the task is running not the executable. This actually should not cause problem if you have the option "If the running task does not end when requested, force it to stop" enabled in Settings tab.

     

    In Settings tab, you can also enable the option "Stop the task if it runs longer than" to stop this task. Then the task statues would be READY.

      

    Regards,

    TechNet Subscriber Support

    If you are TechNet Subscriptionuser and have any feedback, please send your feedback here.

    Thursday, April 11, 2013 6:43 AM
    Moderator
  • To me this says that the task you're running isn't properly stopping after it's done. You might want to check in the task manager (+show tasks from all users) to see if it is indeed still running. 

    A solution to this depends entirely on what it is you're running, whether it's GUI based (generally a bad idea) or you've got some of the command line parameters incorrect. Can generally fall down to permissions that the 'script' or command line tool has when it runs, or just a very badly coded program.

    Thursday, April 11, 2013 8:58 AM
  • Hi, 

    I've enabled the option "Stop the task if it runs longer than 2 minutes" to stop a running task, however, it would stay in "running" status forever and never stops. I tried the option in both "Triggers" and "Settings" tabs but non of either, or combine the two works.

    My task is a batch file that calls some commands in command prompt, and the batch file will create a "lock" bat file to avoid others to run the same program simultaneously. I'm testing on task scheduler so if someone is running the program manually, then the task scheduler will just kill the task after 2 minutes instead of "trying to run/and being locked" forever. Would you please advise on how I should set this up so the Task Scheduler can force the task to stop?

    Thank you!

    Ailun

    • Proposed as answer by AilunJ Wednesday, June 11, 2014 7:42 PM
    Wednesday, June 11, 2014 7:41 PM
  • I have the exact same problem as Ailun. Just running a script that takes seconds to run.
    Tuesday, August 19, 2014 8:51 PM
  • It depends on the .exe. I just want to share what I encountered.

    My exe files was a console application created using visual studio. I used it to backup some database. My last line of code was "Console.ReadLine()". In that case, task scheduler cant terminate the exe file because it's waiting for a user to input for that readline. So I removed that one and task scheduler shows now "operation completed successfully".

    Hope this helps.

    Wednesday, September 16, 2015 7:23 AM
  • I find this problem also - to fix I place the executable.exe in a batchfile.bat and on the second line of the .bat i use the EXIT command.  Then I use Task Scheduler to run the .bat not the .exe    When the batch file exits the scheduler returns to READY state


    Letto

    Monday, October 05, 2015 12:10 AM
  • I had the same problem - the task worked but the status kept showing Running.  One simple thing to try is click on the Task Scheduler Library in the left column.  Click Action/Refresh.  Presto.  Status changed to Ready.  That's all it was for me, the task ran fine, just the status didn't update.  Hope this helps.

    Tuesday, March 22, 2016 10:45 AM
  • Wow, I don't believe that worked.  I just closed task scheduler and re-opened it and the status said "Ready".  I have to say that's is an annoying bug.  Btw, I'm using Windows Server 2012 R2
    Monday, September 12, 2016 8:00 PM