IPV6 Clients don't get registered in DNS unless I add an entry RRS feed

  • Question

  • Hello all,

    I have a test IPV6 network DC with DNS. On my client windows 7 machine I add a static address and add it to my ipv6 domain. If I ping my windows 7 machine from another windows 7 machine i get the fe link local address. If I manually put a host record AAAA with the proper IPV6 address 3fff in the DNS then when I ping the machines I get the proper IPV6 address. Shouldn't the DNS update itself or do I have to manually put a entry everytime I use a static address.

    If I use a DHCP server to issues addresses and add the machine to the domain. How long before a DNS entry shows up? Or in with IPV6 entries maybe they don't show up in DNS.

    Has anybody been able to get their IPV6 addresses to show in DNS or is manually the only way?

    Saturday, February 18, 2012 12:50 AM

All replies

  • By default, Windows client will automatically try to register themselves in DNS using the IP address of the DNS system ther are configured to use -- this is for both IPv4 and IPv6. However, link-local addresses (those that start with fe) won't typically register in DNS because for a couple fo reasons (IME).

    Have you verified that you haven't accidentally unselected the auto-register option? It's on the DNS tab for IP configuration.

    Have you verified that the system has connectivity to the defined DNS server? A simple ping by IP should work for this but may not depending on the firewall.

    Are the systems part of a domain? If not, have you verified that your DNS server allowsnon-secure dynamic updates?

    Have you verified that your server allows dynamic updates at all?

    Jason | | Twitter @JasonSandys

    Saturday, February 18, 2012 8:34 PM
  • Hi Jason,

    All the computers are connected to a domain (ipv6.local).  The dns and dhcp are both on the DC which is called ipv6dc. The issues I'm having is my client machines are getting a DHCP address but fail to connect to domain. I believe the issue is the client's are getting the route/prefix. I'm not using an IPV6 router so the route has to be advertised either on the dhcp server or client. I did some research and found I need to enter the following command on my client machines.

    Netsh interface ipv6 set interface  advertise=enabled
    For my example: Netsh interface ipv6 set interface 11 advertise=enabled
    4) type Netsh interface ipv6 add route 1024://64  publish=yes
    For my example: Netsh interface ipv6 add route 1024::/64 11 publish=yes
    5) type Netsh interface ipv6 add route {your prefix::/64} } publish=yes
    For my example: Netsh interface ipv6 add route fda8:06c3:ce53:a890::/64 11 publish=yes

    Anyways, if I have been using static addresses for now and my machines can be added to the domain without a problem. The issue is when I use a static address it doesn't appear an a DNS entry or host AAAA record. I have to manually add an entry and so when I ping machine on my domain I will get a 3fff address and no the link-local address.

    Monday, February 20, 2012 5:58 PM
  • To anwser your questions above,

    I check on my clients machines and they have register this connection's address in DNS check off in advanced TCP?IP settings

    i can ping my dns server from my client machine, if I do ipconfig /all it will list my dns server witha 3ff address not a fe (link-local)

    Where can I find DNS server allowsnon-secure dynamic updates and allows dynamic updates at all?


    Monday, February 20, 2012 6:06 PM