Connection to the internet using Hyper-V


  • How do I connect to the internet using Hyper-V 2008 Server R2?
    Tuesday, December 29, 2009 3:59 PM

All replies

  • Are you trying to attach a guest to the internet, or the Hyper-V server itself?  You really should only need to attach to the internet for updates to the host system, if at all. 

    Tuesday, December 29, 2009 4:17 PM
  • We are trying to attach a guest
    Tuesday, December 29, 2009 4:19 PM
  • In order to connect a guest to the internet, or any LAN, you need to:

    1.  Determine a NIC on the physical host you'd like to use for guests.   I'd suggest minimum of 2 NICs (one for management and another for guests)
    2.  Create a virtual network under Hyper-V Manager as an "external" network and associate it with the chosen NIC
    3.  Open the settings of the virtual machine (guest) and add a synthetic network card and associate it with the virtual network you created.
    4.  Install the operating system on the virtual machine and install the integration components, allowing the VM to use the synthetic NIC.
    5.  The VM will now act like any other server on the network, such that you'll need to set the IP address, subnet, DNS, gateway, etc. 

    I hope this helps you out.

    Nathan Lasnoski

    Tuesday, December 29, 2009 4:37 PM
  • We did that but it did not work.
    Tuesday, December 29, 2009 4:39 PM
  • There are a couple more details..

    1) if using a Synthetic NIC (Network Adapter) the Integration Services must be installed in the VM (otherwise give the VM a Legacy Network Adapter)

    2) your Server physical NIC associated with the External Virtual Network must be patched into a physical switch on the network.

    3) Your network must assign IP addresses for the VM to get one.

    Any additional symptoms or configuration details would be highly useful in helping us to understand your problem.

    Be sure to check the VM and see what is going on in the operating system of the VM.  Those are important details as well.

    Brian Ehlert (hopefully you have found this useful)
    Tuesday, December 29, 2009 5:20 PM
  • We are running Windows Server 2008 R2 Standard Guest operating systems which do not require the Integration Services to install.  The network cards are showing up on the guests and they actually have an IP Address assigned to them but they cannot connect to the internet.  When trying to diagnose them, it states that the DNS server is not responding.  The host os works fine.

    Tuesday, December 29, 2009 5:54 PM
  • If I add the legacy network adapter it will work but the regular network adapter does not work and since this is Windows Server 2008 R2 you cannot install Integration Services
    Tuesday, December 29, 2009 7:25 PM
  • Do other VMs work for you?

    Have you turned off firewall on all the profiles within the host and guest?
    Tuesday, December 29, 2009 8:41 PM
  • I have 4 VMs and none of them work with the regular network adapter on the external network.  The regular network adapter does work with the private network.  I have disabled the firewall on all the guest vms and the host and still cannot connect to the internet.  When I use the legacy network on all the vms the internet works fine, but I would like to use the gigabit connection since it is a gigabit network.  Again the host OS is Microsoft Hyper-V Server 2008 R2 and all the vms are Windows Server 2008 R2 Standard.
    Tuesday, December 29, 2009 8:56 PM
  • Hi,


    In order to isolate the issue, please help me to collect the following information:


    1.    Can you ping the internet from the inside of the problematic virtual machine?

    2.    Did you encounter the same issue with other virtual machine such as Windows XP or Windows Server 2008?

    By the way, the following post discussed the similar issue, please refer to:


    Network Adapter (not Legacy) does not work on Virtual Machine after installation through ISO



    By the way, please disable TCP offloading on the physical network adapter to check whether it works. You can also add an additional physical network adapter and then create an External Virtual Network bind to it to check whether the issue continues.



    Best Regards,

    Vincent Hu


    Wednesday, December 30, 2009 6:42 AM
  • 1.  No i cannot ping the internet or any other computers from this network card.
    2.  This happened on all 4 of my virtual machines (all running Server 2008 R2 Standard).

    I looked at the other thread and i tried that and it did not work.  I disabled TCP Offloading and that did not work.  The regular network adapter does work with private virtual network but not the external virtual network. We currently have another server running Windows Server 2008 Datacenter with Hyper-V which has a guest OS of Windows Server 2008 R2 Standard and its network adapter works fine.  I used the same ISO image from the working vm to install the 4 vms on Hyper-V Server 2008 R2. 
    Wednesday, December 30, 2009 2:09 PM
  • 2008 R2 as a VM does not _require_ the ICs, be installed - that is true.

    However, it does require patch level equality. - the fact that the Legacy NIC works, means that this is isolated to the VMBus and possibly the host NIC drivers.  A combination of the two.

    What happens when you attempt to install the ICs into the VMs?

    I have heard of folks that need to install the ICs into the VMs, then uninstall, then install again to resolve similar issues.

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 3:05 PM
  • When i try to install the ICs it says "The Hyper-V integration services are already installed on this version of Windows".  I checked in the Programs and Features and there is no where for me to uninstall these components.
    Wednesday, December 30, 2009 3:18 PM
  • Then lets look at the other angle of this - the NIC driver of the host.  That has not been mentioned yet, however since this issue is only happening when the paravirtualized NIC is attempted to be used, I feel it is worth bringing up.

    Is the Host using the stock network drivers that shipped with the installation media?
    What brand are the network drivers?
    Were any thrid party network drivers installed?  Or configured in any way?

    Have you tried disbling TCP Offloading in the driver properties of te physical NIC?

    And, have you sent a diagnostic collection to Microsoft as Vincent outlined?

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 3:48 PM
  • The NIC driver is a stock HP driver that came with the server, no third party drivers were installed.  From what i could find there is only one driver that supports Server 2008 R2.  I disabled TCP Offloading through netsh since hyper-v server 2008 R2 is all CLI.  I have not sent a diagnostic collection to Microsoft.
    Wednesday, December 30, 2009 4:11 PM
  • What is the command that oyu used to disable TCP Offloading?

    There are different commands floating around - one outlines going through the registry and disabling the settings of the nic driver.  One works through netsh settings, another simply is a one liner that disables TCP Chimney.

    I bring this up because disabling TCP Chimney is not the same as disabling tcp offloading features such as Large Send offload, IPv4 settings, etc.
    So I just want to make sure that you changed the correct settings.

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 4:19 PM
  • I am wondering if your situation is similar to this:

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 4:26 PM
  • I finally found this that might help:

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 4:29 PM
  • So do i disable the three that Markus Schuhmacher  said?  Or all that are listed in the msdn article?
    Wednesday, December 30, 2009 4:42 PM
  • Never mind i misread the bottom of the msdn article, so technically all i have to do is set HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload  to 1 and HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Ipsec\EnabledOffload to 0 and that should disable taskoffloading for me?
    Wednesday, December 30, 2009 4:45 PM
  • as far as I know - but it is the differences in drivers that makes it confusing.

    I know many folks that disable them all, just to be safe.

    Brian Ehlert (hopefully you have found this useful)
    Wednesday, December 30, 2009 11:06 PM
  • Hyper-V Server 2008 R2 apparently does not have these registry keys.  Should i create new ones? What are their type?
    Monday, January 04, 2010 2:11 PM
  • You must consider the entire article - the options are different per NIC and per driver.
    It all depends on the driver and what keys the driver presents.

    Brian Ehlert (hopefully you have found this useful)
    Monday, January 04, 2010 4:41 PM
  • OK.  I do not see any of those in the path at the bottom of the page.  If that is not the correct path, where is the correct path?
    • Edited by JoAnn S Monday, January 04, 2010 9:58 PM at sounded a little more confusing.
    Monday, January 04, 2010 9:51 PM
  • Hi,


    Please check the following guide.


    Using Registry Values to Enable and Disable Task Offloading




    Best Regards,

    Vincent Hu


    Wednesday, January 06, 2010 6:00 AM
  • I looked for these values and i could not find them.  I must be looking in the wrong registry location.  What location should i be looking in for these keys?
    Friday, January 08, 2010 2:19 PM
  • I found mine under HKLM\System\CurrentControlSet\Control\Class\{driver GUID}

    I started at the root of the registry and did a search using "ChecksumOffload" or "Offload" or "Checksun"

    Each manufacturer might name these slightly differently - it is their discretion.

    Brian Ehlert (hopefully you have found this useful)
    Friday, January 08, 2010 6:47 PM