none
VM failed to start - Unable to allocate Ram: insufficient system resources - Error 0x800705AA

    Question

  • I havebeen running lot of VMs on the same Windows 2008 R2 server with Hyper-V role installed since November 2010. I updated server to SP1 a long time ago and keep server updated. No antivirus installed. This is standalone training server. No active directory. Intel Core i7 with 6GB RAM.

    On Thursday, I tried to start 4 VMs (usuallyI ran 5 to 7 simultaneous VMs) and when I tried VM #3 I got the following error:

    MachineName failed to start

    Unable to allocate xxx MB of Ram: insufficient system resources exist to complete the request service (0x800705AA)

    So I spent last 4 days going through different tests:

    • Remove video card driver.
    • Disabled all software running on the server (this software was running before)
    • Uninstall all software I can.
    • Check online for similar issues.
    • Modified the cached physical memory reservation (using the registry key), to increase free physical memory.
    • Change memory assignment on VM to dynamic.
    • Applied few hotfixes (KB983289 and KB979149)
    • Check the event viewer for more info
    • Verify I have enough space on all disk partitions
    • Reinstall Hyper-V

    Usually I ran for VMs ( 2 x 512MB of RAM + 2 x 768 RAM) and again I was doing this since November 2010.

    As you can see below there are plenty of memory available.

    Anyone can help on this?

    Thanks!

    Guillermo Musumeci

    Monday, February 13, 2012 1:23 PM

Answers

  • I've seen reports of something like this recently -- it's a google
    background program called GooglecrashHandler.exe.  If you have that
    active on your system, that's what is doing it and you should disable it.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Monday, February 13, 2012 1:59 PM

All replies

  • I've seen reports of something like this recently -- it's a google
    background program called GooglecrashHandler.exe.  If you have that
    active on your system, that's what is doing it and you should disable it.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Monday, February 13, 2012 1:59 PM
  • Thanks Bob!

    I killed these 2 googlecrashhandler*.exe files, removed from task scheduler and delete the folder fixed the issue. The interesting part of this is how this c*** was installed on my system by Google? Also there is no reference on Control Panel. I never installed any software from Google on my system.

    Guillermo

    Monday, February 13, 2012 2:47 PM
  • You're welcome!
     
    This is a pretty new problem that just started showing up recently.  I
    don't know what installs it unfortunately.
     
     

    Bob Comer - Microsoft MVP Virtual Machine
    Monday, February 13, 2012 3:00 PM
  • To add to Bob's reply.

    If you access your Hyper-V Server using RDP and you never logout of your RDP session to the Hyper-V Server management OS...  over time yuor user session will continue to comsume more and more RAM.

    The way to prevent this is to logout of your remote session (and make a practice of it) instead of always disconnecting.

    This would also clean up background processes such as this google thing.


    Brian Ehlert (hopefully you have found this useful) http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Backup, test your backup, try new things. Attempting change is of your own free will.

    Monday, February 13, 2012 4:01 PM
    Moderator
  • Thank you Bob. This is very helpful information. One of my users had a same problem yesterday and I didn't know how to resolve this. You save me a lots of time. Once again, thank you :)

    Romeo Mlinar
    MCSA, MCSE, MCTS, MCITP
    Blog: Admin troubles
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, February 16, 2012 10:02 AM
  • To expand Romeo's reply.

    I experienced the described problem of hyper-v virtual machines running just fine and then starting to report the „Unable to allocate xy MB of Ram:… (0x800705AA) “ error just recently (in the same environment as above, enough memory, enough RAM).

    I use Google Chrome and Google Talk regularly, and I am not aware that I have updated or changed any of them before the error started to appear. I have installed other applications recently, but then deinstalled them all after the error appeared, what did not help. Manually killing the GoogleCrashHandler.exe processes in task manager finally brought my virtual machines to life after a few days of wondering around.

    Additional note: As described here - http://www.ghacks.net/2011/05/16/googlecrashhandler-exe-process-update/, the 2 GoogleCrashHandler.exe processes run because you have accepted the Google’s default setting to „Automatically send usage statistics and crash reports to Google“ in some of your installed Google aps. In Chrome, for example, this option can be turned off in Options-->Under The Hood.


    Thursday, February 16, 2012 10:39 AM
  • Hi,

    Thanks Bob for this solution, it worked on my server too.

    Regards,


    Laeeq Qazi|Team Lead(Exchange + Sharepoint + BES + DynamicsCRM) www.HostingController.com

    Friday, March 2, 2012 3:02 PM