locked
Screen resolution when PXE boot from WDS vs Install Windows 8.1 from USB RRS feed

  • Question

  • Hi all

     

    I own a Lenovo ThinkPad T430s, X230 Tablet, and now have my hands on a T440. All three machines have UEFI Secure Boot enabled properly, i.e. Windows boot screen shows Lenovo logo instead of Windows logo.

     

    However, if I do a PXE boot (using Windows Deployment Services from Windows Server 2012, not R2) and boot to the same boot.wim provided on a Windows 8.1 ISO image, the boot screen resolution turns crap, and the WinPE environment runs in 640x480. Also, as opposed to the Lenovo logo showing on the boot screen, the Windows logo shows up instead, indicating it's not doing a secure boot?

     

    When booting from a USB stick however, using the same Windows 8.1 boot.wim (copied from ISO), the screen resolution in Windows Setup is detected correctly, and the Lenovo logo shows up.

     

    This occurs on all three machines since MDT was upgraded to MDT 2013 or when I replaced Windows 8 boot.wim with Windows 8.1 boot.wim (as the Windows ADK 8 --> ADK 8.1).

     

    Is there a fix for this? Do others have the same problem elsewhere?

     

    Many thanks :smileyhappy:

    Saturday, March 1, 2014 12:03 AM

Answers

  • Boooo!!!! Found the easiest hack!

    In the RemoteInstall folder, move "wdsmgfw.efi" out. 

    Make a copy of "bootmgfw.efi" and rename it to "wdsmgfw.efi".

    Everything is fixed O.O

    Obviously the "wdsmgfw.efi" is the WDS boot loader, but the other one "bootmgfw.efi" is the generic boot loader that works the magic.

    • Marked as answer by hubertlam Wednesday, April 9, 2014 10:06 AM
    Wednesday, April 9, 2014 10:06 AM
  • Hi,

    When boot UEFI-based computer from PXE you should take more into consideration.

    For some computers, you might have to perform additional steps to make sure that Windows is installed in UEFI mode, and not in legacy BIOS-compatibility mode.

    Some computers might support UEFI. However, they do not support a PXE-initiated boot when in UEFI mode.

    How to Create a PXE-Initiated Windows 8 Deployment for UEFI-Based or BIOS-Based Computers in Configuration Manager

    http://technet.microsoft.com/en-us/library/jj938037.aspx

    Especially for “Pre-Deployment Considerations”

    If you still cannot find a way to make it boot from UEFI mode, you should contact with manufacture to confirm if PXE-initiated boot is supported.

    Hope this helps.

    • Marked as answer by Daniel JiSun Thursday, March 6, 2014 2:18 AM
    Monday, March 3, 2014 8:23 AM
  • The BIOS image (BGRT) is only read by Windows when booting in UEFI mode. If it boots in Legacy Mode, it will show the Windows logo instead.

    So the reasons for the difference:

    - You are doing a UEFI boot with the USB key.
    - You are doing a Legacy boot with PXE.

    • Marked as answer by Daniel JiSun Thursday, March 6, 2014 2:18 AM
    Monday, March 3, 2014 3:50 PM

All replies

  • Hi,

    When boot UEFI-based computer from PXE you should take more into consideration.

    For some computers, you might have to perform additional steps to make sure that Windows is installed in UEFI mode, and not in legacy BIOS-compatibility mode.

    Some computers might support UEFI. However, they do not support a PXE-initiated boot when in UEFI mode.

    How to Create a PXE-Initiated Windows 8 Deployment for UEFI-Based or BIOS-Based Computers in Configuration Manager

    http://technet.microsoft.com/en-us/library/jj938037.aspx

    Especially for “Pre-Deployment Considerations”

    If you still cannot find a way to make it boot from UEFI mode, you should contact with manufacture to confirm if PXE-initiated boot is supported.

    Hope this helps.

    • Marked as answer by Daniel JiSun Thursday, March 6, 2014 2:18 AM
    Monday, March 3, 2014 8:23 AM
  • The BIOS image (BGRT) is only read by Windows when booting in UEFI mode. If it boots in Legacy Mode, it will show the Windows logo instead.

    So the reasons for the difference:

    - You are doing a UEFI boot with the USB key.
    - You are doing a Legacy boot with PXE.

    • Marked as answer by Daniel JiSun Thursday, March 6, 2014 2:18 AM
    Monday, March 3, 2014 3:50 PM
  • Thanks all.

    What makes it quite puzzling is that the Windows logo shows up during booting via PXE, but everything installs fine on to the GPT partition. 

    Whilst PXE booting, the computer loads wdsmgfw.efi.

    CSM/Legacy mode has been disabled in the system setup.

    Any other ideas?

    Wednesday, April 9, 2014 9:36 AM
  • Boooo!!!! Found the easiest hack!

    In the RemoteInstall folder, move "wdsmgfw.efi" out. 

    Make a copy of "bootmgfw.efi" and rename it to "wdsmgfw.efi".

    Everything is fixed O.O

    Obviously the "wdsmgfw.efi" is the WDS boot loader, but the other one "bootmgfw.efi" is the generic boot loader that works the magic.

    • Marked as answer by hubertlam Wednesday, April 9, 2014 10:06 AM
    Wednesday, April 9, 2014 10:06 AM
  • Boooo!!!! Found the easiest hack!

    In the RemoteInstall folder, move "wdsmgfw.efi" out. 

    Make a copy of "bootmgfw.efi" and rename it to "wdsmgfw.efi".

    Everything is fixed O.O

    Obviously the "wdsmgfw.efi" is the WDS boot loader, but the other one "bootmgfw.efi" is the generic boot loader that works the magic.


    Just for your information, this does not work anymore in latest CM versions.
    Sunday, December 4, 2016 1:27 PM