none
Move-ClusterSetVM command in Server 2019 RRS feed

  • Question

  • Hi there,

    I am currently setting up a lab to test out cluster sets in Server 2019 by following https://docs.microsoft.com/en-us/windows-server/storage/storage-spaces/Cluster-Sets

    Right now I am stuck on the step for testing out live migrate between cluster sets by running the command Move-ClusterSetVM. The example command shown was -

    Move-ClusterSetVM -CimSession CSMASTER -VMName CSVM1 -ClusterName CLUSTER3

    But -ClusterName is not even a valid parameter. There is another parameter called -Node, but when I tried to specify a node on a different cluster set, all I got was an error saying the move encountered a terminal failure.

    So has anyone managed to get live migration working for cluster sets?

    Wednesday, October 17, 2018 3:36 AM

All replies

  • Hi,

    You have to specify the node in the cluster to where you want to move the VM.

    So the following PowerShell command didn't work?

    Move-ClusterSetVM -Cimsession CSMASTER -VMName CSVM1 -Node CLUSHYPNODE2

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 17, 2018 7:09 AM
  • Hi Leon,

    When I ran that command, I got the following output. I tried to check the Hyper-V events on the source node (HV01) but I couldn't find any event related to the failure (maybe I was looking at the wrong place?).

    My test setup is very simple, just two clusters and there is only one node in each. I was able to follow the MS document up until the point for testing out Move-ClusterSetVM. I was also able to live migrate another VM between HV01 and HV02 with shared nothing live migrate (this VM isn't added to the cluster set), so constraint delegation between the two nodes should be fine too.

    My CSVM1 was added to the cluster set by using the script outlined in that MS document too.

    PS C:\Windows\system32> Move-ClusterSetVM -CimSession csmaster -VMName CSVM1 -node HV02
    Move-ClusterSetVM : The move encountered a terminal failure. Check Hyper-V events on the source node for more
    information.
    At line:1 char:1
    + Move-ClusterSetVM -CimSession csmaster -VMName CSVM1 -node HV02
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (MSFT_ClusterSetVM (Id = 1):root/microsoft/...FT_ClusterSetVM) [Move-Clust
       erSetVM], CimException
        + FullyQualifiedErrorId : HRESULT 0x8007139f,Move-ClusterSetVM
        + PSComputerName        : csmaster
    
    Move-ClusterSetVM : csmaster: Failed to run CIM method Move on the MSFT_ClusterSetVM (Id = 1) CIM object.  The CIM
    method returned the following error code: 2147947423
    At line:1 char:1
    + Move-ClusterSetVM -CimSession csmaster -VMName CSVM1 -node HV02
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidResult: (MSFT_ClusterSetVM (Id = 1):CimInstance) [Move-ClusterSetVM], CimJobExcep
       tion
        + FullyQualifiedErrorId : CimJob_Move_2147947423,Move-ClusterSetVM
        + PSComputerName        : csmaster
    Wednesday, October 17, 2018 8:56 PM
  • Not sure actually where the logs are, maybe the cluster logs?

    The error is very strange, I haven't been able to try this myself yet but I saw a live demo of the Move-ClusterSetVM.

    Check the video here:

    Cluster Sets in Windows Server 2019: What is it and why should I use it? - THR3127
    (From Microsoft Ignite 2018)
    You can watch the full video (19:45min) or jump straight to the video at 15:30 min in where a demo of
    Move-ClusterSetVM will be done.


    Blog: https://thesystemcenterblog.com LinkedIn:

    Wednesday, October 17, 2018 11:14 PM
  • @Renegra380

    Can you try this on the hosts first to see if it works for you.

    Set-VMHost -UseAnyNetworkMigration $true

    After doing so, can you do the live migration?  If you are still getting errors, the command to collect all the Cluster Set Logs would be:

    Get-ClusterSetLog

    You could go through them on both sides to see what the error may be caused by.

    Let me know.


    Thanks, John Marlin Microsoft Program Manager

    Tuesday, April 16, 2019 4:36 PM