none
Virtual desktop template creation with UR1 - two issues RRS feed

  • General discussion

  • There are two new issues affecting Virtual Desktop template creation with WMS 2012 with UR1.

    Issue #1: Some systems fail to create a new or customized virtual desktop template with UR1 applied. UR1 includes an updated MultiPoint Connector which is compatible with a UR1 host. The Connector gets included in the Virtual Desktop template so that the virtual desktops can be managed by MultiPoint Dashboard. On some systems installation of the UR1 Connector will require a reboot that takes too long to complete and template creation will timeout.

    If you try to create a template without doing the following update to the unattend-t.xml file, and if the Connector reboot takes too long, the template creation process will never complete, appearing stuck at 80% until the timeout. If you check the running Virtual Machine Connection, you will see an error message that Windows could not complete the installation.

    Error: windows could not complete the installation

    To correct this:

    1. From MultiPoint Manager or Hyper-V Manager, shutdown the running template VM.
    2. Delete the template .vhd stored in Public Documents\Hyper-V\Virtual hard disks

    My documents, public documents, Hyper-V, Virtual hard disks

     3. a) Make a backup copy of C:\Program Files\Windows MultiPoint Server\Unattend-t.xml

               e.g. rename it .bak

    b) open C:\Program Files\Windows MultiPoint Server\Unattend-t.xml in your favorite text editor.

    b) find “connector” in the file

    c) replace this string (starts with <Path> and ends with </Path>)

    <Path>powershell -Command &quot;try { $process = Start-Process -FilePath &apos;%Windir%\Temp\Connector\WmsConnector.Exe&apos; -ArgumentList &apos;/Quiet&apos; -PassThru -Wait; } catch { throw &apos;WmsConnector Install Failed&apos;}; exit $process.ExitCode&quot;</Path>

    with this string

    <Path>powershell -Command &quot;try { $p = Start-Process -FilePath &apos;%Windir%\Temp\Connector\WmsConnector.Exe&apos; -ArgumentList &apos;/Quiet /NoRestart&apos; -PassThru -Wait; } catch { throw &apos;WmsConnector Install Failed&apos;}; exit $p.ExitCode&quot;</Path>

    then save the file again as Unattend-t.xml  

    d) Proceed with Create and Customize virtual desktop template, and Create virtual desktop station as described on our blog at Virtual Desktop Templates – Part 1 & Part 2

    We continue to investigate why this issue occurs on some machines and not others

    Issue #2: UR1 was intended to fix an issue creating virtual desktop templates on true UEFI systems, i.e. systems that don’t fall back to legacy support for earlier BIOS services. UR1 did not solve the issue. For now we are recommending doing template creation on systems that do fall back to legacy BIOS services. To check: from Device Manager under Disk Drives select your system hard drive. Double click and go to the Volumes tab and click Populate. The Partition Style entry should be Master Boot Record (MBR).  If it is GPT you have a UEFI system.

    We continue to investigate fixing this for UEFI systems.


    Saturday, April 13, 2013 12:14 AM

All replies

  • Hi!

    We are using Atrust HW (Server and Zero Thin Clients m320) and had also problems creating Virtual Desktop Template on WMS 2012. The problem was, that creation stucked at 80% until timeout. We followed the above instructions and this solves our problem.

    The Virtual Desktop Template creation is now successful with Windows 7 Ent. and Windows 8 Ent.

    Thanks for the instructions and hope that MS will create final solution with some UR1 Update for UEFI and non-UEFI systems ASAP.

    With regards,

    Uros.


    UrosL


    • Edited by UrosL Monday, April 15, 2013 7:05 PM typo
    Monday, April 15, 2013 7:01 PM
  • Thanks for the validation! And yes, we continue to investigate simpler resolutions for both issues. We'll let everyone know.
    Monday, April 15, 2013 9:17 PM
  • Deleted
    Tuesday, June 11, 2013 4:59 PM
  • Is there a Fix for the UEFI problem?
    This is a one year old problem and stil no solution!

    When is the release date for the next MultiPoint Server?

    Tuesday, January 7, 2014 5:00 PM
  • I don't think that they have announced one but I heard a rumor that it'll be associated with the next version server

    thanks, Amy

    Monday, January 27, 2014 11:40 PM