none
LoadLibrary("wuaueng1.dll") failed - the specified module could not be found

    Question

  • Hi,

    I have a problem in updating Windows from our WSUS server. Maybe it is a problem on a client computer.

    I run this workaround on one computer and it was successful. This is what I did:

    Click Start, click Run, type cmd, and then click OK.
    At the command prompt, type regsvr32 wuapi.dll, and then press ENTER.
    At the command prompt, type regsvr32 wuaueng.dll, and then press ENTER.
    At the command prompt, type regsvr32 wuaueng1.dll, and then press ENTER.
    At the command prompt, type regsvr32 wucltui.dll, and then press ENTER.
    At the command prompt, type regsvr32 wups.dll, and then press ENTER.
    At the command prompt, type regsvr32 wups2.dll, and then press ENTER.
    At the command prompt, type regsvr32 wuweb.dll, and then press ENTER.

    It was successful.

    unfortunately, I did try it on another computer but I am encountering this problem,

    LoadLibrary("wuaueng1.dll") failed - the specified module could not be found

    Can anyone help me fix this problem?

    Thank you.

    Friday, April 16, 2010 8:34 AM

Answers

  • I would suggest downloading the WindowsUpdateAgent30-x86.exe (or WindowsUpdateAgent30-x64.exe for 64-bit systems), and running that command with the/wuforce command line switch.

     


    Lawrence Garvin, M.S., MCITP:EA, MCDBA, MCSA
    Principal/CTO, Onsite Technology Solutions, Houston, Texas
    Microsoft MVP - Software Distribution (2005-2010)
    My MVP Profile: http://mvp.support.microsoft.com/profile/Lawrence.Garvin
    My Blog: http://onsitechsolutions.spaces.live.com
    Friday, April 16, 2010 8:40 PM
    Moderator