none
Outlook 2010 and CRM 2011 intermittently unresponsive on RDS - Terminal Server

    Question

  • I am running Remote Desktop Services with Windows 2008 R2 with Office 2010 and CRM 2011, and GoToMeeting installed. Also, all Microsoft and Office updates are applied. Over the past month or so performance was affecting one user (that I know of). This week it is affecting several users and we have about 20 users total. Outlook is intermittently unresponsive and moves really slow. This has been working fine for at least one year.

    Any ideas?
    Thursday, January 19, 2012 3:59 PM

Answers

  • Hi, 

     

     

    6)Please increase the Virtual memory (Page file size) by going to this link http://www.windowsreference.com/windows-vista/change-the-size-of-virtual-memory-page-file-size-in-vista/ ,just follow the steps which is mentioned in this link in order to increase the Page file size.

     

    7)Add these same sites to an exception list for any anti-virus software you are using.  This can cause slow performance as the anti-virus software will scan the web site.

     

    And please refer the below link’s KB article as well  which should help you to resolve your issue.

     

    http://support.microsoft.com/kb/282402 

     

    Please try to perform the above steps and let me know whether it worked for you.

    Please perform the following steps and let me know if you find any difference in the performance issue:

     

    1. Go to Run %temp%  Select all the files and delete.

    2. Go to Internet Explorer Tools Internet Options General Tab  Delete Browsing History Select All the options.

    3. Go to Internet Explorer Tools Internet Options Browsing History Settings Increase the Disk Space to 250 MB.

    4. Go to Internet Explorer ToolsInternet OptionsSecurity  Trusted Sites  Sites  Add the following Websites [ *.crm.dynamics.com and *.live.com ] uncheck the option (Server verification required) Click on ok.

    5. Download CCleaner  from http://www.filehippo.com/download_ccleaner . Run the CCleaner.

    Steps to be performed with CCleaner:

    a. Click on Run Cleaner .

    b. Click on Registry. Please take a backup of registry  if poromted.

    Thanks. 

     

    Kevin Ni

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, January 31, 2012 11:58 AM

All replies

  • Hi,

     

    Make sure that Windows Terminal server and client PC's NIC driver has been correctly installed and has been upgraded to the latest version.

     

    Do you have install any antivirus software? Please try to disable the antivirus software to see if the same issue still exists.

     

    For this case, please using Performance Monitor to monitor the performance of the server status, to check whether the RAM or CPU loading is too high or not. Then you can find which process ID causing the problem.

     

    More information:

    Using Performance Monitor

    http://technet.microsoft.com/en-us/library/cc749115.aspx

     

    Performance Monitor Wizard

    http://www.microsoft.com/downloads/en/details.aspx?FamilyID=31fccd98-c3a1-4644-9622-faa046d69214

     

     

    Regards,

    Dollar Wang

    Forum Support

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

     


    Technology changes life……
    Saturday, January 21, 2012 1:35 AM
    Moderator
  • I'm having the same problem.  Outlook is installed on two load-balanced terminal servers.  The add-in does not like it.  Outlook can only sync with ONE machine and as the users login and logout and login again it's unpredicatable which machine the user will end up on.  I've noticed that there are TWO outlook .COM add-in's listed under File-->Options-->Add-ins.  If I disable the add-in's, outlook returns to its normal functioning self.  But if you turn them back on, outlook crawls.  All 25 users experience the same behavior. 

    Apparently load-balanced terminal servers with redirected AppData folders is not a supported configuration for CRM 4 or CRM 2011. 

    Not sure what to do....

    Monday, January 23, 2012 6:22 PM
  • Thanks Dollar. I had two users run Outlook in Safe Mode and they had no problem. On Monday I had them run Outlook with the GoToMeeting disabled and they Still had problems. Today they are running Outlook with the CRM add-ins disabled. Network, Disk and CPUs are high but the offending application is Outlook and GoToMeeting.

     

     

    Tuesday, January 24, 2012 9:32 PM
  •  

    I wouldn't recommend redirecting AppData folders.  These should be local to the terminal server for each user for performance sake and also if the user runs different sessions across terminal servers, you can have locking issues if the sessions are trying to write to the same redirected folder.

    Using the Citrix Profile Manager can also help with the folder redirection and improving logins/logout with what gets copied from redirected folders to the local terminal server.

    I would also suggest verifying which rollup your on.  Rollup 6 was just released.

    Wednesday, January 25, 2012 4:47 PM
  • Robert Stephan.  A TS Farm with redirected AppData folders is indeed supported with CRM 2011.  You need UR#4 to make it work.

    Wednesday, January 25, 2012 7:35 PM
  • Well now I have discovered that when one person disables the CRM add-in, it gets disabled for multiple users. Why would that be happening in a Terminal Server environment?
    Wednesday, January 25, 2012 9:12 PM
  • Am I going to get any assistance with this?
    Vincent McCaskill MCT, MCTS, MCSA
    Monday, January 30, 2012 3:46 PM
  • Please see my post below. Has anyone come across this? RDS is wokring fine, Outlook is slugginsh when CRM 2011 add-in is enabled. The setting to enable or disable the add-inaffects all users instead of each individual profile.


    Vincent McCaskill MCT, MCTS, MCSA
    Monday, January 30, 2012 3:49 PM
  • Hello,

                     

    Thank you for your question.

                     

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.

                     

    Thank you for your understanding and support.


    Technology changes life……
    Tuesday, January 31, 2012 8:48 AM
    Moderator
  • Hi, 

     

     

    6)Please increase the Virtual memory (Page file size) by going to this link http://www.windowsreference.com/windows-vista/change-the-size-of-virtual-memory-page-file-size-in-vista/ ,just follow the steps which is mentioned in this link in order to increase the Page file size.

     

    7)Add these same sites to an exception list for any anti-virus software you are using.  This can cause slow performance as the anti-virus software will scan the web site.

     

    And please refer the below link’s KB article as well  which should help you to resolve your issue.

     

    http://support.microsoft.com/kb/282402 

     

    Please try to perform the above steps and let me know whether it worked for you.

    Please perform the following steps and let me know if you find any difference in the performance issue:

     

    1. Go to Run %temp%  Select all the files and delete.

    2. Go to Internet Explorer Tools Internet Options General Tab  Delete Browsing History Select All the options.

    3. Go to Internet Explorer Tools Internet Options Browsing History Settings Increase the Disk Space to 250 MB.

    4. Go to Internet Explorer ToolsInternet OptionsSecurity  Trusted Sites  Sites  Add the following Websites [ *.crm.dynamics.com and *.live.com ] uncheck the option (Server verification required) Click on ok.

    5. Download CCleaner  from http://www.filehippo.com/download_ccleaner . Run the CCleaner.

    Steps to be performed with CCleaner:

    a. Click on Run Cleaner .

    b. Click on Registry. Please take a backup of registry  if poromted.

    Thanks. 

     

    Kevin Ni

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, January 31, 2012 11:58 AM
  • Hi Vincent,

    Looking forward to your feedback.


    Technology changes life……
    Friday, February 03, 2012 2:21 AM
    Moderator