none
PXE-E55: ProxyDHCP service did not reply to request on port 4011 (on Physical Machines)

    Question

  • Hi,

    Recently we have been facing issues when using our PXE service. We are getting PXE-E55: ProxyDHCP service did not reply to request on port 4011 when we try to pxe boot Physical machines. However, if we try the same with VM's, we can successfully deploy an OS using the PXE service. Our WDS server is not on the same server having the DHCP service. I'm really not sure what's causing the problem since we can make it wotk on vm's but not on physical machines. I don't know if it has something to do with our DHCP having 95% IP addresses being used.

    Help is much appreciated.

    Ron

    Thursday, February 16, 2012 3:02 AM

Answers

All replies

  • Hello,

    please see and follow http://support.microsoft.com/kb/259670/en-us


    Best regards

    Meinolf Weber
    MVP, MCP, MCTS
    Microsoft MVP - Directory Services
    My Blog: http://msmvps.com/blogs/mweber/

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Thursday, February 16, 2012 11:29 AM
  • Check that you enable option 60 on dhcp server.

    WDSUTIL /Delete-AutoAddDevices /DeviceType:ApprovedDevices

    For WDS queries, post here.

    http://social.technet.microsoft.com/Forums/en-US/winserversetup/threads

     

    Thanks

    Thursday, February 16, 2012 12:15 PM
  • Hi Ron,

    Please try to set the network boot referral and see whether it works. In order to do this, please configure the following DHCP options in DHCP scope. It will direct PXE clients to an appropriate NBP.

    Option 60= PXEClient
    Option 66= WDS server name or IP address
    Option 67= Boot file name

    For detailed information about configure network boot grogram, please refer to the following article:

    Managing Network Boot Programs
    http://technet.microsoft.com/en-us/library/cc732351(WS.10).aspx#BKMK3

    In addition, also check the same question answered at the following thread. Hope it helps.

    WDS - PXE No reply from DHCP port 4011
    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/852e57f3-50b4-48ae-a7a9-6e706afd3bbe


    Best Regards,
    Aiden


    Aiden Cao

    TechNet Community Support

    Friday, February 17, 2012 5:20 AM
    Moderator
  • Hi,

    Our WDS runs on a different server so i think option #60 is applicable only if both roles (DHCP WDS) are on the same server.

    I also tried WDSUTIL /Delete-AutoAddDevices /DeviceType:ApprovedDevices but we don't require administrator approval for unknown devices.

    Thanks.

    ron


    Monday, February 20, 2012 5:04 AM
  • Hi Aiden,

    How do I set option 67?

    thanks.

    ron


    Monday, February 20, 2012 5:09 AM
  • Ron,

    In addtional to the steps suggested by Aiden, please refer to the article : PXE-E55

    The "PXE-E55" error indicates that the PXE client has sent a request to the proxyDHCP server on port 4011, but did not receive a reply. This problem can only occur when the DHCP Class Identifier Option #60 is set on the DHCP server, but there is no proxyDHCP service running on port 4011 on the same machine.

    option 67 :

    http://social.technet.microsoft.com/Forums/en-US/configmgrosd/thread/d11e0aab-27e4-4bf5-9897-8f0745f7aeed/

    http://www.windows-noob.com/forums/index.php?/topic/546-how-can-i-troubleshoot-windows-pe-booting-in-sccm/page__p__1354#entry1354


    Gopi Kiran |Facebook| This posting is provided AS IS with no warranties,and confers no rights.


    Monday, February 20, 2012 7:27 AM
  • I know this is an old and answered thread, but i thought i'd add my situation to the list of things to check for other googlers stumbling upon this!

    Presuming you are running WDS on your DHCP server and it has historically been working, but isnt today.. Launch "Windows Deployment Services" on the server open your "Servers" container and check that the Server name has a green "play" symbol and not a black "stop". I periodically get service failures on a reboot for WDS. When i say periodically, i mean like 3 times in 5 years.. but i never associate a DHCP error message with WDS until about 30 minutes of googling!

    Matt

    • Proposed as answer by England_Dan Monday, March 27, 2017 4:24 PM
    Monday, November 05, 2012 1:54 PM
  • I fixed an error when uninstall WDS, delete the folder c:\ RemoteInstall and then I install WDS. And now, never do not select the option "For unknown clients notify administrator and respond after approval".

    Alv.

    Friday, November 16, 2012 6:43 AM
  • I fixed an error when uninstall WDS, delete the folder c:\ RemoteInstall and then I install WDS. And now, never do not select the option "For unknown clients notify administrator and respond after approval".

    Alv.

    "never do not select"...

    This is a double negative nightmare of a solution.  Can you elaborate what you mean by this?

    /BG


    -BrianG (http://supportishere.com)

    Monday, April 01, 2013 4:50 PM
  • Just to add a bit more information for those who get here via Google.

    We have separate servers that only run DHCP and others that only run WDS\MDT on our campus and we have seen this problem as well.

    The workaround is just to restart the WDS service from 'Windows Deployment Services' console.

    I am looking for a more permanent fix but for now this does the trick.

    Dave

    Wednesday, April 10, 2013 7:46 AM
  • Ur guide helps, thank you so much :)
    Thursday, August 01, 2013 11:46 AM
  • Just an FYI as I didn't find anything like this in my troubleshooting of this issue.

    I was having this same problem but only on 3 machines when others would PXE boot just fine (thus ruling out any possible server side configuration issues).

    In our case there was a DHCP Reservation that was marked as "BAD ADDRESS".  The msg on the DHCP server said it tried to assign it but was already in use.  Once we deleted the reservation I was able to PXE boot the machine and image without any issues.

    Monday, August 12, 2013 2:38 PM
  • I just wanted to mention that I started getting the "ProxyDHCP service did not reply to request on port 4011" message from a Lenovo ThinkPad T430 against a Windows Server 2012 R2 + ConfigMgr 2012 SP1 CU3 infrastructure. I was able to resolve the issue by removing DHCP option 60 on the client's DHCP service, which just so happened to be Microsoft Windows DHCP Server.

    If this post was helpful, please click the little "Vote as Helpful" button :)

    Trevor Sullivan
    Trevor Sullivan's Tech Room
    Twitter Profile

    Monday, October 28, 2013 6:37 PM
  • I know this is a pretty old thread, but I recently came across this issue.

    Infrastructure: Physical Client machines, iPXE, WDS, DHCP, ISCSI (DHCP and WDS are on separate servers). Scope option 67 is enabled on the VLAN.

    When trying iPXE boot a computer to an iSCSI target I recieved the same error as you.  To resolve this issue i did the following:

    1. Boot to MBA Configuration
    2. Changed the boot protocol to Boot Strap Protocol (BootP)
    3. Saved changes and rebooted
    4. Let the TFTP fail
    5. Boot back to the MBA Configuration
    6. Changed back to PXE
    7. Saved changes and rebooted.
    8. Successful boot to iSCSI target.

    This ony works in a situations like Ronevangregorio's where only select clients are having the issue and it is not implementation wide.

    Hope this helps someone...

    John Carver

    Friday, August 08, 2014 1:55 AM
  • We have been working with this issue for a while with no luck until now. Our DHCP server and WDS Server are not in the same server. Options 60, 66 and 67 are not configured on the DHCP server. We noticed that in a group of workstations some times one of them shows the PXE-E55 error and the rest continues with the OS deployment process with no problems. The last action taken was to look the IP Address assigned by the DHCP on the Address Leases, and delete it, reboot the pc and as soon as it get another IP Address it continues the process as it should.

    Monday, September 29, 2014 7:07 PM
  • I have just had this issue and resolved it. I had all DHCP options 60,66 and 67 configured. DHCP had been running on the same server during tests but the scope was deactivated. After patching the server and rebooting I noticed this PXE-55 proxyDHCP error. The proxyDHCP relays to option 66 (boot Server) on your DHCP config which is my deployment server. So it had to be a service or firewall that would be stopping it. Looking through my services I found the Windows Deployment Service hadn't started. After starting the service my deployment server was back in the game. Found a system event log entry of why the service didn't start at boot, which was due to DHCP services running on the same server using port 67.

    As I wasn't using DHCP on this server, I just removed the role to stop it from happening again in the future.

    Hope this helps you.

    Ollie


    • Edited by Ollie_Hughes Wednesday, January 14, 2015 1:54 PM
    Wednesday, January 14, 2015 1:30 PM
  • Hi, all.  After struggling with this one it turned out to be a simple dhcp error for us.  The WDS server had an ip in the dhcp range, and the client machine was getting that same ip from the dhcp server and obviously that didn't work too well.  It worked normally after deleting the lease and reserving the ip.  Thanks everyone for your helpful posts!

    -Steve M

    Thursday, May 28, 2015 2:07 PM
  • Hi Ron,

    WDS - PXE No reply from DHCP port 4011

    Please refer to the following article. Hope it helps.

    https://technet.microsoft.com/en-us/library/ee941126(v=ws.10).aspx

    Best Regards,
    Imran Saifi Lohar

    Saturday, September 05, 2015 4:15 AM
  • May be the DHCP server setting you changed

    restart your system.

    Monday, September 14, 2015 3:56 AM
  • Matt, you're the man. Your post was right on in my situation. Not sure if you get points added automatically, but if there was a button for me to click, you'd get 100 points. Thanks!

    Dan

    Monday, March 27, 2017 4:31 PM
  • Some clients are squirrely and I tried some things to account for them, including adding these options on the DHCP server. AS Trevor describes, removing these options from the DHCP scope fixed the problem.

    So even though early on there is one with a check box marked as the solution, it is the opposite of the solution if you are not running WDS and DHCP on the same server.  Undoing that is actually the solution.

    Thursday, April 27, 2017 7:52 PM
  • Hi, everybody! I came from Google as well.

    My situation is kinda weird. I had a DHCP and WDS on different servers. Also I had 2 those brand new Lenovo S510 desktops. Both boots from PXE allright and install the .wims

    Since them both are identical I decided to install all the drivers and updates on first one, do a sysprep, capture the image and then deploy it on the second one to save the time and traffic.

    What can go wrong? :)

    Well, since I'm here, obviously I got a problem. The first Lenovo after I did the sysprep won't boot to PXE anymore. I'm getting the bloody PXE-E55 error.

    Note, that yesterday this desktop booted to PXE. And the second one boots today. But I need the first one to capture the image!

    I even tried to start the DHCP service on the same server as WDS, but got no effect.

    Please, advise something. :) I'm close to replugging the HDD to the second PC to capture the image from there, but I'm truly afraid it might stop booting to the PXE as well after that. :)

    Wednesday, September 20, 2017 12:14 PM