locked
FreeBSD 10 on Hyper-V RRS feed

  • Question

  • Hi,

    I have installed (default installation) FreeBSD 10.0, 10.1, 10.2 and now 11.0 beta in a Windows 2012 R2 Hyper-V.

    The FreeBSD virtual machines at the end of installation are showing me that they acquired DHCP IPv4 IP address but after restart I don’t have Internet access in the virtual machine….and the network cards in the ifconfig screen appear UP.

    I tried with Legacy and synthetic adapter but the situation is the same….I don’t have internet access and I cannot update the VM from the FreeBSD mirrors.

    I have on the same Hyper-V host more than 15 Linux VM (Suse, openSuse, Redhat,centOS, Oracle Linux, Debian and Ubuntu) and all of them are connected to the internet with synthetic adapters and they acquired dhcp IP address from the same  network.

    Is there anything else that I need to configure?

    Thank you,

    Ovidiu

    Friday, August 7, 2015 8:30 PM

All replies

  • SOLVED ..after modifying /etc/rc.conf with SYNCDHCP instead of DHCP on the network card properties
    • Proposed as answer by The_D0lph1n Wednesday, January 13, 2016 3:22 AM
    Friday, August 7, 2015 9:45 PM