none
Installing RemoteFX on Hyper-V Server SP1 RC - instruction say to add

    Question

  • Hello

    I have a Hyper-V Server with SP1 RC.   We have a video card that is nVidia Quadro 3800 (supported).  Server cores are Xeon 5650s (Nehamel, SLAT EPT supported).

    We then follow the steps here - http://technet.microsoft.com/en-us/library/ff830365.aspx

    To install RemoteFX by using Server Manager

    1. Open Server Manager. To open Server Manager, click Start, point to Administrative Tools, and then click Server Manager.

    2. Expand Roles, and then click Remote Desktop Services.

    3. Under Role Services, click Add Role Services.

    4. Select the Remote Desktop Virtualization Host check box, and then select the RemoteFX check box.

    But don't see how to do this.  We can connect remotely to the Hyper-V server using the remote admin tools, but don't see an option to add Remote Desktop Services to the Hyper-V Server.  Do I need to do this or can we skip it?

     

    I am pretty sure Hyper-V Server is supported - http://technet.microsoft.com/en-us/library/ff817578(WS.10).aspx

    Which editions include RemoteFX?

    RemoteFX is available in the following editions of Windows Server 2008 R2 with SP1:

    • Windows Server 2008 R2 Standard with SP1
    • Windows Server 2008 R2 Enterprise with SP1
    • Windows Server 2008 R2 Datacenter with SP1
    • Microsoft Hyper-V Server 2008 R2 with the Windows Server 2008 R2 SP1 update applied

    RemoteFX is not available in the following editions of Windows Server 2008 R2 with SP1:

    • Windows Web Server 2008 R2 with SP1
    • Windows Server 2008 R2 for Itanium-Based Systems with SP1
    Thursday, November 11, 2010 5:18 PM

Answers

  • I think you need to enable Remote Desktop Services first, before the GUI will show you Remote Desktop Virtualization Host.  You might get around that using powershell.  Open a powershell prompt and run:

    PS C:\> Import-Module ServerManager
    PS C:\> Get-WindowsFeature ("RDS-Virtualization", "Remote-Desktop-Services")
    
    Display Name                      Name
    ------------                      ----
    [ ] Remote Desktop Services               Remote-Desktop-Services
      [ ] Remote Desktop Virtualization Host       RDS-Virtualization
    

    You should be able to enable it by running:

    PS C:\> Add-WindowsFeature RDS-Virtualization
    PS C:\> Get-WindowsFeature ("RDS-Virtualization", "Remote-Desktop-Services")
    
    Display Name                      Name
    ------------                      ----
    [X] Remote Desktop Services               Remote-Desktop-Services
      [X] Remote Desktop Virtualization Host       RDS-Virtualization
    

    This should enable Remote-Desktop-Services as well, since it is a dependency.

    • Marked as answer by jim calhoun Friday, November 12, 2010 7:37 PM
    Friday, November 12, 2010 5:48 AM

All replies

  • I think you need to enable Remote Desktop Services first, before the GUI will show you Remote Desktop Virtualization Host.  You might get around that using powershell.  Open a powershell prompt and run:

    PS C:\> Import-Module ServerManager
    PS C:\> Get-WindowsFeature ("RDS-Virtualization", "Remote-Desktop-Services")
    
    Display Name                      Name
    ------------                      ----
    [ ] Remote Desktop Services               Remote-Desktop-Services
      [ ] Remote Desktop Virtualization Host       RDS-Virtualization
    

    You should be able to enable it by running:

    PS C:\> Add-WindowsFeature RDS-Virtualization
    PS C:\> Get-WindowsFeature ("RDS-Virtualization", "Remote-Desktop-Services")
    
    Display Name                      Name
    ------------                      ----
    [X] Remote Desktop Services               Remote-Desktop-Services
      [X] Remote Desktop Virtualization Host       RDS-Virtualization
    

    This should enable Remote-Desktop-Services as well, since it is a dependency.

    • Marked as answer by jim calhoun Friday, November 12, 2010 7:37 PM
    Friday, November 12, 2010 5:48 AM
  • thank you , that worked
    Friday, November 12, 2010 7:37 PM
  • Anyone try this procedure to try an enable RemoteFX on a HyperV server that doesn't have SLAT processor on the base host, just to see RemoteFX work, albeit slow?

    Thanks.

    Saturday, March 19, 2011 9:33 PM
  • I followed the above instructions and it worked - mostly.

    When I executed the command

    [X] Remote Desktop Services        Remote-Desktop-Services
    
     [X] Remote Desktop Virtualization Host    RDS-Virtualization
      [ ] Remote Desktop 			     RDS-RemoteFX
     

     

    Monday, April 25, 2011 8:31 PM
  • I followed the above instructions and it worked - mostly.

    When I executed the command

     

    [X] Remote Desktop Services    Remote-Desktop-Services
    
     [X] Remote Desktop Virtualization Host  RDS-Virtualization
     [ ] Remote Desktop 			   RDS-RemoteFX
     

     

     

    Hi Russel,

    A bit late with this reply as just come across this issue myself, at least it might help others who experience this.

    I basically worked this out myself as (as with a few M/S products lately) documentation is very hard to find (non-existent?).

    PS C:\> Add-WindowsFeature RDS-RemoteFX

    A restart of the server and it's there.

    Wednesday, June 22, 2011 8:51 AM