none
WORKAROUND: Pasting text to Hyper-V guests sometimes results in garbled characters RRS feed

  • General discussion

  • Symptoms

     

    When using a Hyper-V Virtual Machine Connection console to a running virtual machine on Windows Server "8" Beta Hyper-V and then using the Type Clipboard Text menu option, the characters pasted may appear out of order or garbled. This makes copying and pasting longer Windows PowerShell commands difficult, for example.

     

    Cause

     

    Known issue in Windows Server "8" Beta.

     

    Resolution

     

    To work around this issue:

     
    • Use the RDP client (mstsc.exe) to connect directly to virtual machines.
    • Increase the keyboard class buffer size in the virtual machine
    • Disable the synthetic keyboard in the virtual machine to force using the emulated keyboard
       

    To Increase the keyboard class buffer size in the virtual machine

     
    1. Logon to a running virtual machine as a member of the Administrators group. 
    2. Open the Start page, type regedit.exe, and then hit ENTER. 
    3. Locate and then click the following registry entry:
       

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\kbdclass\Parameters
       
       
    4. In the details page, double click:
       

      KeyboardDataQueueSize
       

    5. Select Decimal and type a value data of:
       

      1024 
       

    6. Click OK. Close the Registry Editor and restart the virtual machine.
       

    To disable the synthetic keyboard for a virtual machine

     
    1. Logon to a running virtual machine as a member of the Administrators group.
    2. Open the Start page, type devmgmt.msc, and then hit ENTER.
    3. Click on Keyboards.
    4. Right click on Microsoft Hyper-V Virtual Keyboard.
    5. Click Disable.
    6. Close the Device Manager snap-in.
     

    Note
    On Windows Server "8" Beta Core, download DevCon.exe from the Windows Driver Kit to disable this driver using the
    command-line.


    Ned Pyle [MSFT] | Support Escalation Engineer | Windows Distributed Systems | Charlotte, NC USA

    Monday, May 7, 2012 8:54 PM

All replies

  • not Windows Server 8 only, I also had this issue with Windows Server 2008 R2. However, I found that I can open a notepad within the virtual machine first, seems paste the content in notepad can resolve this issue.
    Tuesday, May 8, 2012 2:46 AM
  • This is a Windows Server "8" beta specific regression; in previous OSes there should be no garbling and if you exceed the buffer you receive a graceful error message telling you to send less text. If that problem can be reproduced in older OS I want to know about it and have you give me specific steps I can use to reliably reproduce the issue on Win2008 R2.

     

    In other words, please show me the money :)

      


    Ned Pyle [MSFT] | Support Escalation Engineer | Windows Distributed Systems | Charlotte, NC USA

    Wednesday, May 9, 2012 10:36 PM
  • Would be interesting if Royal TS (http://www.code4ward.net) has the same issue. Royal TS isn't using the virtual KVM switch to send keyboard text, instead it simulates keyboard input as if you are typing on your computer.

    Stefan Koell | http://www.code4ward.net

    Tuesday, May 22, 2012 6:25 AM
  • I don't know if the following issue has the same cause, but on Hyper-V Server 2008 R2, when I use "Type clipboard text" on a VM connection, the "." is always lost and I have to paste clipboard in notepad within the VM, fix the text and copy/paste again on PowerShell or CMD.

    As far as I know, only the period is lost.

    Tuesday, May 22, 2012 9:56 PM