locked
sconfig Network Settings RRS feed

  • Question

  • Hyper-V 2012 Core install.  Single NIC plugged in and shows as up when get-netadapter is run.  Shows as ifIndex 15. However, when I run sconfig, ifIndex shows 13, and when I choose that index, I get the following error:

    C:\Windows\system32\en-US\sconfig.vbs (696, 21) SWbemObjectEx: Invalid index

    I have tried to set the IP via Powershell, however, I am unable to manage, ping, or rdp into the server (this was all enabled). When I run sconfig again after setting IP through PS, still shows Index 13, but with the IP I have set.

    Any thoughts?

    Thank you

    Tuesday, February 5, 2013 6:24 PM

Answers

  • If you have one NIC and you added an External Virtual Switch you have two NICs.  One physical and one virtual.  Each should have its own index.

    the virtual in this case is the management OS NIC - the one you need to set the IP of.

    Now - did you install Hyper-V Server, or Windows Server with Hyper-V as a Core installation?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    • Marked as answer by Lawrence, Monday, February 18, 2013 6:38 AM
    Tuesday, February 5, 2013 7:02 PM
  • Hi,

    The Hyper-V host server and the client computer, which you used for remote management, are they in same domain?

    If they are in same domain, there is not some special configuration for Hyper-V remote manage. If they are in different domain or in workgroup, you may refer to following articles to configure that:

    Guide to remote manage Hyper-V servers and VM's in workgroups or standalone
    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/fe80f0aa-0697-4657-a1da-19d36b036698
    Configure Hyper-V Server 2012 for Remote Management<//span>

    http://technet.microsoft.com/en-us/library/jj647788.aspx

    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    • Marked as answer by Lawrence, Monday, February 18, 2013 6:38 AM
    Monday, February 11, 2013 8:14 AM

All replies

  • If you have one NIC and you added an External Virtual Switch you have two NICs.  One physical and one virtual.  Each should have its own index.

    the virtual in this case is the management OS NIC - the one you need to set the IP of.

    Now - did you install Hyper-V Server, or Windows Server with Hyper-V as a Core installation?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    • Marked as answer by Lawrence, Monday, February 18, 2013 6:38 AM
    Tuesday, February 5, 2013 7:02 PM
  • Yes, that I understand. I am just trying to set the management IP of the OS...which is the HyperV 2012 Core. 
    Tuesday, February 5, 2013 9:31 PM
  • If you open powershell and type Get-NetAdapter

    You should see them all.

    Usually the numbers in the teens are physical NICs and any in the 20's are where the 'virtual' ones reside (in the management OS).


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, February 5, 2013 9:51 PM
  • tried to put some screen shots, but not allowed...running get-netadapter shows that I have one physical nic configured with the ifinterface of 14, and get-netipaddress for that interface shows IP of 172.22.100.8.

    While in scconfig utility the configured network adapter with, show index of 12, with the IP address of 172.22.100.8.

    When I try to select 12, I get the error sconfig.vbs(696, 21) SWbemObjectEx: invalid index

    Tuesday, February 5, 2013 10:03 PM
  • sounds like an orphaned NIC configuration.

    Did the NIC or NIC driver change?

    Either way, I believe it is Add-NetIPConfiguration  (there isn't a set-netipconfiguration) in powershell


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Tuesday, February 5, 2013 10:18 PM
  • no changes to NIC or driver.  I'm able to, utilizing Corefig utility to set an IP address to the adapter and RDP into the server, however, still cannot connect via HyperV manager and Index still shows different in sconfig vs get information.  I don't see a Add-NetIPconfiguration option for powershell..is there a way to change the ifindex# of an adapter?
    Wednesday, February 6, 2013 2:27 PM
  • No, you canny change the ifindex, it trickles up from the hardware.

    tell us more about your "cannot connect" symptom?

    have you enabeled remote management, set the winrm trusted hosts settings,

    etc?


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, February 6, 2013 3:04 PM
  • yes, all have been set.  Right now I am able to connect to the Host via RDP, just not through the Hyper-V Manager.  
    Wednesday, February 6, 2013 3:19 PM
  • Nothing happens?  Errors?

    Are you using a computer name?  (IP generally does not work in the MSFT world).

    Tell us more about the root issue.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.
    Disclaimer: Attempting change is of your own free will.

    Wednesday, February 6, 2013 4:59 PM
  • Hi,

    The Hyper-V host server and the client computer, which you used for remote management, are they in same domain?

    If they are in same domain, there is not some special configuration for Hyper-V remote manage. If they are in different domain or in workgroup, you may refer to following articles to configure that:

    Guide to remote manage Hyper-V servers and VM's in workgroups or standalone
    http://social.technet.microsoft.com/Forums/en-US/winserverhyperv/thread/fe80f0aa-0697-4657-a1da-19d36b036698
    Configure Hyper-V Server 2012 for Remote Management<//span>

    http://technet.microsoft.com/en-us/library/jj647788.aspx

    Hope this helps!

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Lawrence

    TechNet Community Support

    • Marked as answer by Lawrence, Monday, February 18, 2013 6:38 AM
    Monday, February 11, 2013 8:14 AM
  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as 'Answered' as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we'd love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!


    Lawrence

    TechNet Community Support

    Monday, February 18, 2013 6:38 AM
  • Just to add something about your issue:

    I had exactly the same error and managed to solve it by enabling IPv6 (I disabed previously IPv6 on my Hyper-V 2012 Server). Once enabled, no more Sconfig issue.

    Hope it can help anyone who will read this post...


    • Edited by Samir Hammoudi Thursday, April 11, 2013 7:22 AM
    • Proposed as answer by Syntrex Tuesday, May 21, 2013 8:35 AM
    Wednesday, April 10, 2013 10:47 AM
  • This is a known issue when IPV6 is disabled.  You first need IPV6 enabled when configuring an IP address using SCONFIG.   Once the IP Address is assigned, you can disable IPV6 afterwords.

    • Proposed as answer by Patrick M Friday, May 13, 2016 3:36 AM
    Tuesday, October 29, 2013 7:43 PM
  • This is the correct answer!

    I'm doing lab on Hyper-V Server 2012 R2 core install, and encounter the same error as OP.

    C:\Windows\system32\en-US\sconfig.vbs (696, 21) SWbemObjectEx: Invalid index

    Enabling IPV6 resolves the error, and while I'm done with IP configuration I can disable it back.


    ---Pat

    Friday, May 13, 2016 3:38 AM