locked
Lync 2013 Client Auto Start Registry Key RRS feed

  • Question

  • Hi

    i am trying to make that  the Lync 2013 will automatically start on all the users machines that under my domain once they log in to the computer

    i understand that there is options to do it by configure registry GPO

    can someone please explain me which setting i should put and where to make it works.

    i attach screen shots. (Please note, most of the users using win7 64 bit version and some of them using 32 bit version)

    I will really appreciate your help.

    El.

    Wednesday, May 28, 2014 12:16 PM

Answers

  • You can set the Run these programs at user logon:

    Computer Configuration->Administrative Templates->System->Logon and then in the right-pane, double-click Run these programs at user logon.

    • Click Enabled, and then click Show.
    • Click Add, type the name of the executable program (.exe) file that you want, and then click OK. You must specify the path to the file unless it is located in the %Systemroot% folder.
    • Link that GPO to OU with computers.

    The items that you added to the Items to run at logon list start automatically the next time that you log on to Windows on your computer. A list of these items is located in the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\Run

    http://support.microsoft.com/kb/314488

    In addition, you can set those registry values with GPP (like the picture you added) and link it to users OU.


    Please take a moment to Vote as Helpful and/or Mark as Answer where applicable. Thanks.



    • Edited by Idan Vexler Wednesday, May 28, 2014 12:50 PM
    • Marked as answer by Eliran Net Tuesday, June 10, 2014 2:57 PM
    Wednesday, May 28, 2014 12:47 PM
  • Hi Eliran,

    It’s weird that it still doesn’t work after trying these solutions. Maybe we can refer to the following thread to set the Registry key.

    Lync 2013 - Auto Run on start up – GPO

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/9450d3b6-7f2e-4029-9538-222c87019c06/lync-2013-auto-run-on-start-up-gpo?forum=winserverGP

    Note, as Martin suggested, if we refer to the above solution, don’t add HKCU to the key path. Besides, it’s suggested that we backup the registry in case that things go wrong.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,
    Frank Shen


    • Edited by Frank Shen5 Friday, May 30, 2014 3:17 AM
    • Marked as answer by Frank Shen5 Tuesday, June 10, 2014 2:45 AM
    Friday, May 30, 2014 3:11 AM
  • > btw- i tried to put on the value data both options:
     
    OMG, shed some light on this poor soul....
     
    Swap the values of "key path" and "value data", please.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by Frank Shen5 Tuesday, June 10, 2014 2:45 AM
    Friday, May 30, 2014 9:22 AM

All replies

  • I'd create a new group policy for this, or add it to an existing Office group policy applied to your users.

    Create a Reg_SZ key called Lync in HKCU\Software\Microsoft\Windows\CurrentVersion\Run with the value "C:\Program Files\Microsoft Office 15\root\office15\lync.exe" /fromrunkey"

    That's pretty much it.

    Check out Richard's write-up on this:

    http://blogs.technet.com/b/rischwen/archive/2013/06/20/lync-2013-client-auto-start-registry-key.aspx


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications


    Wednesday, May 28, 2014 12:36 PM
  • You can set the Run these programs at user logon:

    Computer Configuration->Administrative Templates->System->Logon and then in the right-pane, double-click Run these programs at user logon.

    • Click Enabled, and then click Show.
    • Click Add, type the name of the executable program (.exe) file that you want, and then click OK. You must specify the path to the file unless it is located in the %Systemroot% folder.
    • Link that GPO to OU with computers.

    The items that you added to the Items to run at logon list start automatically the next time that you log on to Windows on your computer. A list of these items is located in the following registry key:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer\Run

    http://support.microsoft.com/kb/314488

    In addition, you can set those registry values with GPP (like the picture you added) and link it to users OU.


    Please take a moment to Vote as Helpful and/or Mark as Answer where applicable. Thanks.



    • Edited by Idan Vexler Wednesday, May 28, 2014 12:50 PM
    • Marked as answer by Eliran Net Tuesday, June 10, 2014 2:57 PM
    Wednesday, May 28, 2014 12:47 PM
  • Hi Again

    Ok, i choose to go with the option of add Registery GPO, i did all the setting and now i am able to view the key that i add on the test machine, the only issue is that The Lync does not open automatically as I want

    you can find attach screenshot of the Key on the local machine and the GPO

    Local Machine:

    GPO Configuration:

    

    Hive: HKEY_CURRENT_USER

    Key Path: "C:\Program Files (x86)\Microsoft Office\Office15\lync.exe" /fromrunkey

    Value Name: Lync

    Value Type: REG_SZ

    Value Data: HKCU\Software\Microsoft\Windows\CurrentVersion\Run

    Wednesday, May 28, 2014 1:46 PM
  • Delete that key on a machine that's not working but keep Regedit open.  On the same machine, go to Tools->Options->Personal and check and uncheck the "Automatically start Lync when I log on to Windows" box to see what registry key it populates in there.  If it's different, go ahead and add that one to your GPO too.

    Also see this comment from Richard's blog:

    "FYI if you have a 32 bit client on 64 bit OS you'll have a different run key location
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run"


    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications


    Wednesday, May 28, 2014 2:01 PM
  • My OS is 64 bit and the Office is 32 bit so i take your advice and change the key location to 

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

    i check and unchecked the option on the Lync option and i copy the registry key and put it on the GPO

    but still it's not working.

    Wednesday, May 28, 2014 2:29 PM
  • Can you see the key being created and removed when you're checking the box?  Does it autostart properly when you check the box and not worry about the GPO?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Wednesday, May 28, 2014 2:31 PM
  • Once i check i can see the the key is created and when i unchecked i can see that the key is removed

    if i check the box  on the lync to auto start when windows logon it's working great. 

    Wednesday, May 28, 2014 2:52 PM
  • Then you're really just replicating that method with a GPO. That's odd that it won't work. Can you confirm on another machine?

    Please remember, if you see a post that helped you please click "Vote As Helpful" and if it answered your question please click "Mark As Answer". SWC Unified Communications

    Wednesday, May 28, 2014 3:01 PM
  • > Hive: HKEY_CURRENT_USER
    > Value Data: HKCU\Software\Microsoft\Windows\CurrentVersion\Run
     
    Remove "HKCU" from "Value  Data" - the "Hive" is sufficient...
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    Thursday, May 29, 2014 10:35 AM
  • Ok, i try all of your suggestions but stil it's not working.

    you can see the final configuration at the screen shot that i attach.

    btw- i tried to put on the value data both options: 

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run

    and

    HKCU\Software\Microsoft\Windows\CurrentVersion\Run

    Nothing works for me.

    Thursday, May 29, 2014 11:32 AM
  • Hi Eliran,

    It’s weird that it still doesn’t work after trying these solutions. Maybe we can refer to the following thread to set the Registry key.

    Lync 2013 - Auto Run on start up – GPO

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/9450d3b6-7f2e-4029-9538-222c87019c06/lync-2013-auto-run-on-start-up-gpo?forum=winserverGP

    Note, as Martin suggested, if we refer to the above solution, don’t add HKCU to the key path. Besides, it’s suggested that we backup the registry in case that things go wrong.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,
    Frank Shen


    • Edited by Frank Shen5 Friday, May 30, 2014 3:17 AM
    • Marked as answer by Frank Shen5 Tuesday, June 10, 2014 2:45 AM
    Friday, May 30, 2014 3:11 AM
  • > btw- i tried to put on the value data both options:
     
    OMG, shed some light on this poor soul....
     
    Swap the values of "key path" and "value data", please.
     

    Martin

    Mal ein GUTES Buch über GPOs lesen?

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))
    • Marked as answer by Frank Shen5 Tuesday, June 10, 2014 2:45 AM
    Friday, May 30, 2014 9:22 AM
  • Hi Eliran,

    How is the issue going? If the issue persists, please don't hesitate to let us know.

    TechNet Subscriber Support
    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Best regards,

    Frank Shen

    Tuesday, June 3, 2014 10:24 AM
  • 10x.

    the only solution that solved my issue was yours.

    thanks.

    Tuesday, June 10, 2014 3:04 PM
  • Most welcome,

    Glad it helped you.


    Please take a moment to Vote as Helpful and/or Mark as Answer where applicable. Thanks.

    Tuesday, June 10, 2014 3:45 PM