none
Windows Server 2016 Essentials overwriting DNS servers

    Question

  • I have Windows Server 2016 Essentials installed on my HP MediaSmartServer EX487.

    My client computers (just 4) run Windows 10 Professional with static IP addresses so I can access them when I’m away from home.

    When I start WS 2016E I realize that the DNS Server on the client computers (Windows 10 Pro) is overwritten from the one from my Internet provider to point to my WS 2016E Server IP address (right now 192..etc…etc.. 149).

    When I go to the adapter settings for “Internet Protocol Version 4 (TCP/IPv4)”, the static IP address is there but the “Preferred DNS server” is changed to point to the IP on 192…..149 that as I said is my HP EX487 IP (the "Alternate DNS Server" is also removed from my Internet Provider and is now blank).

    When I turn off the server, of course I lose the internet access on all my clients as they now have a new DNS server value which is not a valid DNS server (I don’t run the server 24h as I use it just for weekly backups so I turn it off).

    I’m connecting my clients to Windows Server Essentials without joining a domain by using the following change to my registry of the server:

     “HKLM\SOFTWARE\Microsoft\Windows Server\ClientDeployment” /v SkipDomainJoin /t REG_DWORD /d 1

    (I got this from this article: http://www.wegotserved.com/2016/09/30/connecting-client-pcs-to-windows-server-essentials-2016/3/ )

    I didn’t want to join a domain, my server is just a backup server and I prefer to work on each workstation locally.

    Does someone know what is causing this problem? How can I prevent the HP EX487 server with WS2016E to overwrite the DNS servers in the client computers?

    Thanks for any help!

    Saturday, November 19, 2016 2:30 AM

Answers

  • Thanks for the reply, but I didn't find Windows Server LAN Config on the clients.

    I googled a bit more and I found the solution for the problem here:

    https://support.microsoft.com/en-us/kb/2862551

    From the article above:

    To skip the automatic DNS detection on a client that is managed by Windows Server Essentials, run the following command on the client computer from an elevated command prompt:

    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ServerDiscovery" /v SkipAutoDNSServerDetection /t REG_SZ /d true

    You can also change the behavior of all clients that are managed by a Windows Server Essentials server. To do this, run the following command on the Windows Server Essentials server from an elevated command prompt:

    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ClientDns" /v SkipAutoDnsConfig /t REG_DWORD /d 1

    Life is good!

    • Marked as answer by dsimoes1 Saturday, November 19, 2016 6:08 PM
    Saturday, November 19, 2016 6:08 PM

All replies

  • On client machines disable Windows Server LAN Config service that is installed by WSE.

    Job done!

    Saturday, November 19, 2016 10:55 AM
  • Thanks for the reply, but I didn't find Windows Server LAN Config on the clients.

    I googled a bit more and I found the solution for the problem here:

    https://support.microsoft.com/en-us/kb/2862551

    From the article above:

    To skip the automatic DNS detection on a client that is managed by Windows Server Essentials, run the following command on the client computer from an elevated command prompt:

    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ServerDiscovery" /v SkipAutoDNSServerDetection /t REG_SZ /d true

    You can also change the behavior of all clients that are managed by a Windows Server Essentials server. To do this, run the following command on the Windows Server Essentials server from an elevated command prompt:

    reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Server\Networking\ClientDns" /v SkipAutoDnsConfig /t REG_DWORD /d 1

    Life is good!

    • Marked as answer by dsimoes1 Saturday, November 19, 2016 6:08 PM
    Saturday, November 19, 2016 6:08 PM
  • Hi,

    Thanks for your posting here and sharing the resolution in the forum as it would be helpful to anyone who encounters similar issues.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,

    Alvin Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 21, 2016 2:44 AM
    Moderator