none
Windows Server 2008 R2 RDP will not connect RRS feed

  • Question

  • I am having a issue with a 2008 R2 server RDP no longer working out of nowhere. I have tried all the things listed below any help with bee appreciated!

    Server will not allow any Remote desktop connection


    1. New Network Nic
    2. Reactivated license server
    3. Reinstall RDP Cals
    4. Run updates
    5. Reboot server ( This was fixing it for the few time it happened before Yesterday)
    6. Checked to make sure no Firewall rules were wrong
    7. Checked that port 3389 was open
    8. Ran a ping test to the Router IP, WAN, and PC IP
    9. Checked to make sure all RDP Services were running.

    Tuesday, July 9, 2019 1:37 PM

Answers

  • The issue seems to be related to Server 2008 R2. We only have two servers with this OS and both are experiencing the same thing. Swapping the WAN's fixes the issue. But the last time we swapped them for the one with the original Issue it worked for 4 months or so then I had to do it again. If I switch it back to the original WAN IP it still does not work. But if I set a 2016 server to that WAN IP everything is working fine. We have decided to build two new 2016 server to hopefully combat this issue. If anyone has anymore ideas please shoot away as Id like to prevent this issue for anyone else who cannot upgrade from 2008 R2.
    • Marked as answer by Alex Klinger Thursday, November 7, 2019 12:22 PM
    • Unmarked as answer by Alex Klinger Thursday, November 7, 2019 12:22 PM
    • Marked as answer by Alex Klinger Friday, November 8, 2019 12:22 PM
    Thursday, November 7, 2019 12:22 PM

All replies

  • enable remote logins under system>remote settings and name users/group?
    Tuesday, July 9, 2019 9:26 PM
  • hi,
    1 if you close NLA on SERVER 2008R2 ,will the problem persist ?like picture 1
    2 did you add remote access need users to "remote desktop users" local group on w2008r2 session host server like picture2 ?
    3 if you use mstsc \admin in command prompt on client computer ,will it can remote access problematical w2008r2?
    4 if you use different computers to remote access w2008r2,will the problem ?
    5 if you try to turn off firewall on both client and w2008r2 temporarily ,will the problem persist ?
    when the problem happen ,is there any related log about your issue ?
    on other RDS related server
    event viewer\windows logs\
    application
    security
    system
    Event Viewer – Applications and Services Logs – Microsoft – Windows – TerminalServices-****
    Event Viewer – Applications and Services Logs – Microsoft – Windows –remote desktop management service
    Event Viewer – Applications and Services Logs – Microsoft – Windows – RemoteDesktopServices-****
    Event Viewer – Applications and Services Logs – Microsoft – Windows-remoteapp and desktop connections
    Event Viewer – Applications and Services Logs – Microsoft – Windows-remoteapp and desktop connection management
    Microsoft-Windows-TerminalServices-Gateway/Operational

    on client computer
    event viewer\windows logs\
    application
    security
    system
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteDesktopServices-SessionServices_Operational
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteApp and Desktop Connections_Admin
    Event Viewer – Applications and Services Logs -RemoteApp and Desktop Connections_Operational
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteDesktopServices-RdpCoreTS_Admin
    Event Viewer – Applications and Services Logs -Microsoft-Windows-RemoteDesktopServices-RdpCoreTS_Operational
    Event Viewer – Applications and Services Logs -Microsoft-Windows-TerminalServices-*****
    Event Viewer – Applications and Services Logs – Microsoft – Windows-remoteapp and desktop connection management


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, July 10, 2019 9:14 AM
    Moderator
  • I have the exact same issue and have done everything listed above. Help
    Wednesday, July 10, 2019 11:09 PM
  • @BJBR 

    is there any related log about your issue  I mentioned above ?
    did your issue happen after you installed update patch ?


    Best Regards
    Andy YOU
    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, July 15, 2019 3:51 AM
    Moderator
  • I apologize for not responding before the fix we found was changing the WAN IP to a different one since we had multiple available. This fix only lasted till today. Could the router be getting hacked? Could the server itself have something one that Anti Virus is not finding. It seems odd that this issue was fixed then showed up again. Very frustrating.
    Friday, November 1, 2019 3:19 PM
  • The issue seems to be related to Server 2008 R2. We only have two servers with this OS and both are experiencing the same thing. Swapping the WAN's fixes the issue. But the last time we swapped them for the one with the original Issue it worked for 4 months or so then I had to do it again. If I switch it back to the original WAN IP it still does not work. But if I set a 2016 server to that WAN IP everything is working fine. We have decided to build two new 2016 server to hopefully combat this issue. If anyone has anymore ideas please shoot away as Id like to prevent this issue for anyone else who cannot upgrade from 2008 R2.
    • Marked as answer by Alex Klinger Thursday, November 7, 2019 12:22 PM
    • Unmarked as answer by Alex Klinger Thursday, November 7, 2019 12:22 PM
    • Marked as answer by Alex Klinger Friday, November 8, 2019 12:22 PM
    Thursday, November 7, 2019 12:22 PM