none
Win Server 2012 R2 Hyper-V UEFI boot from WDS failed. (Integrated mode only). RRS feed

  • Question

  • Hi, here is what's going on: Gen 2 UEFI boot works fine only in Standalone mode. But in AD integrated mode - PXE only. Any ideas? There's my settings and boot screen below:

    Boot Screen


    Vadim

    Tuesday, October 29, 2013 6:33 PM

Answers

  • I spoke with WDS team at Microsoft and they have found a solution.

    Apparently, there is an issue in WDS that causes it to use legacy NetBIOS name resolution instead of DNS to find a domain controller, and it impedes domain controller connectivity. The solution is simple - go to TCP advanced properties on WDS server, and on WINS tab disable NetBIOS over TCP/IP. This forces WDS to use the right name resolution, and everything works perfectly.


    Andy

    • Proposed as answer by Andy Ivanov Tuesday, January 14, 2014 8:28 PM
    • Marked as answer by treckamerica Friday, January 24, 2014 8:23 PM
    Tuesday, January 14, 2014 8:27 PM

All replies

  • Hi,


    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.


    Thanks for your understanding and support.


    Alex Lv

    Wednesday, November 6, 2013 2:45 AM
    Moderator
  • Hi ,

    If you create a Genv1 vm in AD integrated mode, does the vm boot from network?  If not, it sounds like a configuration problem with the WDS server when running in AD integrated mode.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, November 22, 2013 11:24 AM
  • Yes, Gen v1 works fine. the problem with v2 only.

    Vadim

    Sunday, December 1, 2013 11:09 PM
  • Hi Vadim, have you solved your problem? I am experiencing exactly the same issue with WDS in AD integrated mode and a Generation-2 VM. I noticed from WDS debug logging that it takes WAAY too long to talk to AD after WDS first receives a DHCP discover message. In my case it took full 25 seconds of talking back and forth between the WDS server and a domain controller before WDS finally sent its PXE REPLY message (DHCP server replied instantly.) At this point the client had already given up waiting for PXE response.

    Switching to standalone mode solves the problem because it eliminates the need to talk to DC, so the WDS internals move much faster. My domain works fine otherwise, so it must be a bug in WDS.


    Andy

    Tuesday, January 14, 2014 6:17 AM
  • I spoke with WDS team at Microsoft and they have found a solution.

    Apparently, there is an issue in WDS that causes it to use legacy NetBIOS name resolution instead of DNS to find a domain controller, and it impedes domain controller connectivity. The solution is simple - go to TCP advanced properties on WDS server, and on WINS tab disable NetBIOS over TCP/IP. This forces WDS to use the right name resolution, and everything works perfectly.


    Andy

    • Proposed as answer by Andy Ivanov Tuesday, January 14, 2014 8:28 PM
    • Marked as answer by treckamerica Friday, January 24, 2014 8:23 PM
    Tuesday, January 14, 2014 8:27 PM
  • Sorry for the delay. Just a long vacation. Thank you very much! It's a real solution.

    Vadim

    Friday, January 24, 2014 8:25 PM
  • Andy,

    Did Microsoft provide any KB to reference this solution?

    Thanks

    Friday, April 4, 2014 2:34 PM
  • Try this:

    https://social.technet.microsoft.com/Forums/sharepoint/en-US/0818a41c-20c7-41cf-a678-1f0c4ba299bb/pxeboot-with-hyperv-based-on-w2k12-r2-with-gen2vms?forum=winserverhyperv

    DCHP Option 67: Boot\x64\wdsmgfw.efi
    Tuesday, March 1, 2016 11:49 PM
  • Can we get this added as a note in the Technet Library.  I spent all day looking for compatibility notes on why my generation 1 machines could PXE boot but my generation 2 machines failed to get the boot img.  Wonder if this is fixed in 2016?
    • Edited by DSYSTEM Monday, June 13, 2016 7:22 PM
    Monday, June 13, 2016 7:19 PM
  • Thanks a lot, disable NetBIOS solution work fine.

    The opinion expressed by me is not an official position of Microsoft

    Tuesday, July 19, 2016 1:21 PM
  • It is still broke in 2016. Just had to do it in my fresh Lab build on a 2016 WDS server before my Gen 2 Hyper-V 2016 VM would PXE boot.
    Tuesday, December 27, 2016 6:36 PM
  • Just tried it today. Can't even get the thing to work. It is picking the IP up in DHCP then just failing. Tried the suggested which worked on 2012 but not 2016.
    Wednesday, January 4, 2017 10:40 PM
  • Hmm... in 2012 R2 (fully patched), this is not working.  Disabled NetBIOS (even rebooted) and no change.  Still PXE-E16:  No offer received.  I see others are still having this issue.  Any additional ideas?
    Monday, November 27, 2017 6:07 PM
  • Hmm... in 2012 R2 (fully patched), this is not working.  Disabled NetBIOS (even rebooted) and no change.  Still PXE-E16:  No offer received.  I see others are still having this issue.  Any additional ideas?
    So, for me, we had a block on UDP 4011 AND... the WDS service crashed sometime during my testing.  :)  So even though we fixed our ACL, we didn't realize the service had crashed, causing us additional angst.
    Monday, November 27, 2017 8:20 PM