locked
Unable to "See" NAS Drive in Windows Explorer after Win 10 Update - and I've tried the Known Fixes RRS feed

  • Question

  • Network setup is simple:  One desktop Ethernet connected to router.  One NAS drive Ethernet connected to router.  3 laptops wifi connected to network.  All computers are Win 10, with latest updates (1709).

    Once the Win update was applied, the NAS no longer appeared in the Windows Explorer of any of the laptop computers. It still appears in the desktop computer.

    I have tried enabling TCP/IP over NetBIOS under adapter settings, advanced, WINS settings.  I have tried enabling all SMB settings (checking all SMB boxes in Windows Features).  I have gone into all network profiles (public and private) and turned on file sharing and network discovery.

    Despite all of the above, the NAS still doesn't appear in Win Explorer.  I can map directly to folders in the drive using "map network drives," but that's a cumbersome workaround as there are a lot of folders on the NAS and I move among all of them.

    There are no updates available for my NAS drive firmware.

    Is there anything I can do to have the NAS detected on startup and appear under Network in windows explorer?


    • Edited by Bilbo87 Friday, April 27, 2018 2:47 PM
    Thursday, April 26, 2018 9:05 PM

All replies

  • "I have tried enabling all SMB settings."

    I wasn't sure what you meant by this, so I apologize if this is what you tried. Enable all options for "SMB 1.0/CIFS File Sharing Support" in Windows Features

    (Press start and type 'features'. Then select 'Turn Windows Features on or off'. Scroll down to enable the feature).

    Afterwards, restart your computer and you should see your NAS.

    *Extra Info, might not be needed for your situation*

    So, I had a similar, but opposite problem. I could no longer access SMB shares from an Android devices on the latest Windows 10 version. After turning on the "SMB 1.0/CIFS Server", the shares worked for Android, but could no longer be seen by my other Windows 10 PCs. According to this other thread (https://social.technet.microsoft.com/Forums/en-US/3101aeef-115f-4b6e-94c1-c3d0f575b116/master-browser-restored-to-windows-10?forum=win10itpronetworking), Microsoft removed the older 'Computer Browser service' when disabling SMB 1.0. After following the instructions in the link to set the 2 services as 'Automatic (delay)', I now have everything working as it did before the update.

    I apologize if this wasn't helpful or had been tried. I wasn't sure, so I thought I'd give it a shot to help you. Best of luck.

    Friday, April 27, 2018 4:45 AM
  • 1. run cmd as admin

    2. netsh winsock reset

    2. sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi

    3. sc.exe config mrxsmb20 start= disabled

    4. Enabling NetBIOS over TCP/IP

    5. Editing the Hosts file located in c:\windows\system32\drivers\etc, added the IP address of your NAS Drive and its name

    Restart and check again.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by palmerpcs Friday, January 25, 2019 1:18 PM
    Friday, April 27, 2018 7:17 AM
  • Thank you for your response Brent.

    Yes, what you outlined to turn on SMB1 is what I tried.  Sorry I wasn't clear on that.

    I took a look at the link you provided, but from that thread it's clear that that fix is just to make sure that windows devices appear in network neighborhood, and I'm just dealing with a non-windows NAS.

    I appreciate your inputs.



    • Edited by Bilbo87 Friday, April 27, 2018 3:26 PM
    Friday, April 27, 2018 2:42 PM
  • Thanks for your response, Teemo Tang

    Just so I'm clear, is Step 4 what I've already done, as in going in under adapter settings and then making this setting under "advanced" and "wins"?

    Also, do I do ALL of these steps, or 1-3, then 4, then 5?  In other words, could 4 or 5 work all by themselves, or is it part of one overall solution?


    • Edited by Bilbo87 Friday, April 27, 2018 2:47 PM
    Friday, April 27, 2018 2:45 PM
  • Thanks Momo

    Okay, it's showing TCP/IP NETBIOS as disabled, despite me enabling it in windows.  So that may well be it.

    Please forgive my ignorance here, but when you write "install your network driver by .....", what driver is it that I'm looking for?

    For example, when I look under the Ethernet adapter properties, I see "connect using" "Realtek PCIe GBE Family Controller."  Is that what I should look for to download?


    • Edited by Bilbo87 Friday, April 27, 2018 3:38 PM
    Friday, April 27, 2018 3:33 PM
  • Thank you.  One new piece of info:

    I went back into ipconfig, and realized that NetBIOS over TCPIP was enabled for the Ethernet and wifi adapters. It was turned off for something called "Tunnel Adapter Teredo Tunneling."

    So, that may not have been the problem after all. I just looked at the wrong part of the ipfconfig results before.

    Friday, April 27, 2018 3:50 PM
  • Momo

    Typing NET VIEW on the desktop connected to the router brings up a list showing that PC and the NAS drive.

    When I type it on the laptops, I get "this service has not been started."

    Tuesday, May 1, 2018 7:24 PM
  • Momo

    I'm assuming my NAS drive does have SMB1.  It was working fine before Microsoft disabled SMB1 with their update.  I'm just saying there isn't any new update for the NAS to give me SMB2 or 3.

    Wednesday, May 2, 2018 2:23 AM
  • Momo

    Mapping is just not a good option, as I'd have to map to each folder and I move among them a lot during the course of the day.

    As for firmware, I did check the manufacturer.  It's a Promise SmartStor N2300 NAS drive. Up until now it's been great.

    Saturday, May 5, 2018 2:48 PM
  • My apologies I haven't responded to this.  I had a family emergency that took me out of town for a long time.

    The Promise 2300 doesn't have an internal firewall.  Even if it did, that shouldn't change things, because I haven't changed the NAS settings at all since I installed it, and that's the only way the IPs could now be blocked. The IPs for the laptops are static.

    Tuesday, June 19, 2018 12:14 AM
  • Hi All, 

    I had the exact same problem. I fixed it by changing the network settings on the NAS device from SMB2 to SMB3. I have a windows Machine with Win 10 installed.

    Friday, August 10, 2018 4:05 AM
  • I performed the above steps as laid out and this worked like a charm!  I had previously tried everything else I could find with no avail until now.  Thanks Teemo Tang!
    Sunday, August 19, 2018 2:13 AM
  • Can you elaborate what are the steps again? I am unable to locate my NAS on Windows 10. Thanks.
    Sunday, August 26, 2018 3:01 PM
  • Thank you, thank you, thank you!

    Bought a new NAS when, I thought, my old one failed, but the new one wasn't working either.

    Appears that a Windows update switched this off.

    Friday, November 16, 2018 6:43 PM
  • I am still having problems with this.  Followed everything above except cab't get into NAS (WD Mybooklive) to change smb2 to smb3.

    The thing is, my daughter has a MAC book and she had no problems getting into the NAS and viewing files.

    This really is a nuisance ny Micrsoft and needs urgent attention

    Friday, January 18, 2019 3:27 AM
  • Doing step 5 was the fix I needed... I have tried everything else and had no luck. This could be the final step in the rest of the processes. Please give that a try, you should rename the original with a number (for backup purposes) you will need to save it to desktop ( you most likely will not be able to overwrite the original due to permissions or save it directly to the folder) as a TXT file then remove the .txt file extension and copy to c:/windows/system32/drivers/etc folder. ( please do the instructions as it states in the doc) Also, with any NAS Storage/Server setup you should make the IP address as static within the network so this would be a more “perminate” fix. This worked great for me.

    palmers pcs


    • Edited by palmerpcs Friday, January 25, 2019 1:31 PM
    Friday, January 25, 2019 1:26 PM
  • Have you ran windows update and ensured Windows 1809 is fully patched?

    https://support.microsoft.com/en-us/help/4469342

    Go into your scripts, ad accounts, gpo, etc. and make sure your drive mapping is correct. During my troubleshooting I found that attributes were not adding the semi-colon for the drive letter which was causing the issue ( "S" Vs "S:" )

    Friday, January 25, 2019 2:45 PM
  • This worked for me. Finally I can see my new NAS on Windows 10. No issues seeing it on Windows 7 before. What a relief, thank you.
    Monday, June 24, 2019 5:10 PM
  • After the latest Win10 update around 7/31/20 my NAS disappeared. No idea what SMB2 and 3 are or where to find them. I have Windows 10 Home ver 1909

    Monday, August 10, 2020 2:14 AM