none
AD FS Windows 2012 R2 exception occurred in service

    Question

  • I'm installing the first ADFS server in a new W2012 R2 farm

    The post-deployment configuration failed, during the installation the service doesn't start with the following event ID 7023:

    The Active Directory Federation Services service terminated with the following error:

    An exception occurred in the service when handling the control request.

    I have followed all best practice but nothing. I have used standard AD user and gMSA as service account for the ADFS service. 

    The certificate is selfsigned.

    Thank you in advance.

    Simone


    Simone

    • Changed type SimoneIT Thursday, March 13, 2014 4:36 PM
    Thursday, March 13, 2014 4:03 PM

Answers

  • Hi Simone,

    below the solution indicated by Microsoft:

    ADFS encounters issues with some languages. From the control panel, open the panel “Clock, Language and Region” and then “Region”. In the tab “Formats”, check that the format is “English (United States)” and in the tab “Administrative”, check that the language for non-Unicode programs is “English (United States)”.  If you have any other value, change them and click on “Copy settings” from the tab “Administrative”.  Select then the options “Welcome screen and system accounts” and “New user accounts” and validate.

    As last check, execute the Powershell command Get-WinSystemLocale. You must see “English (United States)”.

    Cheers! :)

    • Marked as answer by SimoneIT Friday, March 21, 2014 5:15 AM
    Tuesday, March 18, 2014 3:48 PM

All replies

  • Hi Simone,

    Here is a troubleshooting link below I suggest you refer to:

    Event ID 7023 — Service Stop Operations

    http://technet.microsoft.com/en-us/library/cc756318(WS.10).aspx

    According to this article, if Event ID 7011 or Event ID 7034 is logged in the event logs, please resolve Event ID 7011 or Event ID 7034 accordingly.

    If this issue couldn’t be solved after you followed this guide, please contact Microsoft support to get further assistance.

    http://support.microsoft.com/contactus/?ln=en-au

    Best Regards,

    Amy Wang

    Friday, March 14, 2014 6:47 AM
    Moderator
  • Hi Simone,

    below the solution indicated by Microsoft:

    ADFS encounters issues with some languages. From the control panel, open the panel “Clock, Language and Region” and then “Region”. In the tab “Formats”, check that the format is “English (United States)” and in the tab “Administrative”, check that the language for non-Unicode programs is “English (United States)”.  If you have any other value, change them and click on “Copy settings” from the tab “Administrative”.  Select then the options “Welcome screen and system accounts” and “New user accounts” and validate.

    As last check, execute the Powershell command Get-WinSystemLocale. You must see “English (United States)”.

    Cheers! :)

    • Marked as answer by SimoneIT Friday, March 21, 2014 5:15 AM
    Tuesday, March 18, 2014 3:48 PM
  • Hi all,

    Hoping to save you some time, I want to share one more step to check for.

    If you are using SQL as the configuration store you need to check the default language of the user connecting to the ADFS SQL configuration DB and be sure that is set to English.

    I cross-tryed reverting back to Italian as default language for the SQL user and the service did not start again.

    ADFS and SQL are both 2012 R2.


    AGEVIS

    • Proposed as answer by AGEVIS Monday, May 04, 2015 12:31 PM
    • Edited by AGEVIS Monday, May 04, 2015 12:39 PM
    Monday, May 04, 2015 12:30 PM
  • Hi all,

    I would like to add one more thing from my experience. I had run into the same problem, implemented all of the steps above and had no results. ADFS and SQL Servers are under Windows Server 2012 R2 Rus, SQL Server 2014 Rus, AD DC, AD CS

    I have opened SQL Server global settings, and set parameter "Default language for new user"=English. After that ADFS have installed, and started normally

    Hope, it will help to save you some time

    ---

    Kind regards,

    Andrey

    Sunday, September 04, 2016 9:15 AM