none
VSS NTDS Writer Failed

    Question

  • On one of my AD 2008 domain controllers the NTDS writer is in failed state.

    Writer name: 'NTDS'
       Writer Id: {b2014c9e-8711-4c5c-a5a9-3cf384484757}
       Writer Instance Id: {a0b40cc8-ded5-4497-b6dd-50f56de2dbe2}
       State: [11] Failed
       Last error: Non-retryable error

    This is Windows server 2008 STD 64 bit

    I'm trying to find out if there is a way to fix this WITHOUT rebooting my DC.  I tried restarting the VSS service.

    The cause of the failure was this.

    lsass (636) An attempt to write to the file "\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy9\Windows\NTDS\edb.log" at offset 6029824 (0x00000000005c0200) for 512 (0x00000200) bytes failed after 0 seconds with system error 19 (0x00000013): "The media is write protected. ".  The write operation will fail with error -1032 (0xfffffbf8).  If this error persists then the file may be damaged and may need to be restored from a previous backup.

    lsass (636) Unable to write to logfile \\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy9\Windows\NTDS\edb.log. Error -1032 (0xfffffbf8).

    Any help is greatly appreciated!

    Friday, August 10, 2012 5:42 PM

Answers

  • Yes actually I've found the answer.  You can run the following commands.

    "vssadmin list writers"

    You'll see some in error.

    Restart the Com and DCOM services.

    Restart the Volume Shadow Copy Service.

    Rerun the vssadmin command and check your writers.  If any are in error then you need to reboot, but I've found this works about 98% of the time.

    • Marked as answer by Statistic Friday, October 09, 2015 2:30 PM
    Saturday, February 09, 2013 8:01 PM

All replies

  • The primary solution for this type of issue is rebooting the server. So, please reboot the server and report back the result...

    Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Marked as answer by Statistic Saturday, August 18, 2012 12:05 AM
    • Unmarked as answer by Statistic Saturday, February 09, 2013 7:59 PM
    Saturday, August 11, 2012 9:23 PM
  • Yeah that's what the AppAssure guys told me.  I was looking for something a little less intrusive.  I can't go around rebooting domain controllers and affecting production systems without a maintenance window.

    Sunday, August 12, 2012 7:04 PM
  • How many DCs you have in your production network? If you have more than one, you can reboot the server without any effect to your network...

    Please VOTE as HELPFUL if the post helps you and remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, August 12, 2012 7:15 PM
  • Any updates for your issue?
    Friday, August 17, 2012 10:19 PM
    Moderator
  • Rebooting worked, but i'm not happy with it.

    • Proposed as answer by Pankul Jain Saturday, February 09, 2013 10:05 AM
    • Unproposed as answer by Pankul Jain Saturday, February 09, 2013 10:05 AM
    Saturday, August 18, 2012 12:05 AM
  • Same issue with us also , and reboot does not help, any other suggestions ??
    Saturday, February 09, 2013 10:06 AM
  • Yes actually I've found the answer.  You can run the following commands.

    "vssadmin list writers"

    You'll see some in error.

    Restart the Com and DCOM services.

    Restart the Volume Shadow Copy Service.

    Rerun the vssadmin command and check your writers.  If any are in error then you need to reboot, but I've found this works about 98% of the time.

    • Marked as answer by Statistic Friday, October 09, 2015 2:30 PM
    Saturday, February 09, 2013 8:01 PM
  • thank
    Monday, August 12, 2013 4:00 PM
  • Worked perfectly for me on SBS-2008.

    Thanks, IBTS !!

    Tuesday, March 11, 2014 1:58 PM
  • Hello! Which solution worked? I tried everything and nothing works so far...

    Andry

    Friday, September 11, 2015 10:48 AM
  • Restart the Com and DCOM services.

    Restart the Volume Shadow Copy Service.

    Rerun the vssadmin command and check your writers.  If any are in error then you need to reboot, but I've found this works about 98% of the time.

    Friday, September 11, 2015 2:47 PM
  • I restarted the domain controller  and I had a BSOD 0xc00002e2

    I was forced to restore the server with a valid full backup.

    After this, I had the same error again few days later.

    I simply restarted the COM+ and DCOM services as indicated below and it worked. No need to restart Windows, and no need to restore.
    Thursday, October 08, 2015 8:06 AM
  • Hi

    I have also VSS writers errors previously. In our servers mostly system writers, registry writers and WMI writers gets timed out. After digging a lot I found one solution to recycle the below services. Then server reboot will not be required and next backup will be successful.

    Application Host Helper Service
    COM+ Event System
    Cryptographic Services
    IIS Admin Service
    Volume Shadow Copy
    Windows Management Instrumentation

    Thanks


    **-CK-**

    • Proposed as answer by GuruCKg Friday, October 09, 2015 2:52 AM
    • Unproposed as answer by Statistic Friday, October 09, 2015 2:30 PM
    Thursday, October 08, 2015 8:30 AM
  • If you have repeated writer errors, and you're using a backups program that grabs and available writer to do it's work, you may sometimes need to go into that program and limit the available writers it can use.  This way the writer isn't in use by the backups program when it needs to be used for it's original purpose, or vice versa.  We've had this condition before with AppAssure and DFS.
    Thursday, October 08, 2015 4:08 PM
  • This solution, of cycling all the services worked for me.
    Saturday, October 17, 2015 4:44 AM
  • This same problem happened to me, and it turned out that the SQL server VSS writer was enabled, and set to auto start, and was started. I disabled and stopped the SQL VSS service, (as we use ShadowProtect to backup those DBs) and restarted the COM+ and Volume Shadow Copy services, and the problem was resolved, no reboot required!

     
    Wednesday, November 04, 2015 6:31 PM