Access Denied, Unable to connect (XP client to 2008 R2 Server)


  • Hey all, I've run into an issue in our environment that's been driving me crazy. Basically, XP SP3 machines are connecting to my new Windows 2008 R2 server and are randomly receiving "Access Denied, Unable to connect." errors. To make matters even worse, it seems to happen with random queues on the server, and not everyone experiences this (maybe 1 out of 10 people). For example, the user can connect to 1 out of the 5 print queues successfully. Furthermore, and this may not matter, but the print queue than has problems usually has no server or the FQDN in the Printer/Faxes view. Any ideas or direction would be appreciated!
    Wednesday, October 06, 2010 11:31 AM

All replies

  • I work with APIT and want to add some additional information on this issue.

    Someone passed along some event log messages from a machine that experienced the issue

    Event Type:   Error

    Event Source:           Print

    Event Category:       None

    Event ID:        22

    Date:               10/6/2010

    Time:              10:59:29 AM

    User:               NT AUTHORITY\SYSTEM

    Computer:     COMPUTERNAME


    Failed to ugrade printer settings for printer \\OURPRINTSERVER\PRINTERNAME,LocalOnly driver C:\WINDOWS\System32\spool\DRIVERS\W32X86\3\hpmdp6de.DLL error 5.


    For more information, see Help and Support Center at

    The same engineer who collected this information was successfully able to reproduce this problem on another Windows XP SP3 machine that previously didn't have this problem.

    These articles have some useful information specific to Event ID 22, but does not provide enough information on [root] cause (or possible root causes) or solutions:

    • Edited by JuliusPIV Wednesday, October 06, 2010 7:20 PM Updated Links.
    Wednesday, October 06, 2010 4:39 PM
  • When the machine has this issue, stop the spooler and delete all the BUD files in C:\WINDOWS\System32\spool\DRIVERS\W32X86\3

    start the spooler and have the user connect to then share again.

    I ASSUME the version of unidrv.dll is 7600.nnnn on the XP machine

    I am sure the user is not admin on the system so you can stop the spooler for them remotely with admin credentials

    sc \\XP machinename stop spooler

    then delete the binary version of the GPD file

    del \\XPmachinename\c$\windows\System32\spool\DRIVERS\W32X86\3\*.BUD

    sc \\XP machinename start spooler

    have the user attempt the connection again.

    Alan Morris Windows Printing Team
    Wednesday, October 06, 2010 10:05 PM
  • It appears to of worked.. Here is the process I followed:

    1) Deleted the printers

    2)Restart print spooler

    3)Delete drivers from Server Properties

    4)Delete .bud files

    5) Re-add printer from Active Directory


    Alan, do you have any insight as to why this would occur?
    Thursday, October 07, 2010 11:50 AM
  • I tried deleting the .bud files but it still didn't work -- but I found a workaround.

    The connection to the print server was part of a login batch file for Terminal Server 2003 users connecting to a 2008R2 print server with command     net use  \\printserver\ipc$. This connection frequently did not work despite showing a successful mapping.

    I suspected there might be a sequencing issue with other processes running at login, so I added a 2-second delay at the start of the batch file with the command    ping -n 2 [printserver].

    This fixed the issue. The connection to the print server is now stable.

    Tuesday, June 05, 2012 5:11 PM
  • Try this

    1. Goto run type "services.msc" without quotes.
    2. Now services gets open.
    3. Start the services "Workstation" and "Server", if it is stopped.
    4. Resolved :)

    Saturday, January 19, 2013 6:30 AM
  • Try this

    1. Goto run type "services.msc" without quotes.
    2. Now services gets open.
    3. Start the services "Workstation" and "Server", if it is stopped.
    4. Resolved :)

    Saturday, January 19, 2013 7:26 AM
  • Question:  Why does this happen?
    Friday, January 25, 2013 7:06 PM